E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Low Oil Temp---Any ideas?



Reply
 
Thread Tools Search this Thread
      10-24-2012, 04:53 PM   #1
smartys
Lieutenant
 
Drives: 07 e93 335i
Join Date: Dec 2007
Location: toronto, on

Posts: 595
iTrader: (1)

Low Oil Temp---Any ideas?

hey guys,

I've noticed something strange going on with my e93 the last several months. for the first 3 years i had this car, the oil temp gauge would always get to "operating temp" within a few minutes, get to between 240-250 (usually 245) and just stay there. about a year ago, I noticed that the oil temp gauge started taking FOREVER to move at all, and when it did, after 15-20 minutes or so, it would be around 180-190F range. Soon after that, i got a limp mode under load, and eventually found out to be an engine coil, which was replaced. Problem solved. I parked the car over the last winter, and in the spring after starting to drive it again, same issue. Oil temp not reaching the operating temp as it did for the first few years. Over the summer, I got another limp mode under load, which disappeared after I shut the car off and on. I took it to the dealer, they ran tonnes of diagnostics, including the HPFP, and they can't find anything, and they just told me "The oil cooler is working super-efficiently". What the hell kind of explanation is that? I know there's something wrong with my car, but I don't know exactly what. Performance seems to be fine, and I even did a carbon blast to ensure the injectors are clean......

Any ideas?

Thanks!
__________________
SG | Coral Red | 6MT | Sports Pkg | CA | PDC | KWV2 | Dinan Stage II | Morr VS8 | Aero Lip |
smartys is offline  
0
Reply With Quote
      10-26-2012, 02:12 PM   #2
e90pilot
Freight Dawg
 
e90pilot's Avatar
 
Drives: E90 325i
Join Date: Jul 2005
Location: Oakland, CA

Posts: 2,090
iTrader: (3)

Maybe your water thermostat is stuck open. It would cause the entire car to run cool. Might not register a code or you won't find the code if you aren't looking for it.
__________________
--Marcelo
'06 Arctic Metallic 325i | Sport Package | 6MT | Dinan Stage III suspension | Dinan exhaust | 330i manifold swap! Click here! | Active Autowerke tune | 135i Brake Calipers | Deiselboost caliper brackets | E46 M3 front rotors
e90pilot is offline   United_States
0
Reply With Quote
      10-26-2012, 02:32 PM   #3
smartys
Lieutenant
 
Drives: 07 e93 335i
Join Date: Dec 2007
Location: toronto, on

Posts: 595
iTrader: (1)

thanks for the tip....im having an oil change done next week, will have the dealer check it out.....i also read on here after searching the forums, that some people with slightly similar issues (albeit more severe and performance issues as well) had a failing water pump altogether......anyone think that could be the cause?

anyhow, thanks again
__________________
SG | Coral Red | 6MT | Sports Pkg | CA | PDC | KWV2 | Dinan Stage II | Morr VS8 | Aero Lip |
smartys is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:04 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST