E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Problems with boost solenoid?



Reply
 
Thread Tools Search this Thread
      11-03-2012, 10:30 PM   #1
D1swoop
Enlisted Member
1

 
Drives: e92
Join Date: May 2012
Location: Bay Area


Posts: 34
iTrader: (0)

Problems with boost solenoid?

Hey guys
Sorry, I can't search because I am on the e90 app. I'm hoping to get some good feed back from those who are really knowledgable about our cars.

I just had my inline fuel pump installed to help my flex fuel kit. I was cruising on the freeway doing about 75-80mph when all of a sudden the car just shut down. The engine just cut off and I had to pull over the side of the freeway. I tries restarting but the engine would not turn over.
I had it towed back to FFTec and it turned out that the ignition fuse blew out.
Does anyone know why this would happen? After getting fuse replaced, the car still does not run correctly. It seems the boost kicks in sporadically and is not consistent. I am taking it back to FFTec on Monday, but was hoping for some in site from fellow members.
Thanks for any feedback
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 05:41 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST