E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Help... Loud clicking noise when turning



Reply
 
Thread Tools Search this Thread
      12-23-2012, 01:34 PM   #23
BMWM.D.
Stupid Idiot
BMWM.D.'s Avatar
42
Rep
773
Posts

Drives: E90 335i & C6 Grand Sport
Join Date: May 2009
Location: Santa Barbara

iTrader: (1)

Quote:
Originally Posted by lenhartjames View Post
Any updates on this? I have the same issue. I have examined the strut guide mounts and they appear to be perfectly fine. No major wear. I have a 08 328i with 49k on it.

I even greased the bearings to see if that would help. I have not examined the control arms first hand, but was told by a mechanic that all the bushings look fine.

Lastly, I am beginning to think this is related to the steering and not the suspension. Any ideas on what would make a click sound while turning to the left from a complete stop?
Quote:
Originally Posted by lenhartjames View Post
This goes back to the suspension being a possible issue, but how likely is it that this part would be the problem?:

http://www.oembimmerparts.com/produc...933-934e9x.htm

I've seen the tension strut bushings make noise on some BMW's, even when they don't show any wear. The ones I've seen were due to something inside the bushing flexing and making a "tick" sound.

As for that sway bar link, the ones I've seen fail will cause a rattle sound while driving down a slightly bumpy road. Should be pretty easy to grab them and check for excessive play. Big difference between a bad one and a normal one.
__________________
Appreciate 0
      12-23-2012, 02:12 PM   #24
lenhartjames
New Member
lenhartjames's Avatar
0
Rep
19
Posts

Drives: 2008 328i Arctic Silver/Tan
Join Date: Dec 2012
Location: Florida

iTrader: (0)

Quote:
Originally Posted by BMWM.D. View Post
I've seen the tension strut bushings make noise on some BMW's, even when they don't show any wear. The ones I've seen were due to something inside the bushing flexing and making a "tick" sound.

As for that sway bar link, the ones I've seen fail will cause a rattle sound while driving down a slightly bumpy road. Should be pretty easy to grab them and check for excessive play. Big difference between a bad one and a normal one.
thanks for the tip. Gonna check it out later today. See what's loose and what doesnt look normal.
Appreciate 0
      12-23-2012, 06:55 PM   #25
lenhartjames
New Member
lenhartjames's Avatar
0
Rep
19
Posts

Drives: 2008 328i Arctic Silver/Tan
Join Date: Dec 2012
Location: Florida

iTrader: (0)

I took the shield off the bottom today and checked everything for signs of wear on the control arms, end links, strut tension arm, etc...

There was minor wear on the lower control arms but nothing to cause a click sound.

My problem seems to be one of the following:

Loose bolts on the sway bar. Tightened them down.

Or an old screw driver that was sitting in the side of the shield. I really think it was the screw driver. I've only had the car for 3 weeks. So I was unaware. Whoever did work last must have forgot their tools O_o

I'll post back if the sound comes back. But my suggestion is to check lose bolts if your bushings appear to be normal.
Appreciate 0
      01-11-2013, 08:51 AM   #26
MJ777LR
Private First Class
United_States
14
Rep
133
Posts

Drives: 2007 BMW328i
Join Date: Jan 2012
Location: Kansas

iTrader: (1)

Wow, I haven't checked back here in a while. For those interested, the hunch my indy and I had turned out to be right. It was a couple of loose bolts somewhere on the front end. They retorqued every bolt to spec, and that fixed the noise I was hearing. In fact, the car seemed 'tighter' after that. So, yes, lenhartjames is correct above in suggesting to check for loose bolts as a possible cause of the suspension noises you might be having, assuming all control arms and bushings, etc, are in good shape or have just been replaced.
Appreciate 0
      04-11-2013, 03:20 PM   #27
casmako
Private First Class
2
Rep
122
Posts

Drives: e92 335
Join Date: Feb 2013
Location: Dana Point

iTrader: (1)

Garage List
2009 BMW 335i  [5.00]
Thank you for coming back to post that.

I had mine serviced and they cleared it...still happening!
Appreciate 0
      12-01-2015, 10:01 PM   #28
gunnerxq
Lieutenant Colonel
gunnerxq's Avatar
United_States
88
Rep
1,512
Posts

Drives: e90 "325i"
Join Date: Sep 2010
Location: Staten Island and Albany

iTrader: (0)

Quote:
Originally Posted by Chefcg1 View Post
I have the same issue, but my click only happens when backing up and turning to the right while backing. I did have the alignment done recently.
Did you ever find out the problem? Mine does that backing out of my driveway turining to the right. There is a slight ledge and it's always the front passenger wheel that makes the noise. But only backing out with the wheel turned.
Appreciate 0
      02-19-2017, 04:54 PM   #29
Bmwboy219
Registered
1
Rep
3
Posts

Drives: E92 335 I
Join Date: Jan 2017
Location: Los Angeles

iTrader: (0)

I am having the same issue 2012 335i n55 I had wear on bushing struts and control arm had all that replaced but I am still getting the issue I got the car last month smooth ride but that rattle is Fxckn driving me crazy at the red lights same when reversing and turning my wheel
Appreciate 0
      11-28-2017, 11:07 PM   #30
robygomez
Private
Mexico
3
Rep
56
Posts

Drives: 325i, 2010, E90
Join Date: Nov 2016
Location: Mexico City

iTrader: (0)

Noise when turning steering wheel in cold weather.

Quote:
Originally Posted by Bmwboy219 View Post
I am having the same issue 2012 335i n55 I had wear on bushing struts and control arm had all that replaced but I am still getting the issue I got the car last month smooth ride but that rattle is Fxckn driving me crazy at the red lights same when reversing and turning my wheel
My problem happens only in cold weather when temperature is below 53 F, but when the car heats up it totally disappears, let my add a video so it is more clear.
Will appreciate any input in the matter

https://www.youtube.com/watch?v=n7JuCCTDzww
Appreciate 0
      11-29-2017, 07:25 PM   #31
ritzzzzzwik
Captain
ritzzzzzwik's Avatar
109
Rep
658
Posts

Drives: 2007 335i MT
Join Date: Oct 2014
Location: NOVA

iTrader: (0)

Quote:
Originally Posted by robygomez View Post
My problem happens only in cold weather when temperature is below 53 F, but when the car heats up it totally disappears, let my add a video so it is more clear.
Will appreciate any input in the matter

https://www.youtube.com/watch?v=n7JuCCTDzww
Strut hat. Quick way to test- pop the plastic caps on your strut tower, and spray a healthy dose on silicone/WD40. If the noise disappears its most likely that.
9/10 times its strut tower hat. Its rubber and it degrades over time and heat/cold cycles.
__________________
2007 335i E92 MT | MFactory LSD | MHD/Wedge Tuned 93Oct | Stg2 lpfp BoostConcepts | VRSF DPs | VRSF 5" SteppedFMIC | DCI | VRSF CP | BMW SSK | Billstein PSS Coilovers | M3 Control Arms | Whiteline Rear SF Inserts | M219s + PSS | PE Mod
Appreciate 0
      11-30-2017, 08:15 AM   #32
robygomez
Private
Mexico
3
Rep
56
Posts

Drives: 325i, 2010, E90
Join Date: Nov 2016
Location: Mexico City

iTrader: (0)

Quote:
Originally Posted by ritzzzzzwik View Post
Strut hat. Quick way to test- pop the plastic caps on your strut tower, and spray a healthy dose on silicone/WD40. If the noise disappears its most likely that.
9/10 times its strut tower hat. Its rubber and it degrades over time and heat/cold cycles.
Thank you for your quick feedback,

If by strut tower hat you mean shock absorber mount, it's important to let you know that they have been replaced recently along with the struts. Please excuse my english but it's not my native language.

I'll take it to the shop and keep you posted.

GREETINGS.
Appreciate 0
      11-30-2017, 02:30 PM   #33
ritzzzzzwik
Captain
ritzzzzzwik's Avatar
109
Rep
658
Posts

Drives: 2007 335i MT
Join Date: Oct 2014
Location: NOVA

iTrader: (0)

Quote:
Originally Posted by robygomez View Post
Thank you for your quick feedback,

If by strut tower hat you mean shock absorber mount, it's important to let you know that they have been replaced recently along with the struts. Please excuse my english but it's not my native language.

I'll take it to the shop and keep you posted.

GREETINGS.
hmm, try this. I did have this issue one winter. I sprayed some silicone and its been good since
https://www.youtube.com/watch?v=gRH8caDH_uE
__________________
2007 335i E92 MT | MFactory LSD | MHD/Wedge Tuned 93Oct | Stg2 lpfp BoostConcepts | VRSF DPs | VRSF 5" SteppedFMIC | DCI | VRSF CP | BMW SSK | Billstein PSS Coilovers | M3 Control Arms | Whiteline Rear SF Inserts | M219s + PSS | PE Mod
Appreciate 0
      11-30-2017, 04:39 PM   #34
robygomez
Private
Mexico
3
Rep
56
Posts

Drives: 325i, 2010, E90
Join Date: Nov 2016
Location: Mexico City

iTrader: (0)

Quote:
Originally Posted by ritzzzzzwik View Post
hmm, try this. I did have this issue one winter. I sprayed some silicone and its been good since
https://www.youtube.com/watch?v=gRH8caDH_uE
Thank you ritzz,
Ive already done that last year, I have that video in my Youtube favorite list, unfortunately that didnt fix my problem, but thank you anyway.
Appreciate 0
      11-30-2017, 05:56 PM   #35
Faredo
Second Lieutenant
Faredo's Avatar
85
Rep
225
Posts

Drives: 335i
Join Date: Sep 2016
Location: Arkansas

iTrader: (0)

Have any of you "same problem" guys tried jacking your car up and looking? this can be extremely dangerous to just back burner as random noise. Last time i heard this, i jacked up the from end and started tugging on the wheel in question. Turned out my steering endlink was loose and nearly fell out. imagine no steering at 70+mph.
get off your ass and JUST LOOK!
__________________
Stock Turbos, MHD stage 2 93 oct, VRSF Downpipes, VRSF Relocated inlets, CTS Turbo 7" Intercooler.
Appreciate 0
      12-01-2017, 10:31 AM   #36
robygomez
Private
Mexico
3
Rep
56
Posts

Drives: 325i, 2010, E90
Join Date: Nov 2016
Location: Mexico City

iTrader: (0)

Quote:
Originally Posted by Faredo View Post
Have any of you "same problem" guys tried jacking your car up and looking? this can be extremely dangerous to just back burner as random noise. Last time i heard this, i jacked up the from end and started tugging on the wheel in question. Turned out my steering endlink was loose and nearly fell out. imagine no steering at 70+mph.
get off your ass and JUST LOOK!
Faredo,

Thank you for the strong advice, I totally agree with you but I have already taken it twice to 2 different shops and they have told me that the suspenssion and the steering looks ok, the problem is that the noise happens only when its cold so I had to wait for the right weather to record the noise and send it to the shop.

So today I have an appointment and the car is going to stay all night at the shop so they can check it early in the morning when its cold.

GREETINGS
Appreciate 1
      12-02-2017, 12:57 PM   #37
robygomez
Private
Mexico
3
Rep
56
Posts

Drives: 325i, 2010, E90
Join Date: Nov 2016
Location: Mexico City

iTrader: (0)

Unhappy Veredic so far

So I took my car for the third time to the shop and they ratify that it has no suspenssion issues the problem might be related with the hydraulic steering box but they don't service that part.

So gotta find a shop that would be an specialist on that part, so problem not solve yet.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:47 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST