E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > Help... Loud clicking noise when turning



Reply
 
Thread Tools Search this Thread
      12-23-2012, 12:34 PM   #23
BMWM.D.
Stupid Idiot
BMWM.D.'s Avatar
8
Rep
687
Posts

 
Drives: E90 335i & C6 Grand Sport
Join Date: May 2009
Location: Santa Barbara

iTrader: (1)

Quote:
Originally Posted by lenhartjames View Post
Any updates on this? I have the same issue. I have examined the strut guide mounts and they appear to be perfectly fine. No major wear. I have a 08 328i with 49k on it.

I even greased the bearings to see if that would help. I have not examined the control arms first hand, but was told by a mechanic that all the bushings look fine.

Lastly, I am beginning to think this is related to the steering and not the suspension. Any ideas on what would make a click sound while turning to the left from a complete stop?
Quote:
Originally Posted by lenhartjames View Post
This goes back to the suspension being a possible issue, but how likely is it that this part would be the problem?:

http://www.oembimmerparts.com/produc...933-934e9x.htm

I've seen the tension strut bushings make noise on some BMW's, even when they don't show any wear. The ones I've seen were due to something inside the bushing flexing and making a "tick" sound.

As for that sway bar link, the ones I've seen fail will cause a rattle sound while driving down a slightly bumpy road. Should be pretty easy to grab them and check for excessive play. Big difference between a bad one and a normal one.
__________________
Appreciate 0
      12-23-2012, 01:12 PM   #24
lenhartjames
New Member
lenhartjames's Avatar
0
Rep
19
Posts

 
Drives: 2008 328i Arctic Silver/Tan
Join Date: Dec 2012
Location: Florida

iTrader: (0)

Quote:
Originally Posted by BMWM.D. View Post
I've seen the tension strut bushings make noise on some BMW's, even when they don't show any wear. The ones I've seen were due to something inside the bushing flexing and making a "tick" sound.

As for that sway bar link, the ones I've seen fail will cause a rattle sound while driving down a slightly bumpy road. Should be pretty easy to grab them and check for excessive play. Big difference between a bad one and a normal one.
thanks for the tip. Gonna check it out later today. See what's loose and what doesnt look normal.
Appreciate 0
      12-23-2012, 05:55 PM   #25
lenhartjames
New Member
lenhartjames's Avatar
0
Rep
19
Posts

 
Drives: 2008 328i Arctic Silver/Tan
Join Date: Dec 2012
Location: Florida

iTrader: (0)

I took the shield off the bottom today and checked everything for signs of wear on the control arms, end links, strut tension arm, etc...

There was minor wear on the lower control arms but nothing to cause a click sound.

My problem seems to be one of the following:

Loose bolts on the sway bar. Tightened them down.

Or an old screw driver that was sitting in the side of the shield. I really think it was the screw driver. I've only had the car for 3 weeks. So I was unaware. Whoever did work last must have forgot their tools O_o

I'll post back if the sound comes back. But my suggestion is to check lose bolts if your bushings appear to be normal.
Appreciate 0
      01-11-2013, 07:51 AM   #26
MJ777LR
Private First Class
United_States
4
Rep
132
Posts

 
Drives: 2007 BMW328i
Join Date: Jan 2012
Location: Kansas

iTrader: (1)

Wow, I haven't checked back here in a while. For those interested, the hunch my indy and I had turned out to be right. It was a couple of loose bolts somewhere on the front end. They retorqued every bolt to spec, and that fixed the noise I was hearing. In fact, the car seemed 'tighter' after that. So, yes, lenhartjames is correct above in suggesting to check for loose bolts as a possible cause of the suspension noises you might be having, assuming all control arms and bushings, etc, are in good shape or have just been replaced.
Appreciate 0
      04-11-2013, 02:20 PM   #27
casmako
Private First Class
1
Rep
116
Posts

 
Drives: e92 335
Join Date: Feb 2013
Location: Dana Point

iTrader: (1)

Garage List
2009 BMW 335i  [5.00]
Thank you for coming back to post that.

I had mine serviced and they cleared it...still happening!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:20 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST