E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Mechanical Maintenance: Break-in / Oil & Fluids / Servicing / Warranty > Need some help! 335 broke down after tune up at dealership



Reply
 
Thread Tools Search this Thread
      11-02-2012, 11:35 PM   #1
j. cooper
Teufel Hunden
 
j. cooper's Avatar
 
Drives: 2007 BMW 335i
Join Date: Jan 2012
Location: 29 Palms, CA

Posts: 61
iTrader: (0)

Send a message via Skype™ to j. cooper
Need some help! 335 broke down after tune up at dealership

Alright, I will keep this short and to the point...

Car: 2007 335i Sedan
Mods: 5" ETS FMIC, HKS SSQV BOV, Injen DCI, 3" AR Design Catless DPs, Exhaust, JB4.

The rear left window regulator went out so I took it in to have them replace it. I walked into the dealership and the guy told me I couldn't take it off the lot until they replaced a bunch of "recalled parts" on the car. I explained to him that the HPFP had already been replaced and the ecu had the update last year. He said they wanted to do it all again (for reasons that made no sense to me). Ok, fine... so they gave me a rental for the week and I went to get it earlier this afternoon (they also did an oil change). On the way home... it all of a sudden - lost boost, wouldn't shift, wouldn't accelerate, gave me a small jolt/hesitation and sounded like something snapped, and then the engine light came on. I immediately pulled over and shut off the car ASAP. I proceeded to pop the hood and see what the deal was -> no leaking fluids, but it smelt like burning rubber and burning radiator fluid. The tow guy finally showed up, still no leaking fluids, but still smelt like crap. It started back up fine when I had to put it in neutral for the tow guy, but something was definitely not right.

Any ideas would be really helpful. The dealership opens back up in the AM and the tow guy is taking it straight there.

Thanks a bunch!

Jeremy

Last edited by j. cooper; 11-03-2012 at 07:17 PM.
j. cooper is offline  
0
Reply With Quote
      11-03-2012, 01:17 AM   #2
j. cooper
Teufel Hunden
 
j. cooper's Avatar
 
Drives: 2007 BMW 335i
Join Date: Jan 2012
Location: 29 Palms, CA

Posts: 61
iTrader: (0)

Send a message via Skype™ to j. cooper
Ohh forgot to add, the engine temps were normal.
j. cooper is offline  
0
Reply With Quote
      11-03-2012, 07:00 PM   #3
j. cooper
Teufel Hunden
 
j. cooper's Avatar
 
Drives: 2007 BMW 335i
Join Date: Jan 2012
Location: 29 Palms, CA

Posts: 61
iTrader: (0)

Send a message via Skype™ to j. cooper
The dealership said they can't get it in until Monday.

Any ideas?
j. cooper is offline  
0
Reply With Quote
      11-03-2012, 07:16 PM   #4
Slow_335i
Daily Driven!
 
Slow_335i's Avatar
 
Drives: BMW 335i
Join Date: Jun 2011
Location: Peoria IL

Posts: 2,489
iTrader: (11)

Garage List
2008 BMW 335I  [3.32]
Bad fuel? Did they even put oil in it? what did they all replace? failed install on the fuel pump if they replaced it again?
__________________
Slow_335i is offline   United_States
0
Reply With Quote
      11-03-2012, 10:34 PM   #5
j. cooper
Teufel Hunden
 
j. cooper's Avatar
 
Drives: 2007 BMW 335i
Join Date: Jan 2012
Location: 29 Palms, CA

Posts: 61
iTrader: (0)

Send a message via Skype™ to j. cooper
I'm hoping that it was the "new" pump they put in. As for them replacing the already replaced pump, is beyond me. I've heard horror stories of dealerships not putting oil in, and I didn't check. I was more concerned about getting back to work unfortunately and didn't even think about it.

Would a failing pump explain it shifting to third, then not shifting anymore?

They replaced the pump, and did another reflash "ecu upgrade" on it (the service desks exact words).
j. cooper is offline  
0
Reply With Quote
      11-05-2012, 12:15 AM   #6
j. cooper
Teufel Hunden
 
j. cooper's Avatar
 
Drives: 2007 BMW 335i
Join Date: Jan 2012
Location: 29 Palms, CA

Posts: 61
iTrader: (0)

Send a message via Skype™ to j. cooper
I just hope whatever the dealership did to it, they don't try and cover it up. The car ran perfectly fine until they touched it.
j. cooper is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:42 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST