E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Vargas Stage I Turbo First Impressions



Reply
 
Thread Tools Search this Thread
      09-29-2012, 09:39 PM   #1
sahyoun
Lieutenant
 
sahyoun's Avatar
 
Drives: E92 jb4 e85 335i
Join Date: Jul 2010
Location: Bay Area, California

Posts: 504
iTrader: (0)

Vargas Stage I Turbo First Impressions

deleted

Last edited by sahyoun; 11-26-2012 at 02:46 PM.
sahyoun is offline   Lebanon
0
Reply With Quote
      09-29-2012, 11:07 PM   #2
sammy_0559
Lieutenant Colonel
 
sammy_0559's Avatar
 
Drives: e93 2008 Montego Metallic 335i
Join Date: Apr 2011
Location: FortWorth, Texas

Posts: 1,944
iTrader: (0)

Garage List
2008 E93 335i  [1.83]
nice

stage 2's :3

anyways. u might wanna take jb4 out of ur sig
sammy_0559 is offline   United_States
0
Reply With Quote
      09-30-2012, 01:41 AM   #3
idrift4wd
Brigadier General
 
Drives: Three Hundred and Thirty Five
Join Date: Jul 2010
Location: Yonkers NY

Posts: 3,316
iTrader: (0)

Garage List
2007 BMW  [3.50]
how much for upgrade? and is it just like RB? send in turbo and wait for replacement? Price?

looking forward to dyno numbers
idrift4wd is offline  
0
Reply With Quote
      09-30-2012, 01:51 AM   #4
Simple3
Lieutenant
 
Drives: e90
Join Date: Jul 2011
Location: USA

Posts: 493
iTrader: (7)

Mods please move this to the n54 section where it belongs!!! Looking forward to dyno results!!!
Simple3 is offline  
0
Reply With Quote
      09-30-2012, 04:29 AM   #5
BMW_Belgier
Lieutenant Colonel
 
BMW_Belgier's Avatar
 
Drives: E92 335xi n55
Join Date: May 2012
Location: Switzerland

Posts: 1,522
iTrader: (0)

Quote:
Originally Posted by idrift4wd View Post
how much for upgrade? and is it just like RB? send in turbo and wait for replacement? Price?

looking forward to dyno numbers
+1

How was the install? Any probs?
__________________
BEFORE: 130i N52 (2006-2011)
NOW: 335xi N55 (2011- )
BMW_Belgier is offline   Switzerland
0
Reply With Quote
      10-02-2012, 03:44 PM   #6
shaginwagon13
Charted Accountant
 
shaginwagon13's Avatar
 
Drives: BMW 335i Coupe
Join Date: Apr 2012
Location: Toronto

Posts: 904
iTrader: (4)

I am gonna get these turbo's as well when my OEM ones go. Please keep us updated with the dyno results.
shaginwagon13 is offline   Canada
0
Reply With Quote
      10-02-2012, 03:59 PM   #7
type rrr
Second Lieutenant
 
type rrr's Avatar
 
Drives: 335i coupe
Join Date: Apr 2012
Location: montreal canada

Posts: 232
iTrader: (0)

great new's !!!!!!!!!!!
__________________
2007 335i coupe AT-- I80AS--FBO -stock turbos--COBB v402 beta stage 2 + ATR-- NITTO'S 275-40-17 NT05R --- 12.025 @ 120 mph -- full weight
type rrr is offline  
0
Reply With Quote
      10-02-2012, 09:55 PM   #8
sahyoun
Lieutenant
 
sahyoun's Avatar
 
Drives: E92 jb4 e85 335i
Join Date: Jul 2010
Location: Bay Area, California

Posts: 504
iTrader: (0)

So basically my car was boosting fine then all of the sudden no boost and half engine light, apparantly the rear turbo intake hose came off and a foreign object went in and messed up the compressor wheel and put it out of balance
sahyoun is offline   Lebanon
0
Reply With Quote
      10-02-2012, 09:57 PM   #9
shaginwagon13
Charted Accountant
 
shaginwagon13's Avatar
 
Drives: BMW 335i Coupe
Join Date: Apr 2012
Location: Toronto

Posts: 904
iTrader: (4)

Quote:
Originally Posted by sahyoun View Post
So basically my car was boosting fine then all of the sudden no boost and half engine light, apparantly the rear turbo intake hose came off and a foreign object went in and messed up the compressor wheel and put it out of balance
Uh ohhhhhh.

Would that be a warranty issue with Vargas or with the mechanic who installed the turbos and the lines?
shaginwagon13 is offline   Canada
0
Reply With Quote
      10-02-2012, 10:02 PM   #10
mave198
Lieutenant
 
mave198's Avatar
 
Drives: 2007 BMW 335i
Join Date: Jul 2010
Location: Brooklyn NYC

Posts: 440
iTrader: (2)

I think OP was the mechanic.

Hopefully its a quick fix, alot of people are anxious to see these turbos on the dyno.
mave198 is offline  
0
Reply With Quote
      10-02-2012, 10:08 PM   #11
shaginwagon13
Charted Accountant
 
shaginwagon13's Avatar
 
Drives: BMW 335i Coupe
Join Date: Apr 2012
Location: Toronto

Posts: 904
iTrader: (4)

Quote:
Originally Posted by mave198 View Post
I think OP was the mechanic.

Hopefully its a quick fix, alot of people are anxious to see these turbos on the dyno.
Quote:
Originally Posted by sahyoun View Post
...a foreign object went in and messed up the compressor wheel and put it out of balance
That sounds like it has to go back to Vargas for some repairs. Get these bad-boys fixed and get on a dyno cause I wanna go with Vargas for my upgrade as well.
shaginwagon13 is offline   Canada
0
Reply With Quote
      10-03-2012, 11:13 AM   #12
sahyoun
Lieutenant
 
sahyoun's Avatar
 
Drives: E92 jb4 e85 335i
Join Date: Jul 2010
Location: Bay Area, California

Posts: 504
iTrader: (0)

I installed them first on jack stands in my driveway but vargas reinstalled them properly but i guess its a common problem on rbs and he told me there was a bracket missing that holds the rear intake tube to the engine. So the engine was free to move basically. And yeah the car should be up and running today and possibly dyno'd tonight or tomorrow
sahyoun is offline   Lebanon
0
Reply With Quote
      10-03-2012, 11:23 AM   #13
Rob@RBTurbo
BimmerPost Supporting Vendor

 
Rob@RBTurbo's Avatar
 
Drives: 335I
Join Date: Jan 2008
Location: St. Louis, MO

Posts: 1,054
iTrader: (4)

I have had one customer (dzenno) have this happen a year or so ago on his RBs. Last week a newly installed set it seems suffered the same fate. If ANY turbo eats something, its game over. Sometimes it is carelessness, installation or platform learning curve, or just bad luck. Either way it's a real bum deal.

But least youll be back up and running quickly!

Rob
Rob@RBTurbo is offline  
0
Reply With Quote
      10-03-2012, 12:05 PM   #14
Joshboody
Lieutenant Colonel
 
Drives: pickemuptruck
Join Date: Jul 2009
Location: Phoenix, AZ

Posts: 1,708
iTrader: (7)

I'm sure the issue stems from install and how rough someone is with the intake tube pressing on the bracket. Can this bracket be removed (without too much trouble)with the various install options for turbos? Dropping the subframe probably no prob, but lifting the engine, maybe not.

You can reach your hand down from the top to check it.
Joshboody is offline  
0
Reply With Quote
      10-03-2012, 12:23 PM   #15
Evil///M
Professional Hitman
 
Drives: 335i Street. E36 M3 Track.
Join Date: Feb 2011
Location: 719/856

Posts: 506
iTrader: (6)

Garage List
2007 335i  [4.25]
I wonder how many stage 1's he has available. I'm seriously thinking about it...
__________________
Evil///M is offline   United_States
0
Reply With Quote
      10-03-2012, 12:37 PM   #16
enrita
Major General
 
enrita's Avatar
 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

Posts: 7,323
iTrader: (0)

if you do it than do it right means upgrade compressor and most important TURBINE
__________________
07 335i AT - TD St.2 Turbos - COBB (Custom Cobb mapping by http://www.protuningfreaks.com/) - JB4G5 ISO - Okada Coils - NGK 5992 Plugs - E85 Walbro - Injen Intake - Helix IC - Snow Stg. 3 - Stett CP - AR DPs - midpipes 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - Level 10 AT upgrade - Alpina AT Flash
enrita is offline   Sweden
0
Reply With Quote
      10-03-2012, 12:56 PM   #17
jippii ensio
Major
 
Drives: 335i
Join Date: Feb 2009
Location: On the road

Posts: 1,190
iTrader: (0)

Quote:
Originally Posted by sahyoun View Post
I installed them first on jack stands in my driveway but vargas reinstalled them properly but i guess its a common problem on rbs and he told me there was a bracket missing that holds the rear intake tube to the engine. So the engine was free to move basically. And yeah the car should be up and running today and possibly dyno'd tonight or tomorrow
"i guess it is a common problem on rbs" is misleading because there are dozens of rbs out there and the problem has nothing to do with rbs as turbo hardware. It looks like either you or Vargas removed the bracket or did not fasten it properly.

Nice that you'll get it running and dynoed so quickly.
jippii ensio is offline  
0
Reply With Quote
      10-03-2012, 01:36 PM   #18
Rob@RBTurbo
BimmerPost Supporting Vendor

 
Rob@RBTurbo's Avatar
 
Drives: 335I
Join Date: Jan 2008
Location: St. Louis, MO

Posts: 1,054
iTrader: (4)

Agree with jippii e, FOD (foreign object damage) will get any turbo.

Considering 120+ turbos (60+ sets) total RBs out there, the couple encountered to date is actually pretty good.
Rob@RBTurbo is offline  
0
Reply With Quote
      10-03-2012, 03:23 PM   #19
RSTECH
Enlisted Member
 
Drives: e90 335i xdrive Msport
Join Date: Mar 2012
Location: queens n.y.

Posts: 45
iTrader: (0)

Looking forward to dyno results
__________________
RIP killed by 18 wheeler 10' A/W M-Sport-JB4-E85/93,50/50-BMS DCI-AR DP'S-Balck Kidney Grills-muffler delete-mm6 mesh18x8.5/9.5-Conti DWS 235/40 18, 265/35 18.
10'e90 a/w SportPackage mods coming soon.
95 civic-k24 block-k20 head-12.5:1 c/r pistons-drag cartel stg 4 cams-ported rbc mani-q45 90mm tb-ssr headers- 3" exhaust, 300+whp, 2000 lbs.
RSTECH is offline   United_States
0
Reply With Quote
      10-04-2012, 11:35 AM   #20
sahyoun
Lieutenant
 
sahyoun's Avatar
 
Drives: E92 jb4 e85 335i
Join Date: Jul 2010
Location: Bay Area, California

Posts: 504
iTrader: (0)

Quote:
Originally Posted by jippii ensio View Post
"i guess it is a common problem on rbs" is misleading because there are dozens of rbs out there and the problem has nothing to do with rbs as turbo hardware. It looks like either you or Vargas removed the bracket or did not fasten it properly.

Nice that you'll get it running and dynoed so quickly.
Sorry, i meant that the whole problem with the tube coming off is a problem experienced by multiple upgraded turbos, but i could be wrong. I guess its missing that bracket which is why this happened.
sahyoun is offline   Lebanon
0
Reply With Quote
      10-04-2012, 11:52 AM   #21
Rob@RBTurbo
BimmerPost Supporting Vendor

 
Rob@RBTurbo's Avatar
 
Drives: 335I
Join Date: Jan 2008
Location: St. Louis, MO

Posts: 1,054
iTrader: (4)

It moreso can be a very rare problem during any turbo swap, but I have only seen it happen a time or two.
Rob@RBTurbo is offline  
0
Reply With Quote
      10-04-2012, 11:54 AM   #22
sahyoun
Lieutenant
 
sahyoun's Avatar
 
Drives: E92 jb4 e85 335i
Join Date: Jul 2010
Location: Bay Area, California

Posts: 504
iTrader: (0)

Someone should make an intake that just ditches that whole wrap around the engine bs
sahyoun is offline   Lebanon
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:00 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST