E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Engine Fluttering



Reply
 
Thread Tools Search this Thread
      11-07-2012, 12:22 PM   #1
Pourky
First Lieutenant
 
Pourky's Avatar
 
Drives: E92 335i / E46 M3
Join Date: Jun 2006
Location: Los Angeles / SoCal

Posts: 311
iTrader: (6)

Engine Fluttering

Hey everyone, need your expertise and input... The other night I decided to push my car through 4th gear and suddenly the car started fluttering and very rigid through the powerband. It was a pretty good amount. I would think it would be a misfire, injectors, or coil packs but I didn't get any codes.

There was no display of the SEIZED engine sign but the "Service Engine" light came on during the fluttering. I even ran it through 3rd gear and would get the same results.

So this morning I decided to run some logs and see whats going on... can you guys take and see if anything looks wrong. I pulled the codes but it says "No Codes Found"

Here are a couple pulls...

Here is the 1st pull in 3rd gear


Another pull from 3rd gear and SEIZED engine cut off with the 1/2 Engine Display


One last pull from 4th gear with the same results of the engine SEIZING
__________________
2007 E92 335i - JB4 / AR Catless DPs / ETS Chargepipe / HKS SSQV BOV / AFE Stage 2 DCI / MagnaFlow Exhaust / LUX V3 Angel Eyes / H&R Race Springs / Too Many Cosmetic Upgrades to List
Pourky is offline  
0
Reply With Quote
      11-07-2012, 01:32 PM   #2
Dylan335i
Lieutenant
 
Dylan335i's Avatar
 
Drives: 2007 BMW 335i
Join Date: Sep 2011
Location: Orlando

Posts: 457
iTrader: (4)

If the service engine soon light came on im 90% sure you should have codes. What are you using to pull them?
__________________
JB4 G5 / Walboro LPFP/ BMS Flash/ M3 Rep Front Bumper / OSS Headlights / BC Coilovers / 5" ETS FMIC / 3" VRSF Downpipes / AA Charge Pipe & BOV / BMS DCI / LCI Tails / CSL Trunk / CF Interior / CF Emblems / Cyba Air Scoops / 15% Tints / 5k Fogs / EBC RedStuff Pads / Drilled & Slotted Rotors / ECS SS Brake Lines
Dylan335i is offline   United_States
0
Reply With Quote
      11-07-2012, 01:34 PM   #3
Jeff@TopGearSolutions
BimmerPost Supporting Vendor

 
Jeff@TopGearSolutions's Avatar
 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

Posts: 17,133
iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
Yes you should have codes, atleast shadow codes. Probably misfires.

How many miles on the plugs?
Jeff@TopGearSolutions is offline   United_States
0
Reply With Quote
      11-07-2012, 02:59 PM   #4
Pourky
First Lieutenant
 
Pourky's Avatar
 
Drives: E92 335i / E46 M3
Join Date: Jun 2006
Location: Los Angeles / SoCal

Posts: 311
iTrader: (6)

I plugged the USB cable in and ran those pulls... Then went to settings to read codes and kept saying no error codes.

Do I need to run the codes while I'm driving?

I have 50,000 miles on it now and not sure when the injectors were last changed if they even were. I purchased the car with 40,000 miles.
__________________
2007 E92 335i - JB4 / AR Catless DPs / ETS Chargepipe / HKS SSQV BOV / AFE Stage 2 DCI / MagnaFlow Exhaust / LUX V3 Angel Eyes / H&R Race Springs / Too Many Cosmetic Upgrades to List
Pourky is offline  
0
Reply With Quote
      11-07-2012, 03:08 PM   #5
See5
Real Goon
 
See5's Avatar
 
Drives: Nothing
Join Date: Jul 2011
Location: Atlanta

Posts: 350
iTrader: (0)

You might have the autoclear turned on.
See5 is offline   United_States
0
Reply With Quote
      11-07-2012, 03:59 PM   #6
enrita
Major General
 
enrita's Avatar
 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

Posts: 7,323
iTrader: (0)

your timing look not that good. but you have throttle closure as well , do you have traction control on?
__________________
07 335i AT - TD St.2 Turbos - COBB (Custom Cobb mapping by http://www.protuningfreaks.com/) - JB4G5 ISO - Okada Coils - NGK 5992 Plugs - E85 Walbro - Injen Intake - Helix IC - Snow Stg. 3 - Stett CP - AR DPs - midpipes 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - Level 10 AT upgrade - Alpina AT Flash
enrita is offline   Sweden
0
Reply With Quote
      11-07-2012, 04:54 PM   #7
Pourky
First Lieutenant
 
Pourky's Avatar
 
Drives: E92 335i / E46 M3
Join Date: Jun 2006
Location: Los Angeles / SoCal

Posts: 311
iTrader: (6)

Quote:
Originally Posted by enrita
your timing look not that good. but you have throttle closure as well , do you have traction control on?
No it's completely off. I'm not sure... maybe I should try to read the codes again. I'm thinking it could be injectors or coil packs but would that be symptoms of it?

The engine just kinda flutters through the powerband, as if a O2 sensor went out or something.
__________________
2007 E92 335i - JB4 / AR Catless DPs / ETS Chargepipe / HKS SSQV BOV / AFE Stage 2 DCI / MagnaFlow Exhaust / LUX V3 Angel Eyes / H&R Race Springs / Too Many Cosmetic Upgrades to List
Pourky is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:39 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST