E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > E90 LCI Taillight LED's failed



Reply
 
Thread Tools Search this Thread
      11-08-2012, 10:07 PM   #1
pepsih
Captain
 
pepsih's Avatar
 
Drives: E90 335i
Join Date: Oct 2011
Location: Currently NY

Posts: 655
iTrader: (0)

E90 LCI Taillight LED's failed

Hi im currently working on my LCI tailight conversion and did the test of my euro taillights for the very first time today.
And here is the result....



I bought them from Europe so its not so easy to send them back...
I know it's a "common" issue but is there any way to fix that without replacing it ?

please help me out.
pepsih is offline   France
0
Reply With Quote
      11-08-2012, 10:22 PM   #2
theblackmamba
Colonel
 
Drives: 0
Join Date: Dec 2007
Location: 1

Posts: 2,262
iTrader: (8)

yea, sell them in the classifieds.

*dead*
__________________
theblackmamba is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:11 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST