E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > 335i Jerking When Applying Throttle



Reply
 
Thread Tools Search this Thread
      10-13-2010, 06:32 PM   #1
TiAg335i
Trance Life
 
TiAg335i's Avatar
 
Drives: 2007 E92 335i
Join Date: Jan 2007
Location: Long Island, NY

Posts: 4,710
iTrader: (4)

335i Jerking When Applying Throttle

Just today I have came across another issue with my 335i with AT. When I apply throttle from 1st-2nd or at the beginning of a gear the car jerks pretty bad, even though I am pressing the throttle smoothly the car will sort of stop, go, stop, go and so on for a short while...almost like there is something wrong with the transmission or maybe bad fuel (I l put in a couple gallons of 93 BP gasoline when I almost always use 93 Shell). I have the JB+ in but it's only been in my car for a couple of days after a long time of not using it. I am not under warranty anymore (just expired end of Sept).
TiAg335i is offline   United_States
0
Reply With Quote
      10-13-2010, 07:12 PM   #2
dragazn
Captain
 
Drives: i
Join Date: Apr 2008
Location: dfw

Posts: 964
iTrader: (1)

Garage List
2008 BMW 335i  [2.88]
Send a message via Yahoo to dragazn
Might be a sign of the notorious HPFP going out. Mine did exactly same thing on MT, and a few days later it stall on me. I can get the engine start again, but within 50ft of driving it will throw the engine light and stall.
dragazn is offline  
0
Reply With Quote
      10-13-2010, 07:24 PM   #3
TiAg335i
Trance Life
 
TiAg335i's Avatar
 
Drives: 2007 E92 335i
Join Date: Jan 2007
Location: Long Island, NY

Posts: 4,710
iTrader: (4)

Hmm...i just went to get gas and the engine light (half yellow) came on. I think that is what is notoriously known as "limp mode". Car drove fine but I wasn't pushing it. It can either be the JB+ or the fuel pump...not good either way.
TiAg335i is offline   United_States
0
Reply With Quote
      10-13-2010, 07:48 PM   #4
PeteW84
COBB'ed
 
PeteW84's Avatar
 
Drives: 13 Mini Cooper S
Join Date: Apr 2008
Location: Tinley Park, IL

Posts: 2,232
iTrader: (1)

Garage List
2008 335i  [3.78]
Take the Jb+ out, and see what happens.
__________________


13 Mini Cooper S
08 E92 335i (SOLD)
PeteW84 is offline   United_States
0
Reply With Quote
      10-13-2010, 07:55 PM   #5
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: The Coding Guy
Join Date: Jun 2007
Location: Call 917-939-4980

Posts: 18,221
iTrader: (5)

Send a message via Yahoo to cn555ic
Yeah take it out and see if it still does it
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      10-13-2010, 08:25 PM   #6
lsdless
Private First Class
 
lsdless's Avatar
 
Drives: E92 335i 6MT
Join Date: Jan 2009
Location: Atlanta, GA

Posts: 184
iTrader: (0)

I had this problem when I got the most recent software update. I removed my JB+ and haven't had the problem since. I'm saving up to upgrade to jb3 or proceed (I still haven't decided.) Here is a link to the thread I started about my problems.
http://www.e90post.com/forums/showthread.php?t=419871
lsdless is offline   United_States
0
Reply With Quote
      10-13-2010, 08:26 PM   #7
michaelalex17
Colonel
 
michaelalex17's Avatar
 
Drives: 335xi E92
Join Date: Aug 2010
Location: NY

Posts: 2,219
iTrader: (3)

does this only happen when the car is cold? if not check the fuel inkectors
michaelalex17 is offline  
0
Reply With Quote
      10-13-2010, 08:38 PM   #8
sant0r0
New Member
 
Drives: 07 BMW 335i
Join Date: Jun 2010
Location: Newburgh, NY

Posts: 10
iTrader: (0)

Yea i just had this problem 3 days ago and it was fuel injectors. All better now!!
sant0r0 is offline  
0
Reply With Quote
      10-13-2010, 08:41 PM   #9
TiAg335i
Trance Life
 
TiAg335i's Avatar
 
Drives: 2007 E92 335i
Join Date: Jan 2007
Location: Long Island, NY

Posts: 4,710
iTrader: (4)

Happens when the car is warm. I'm going to take the JB+ out and run the car with the new gas and we'll see what happens. Thanks guys.

Since I have no longer have warranty can't afford to play anymore.
TiAg335i is offline   United_States
0
Reply With Quote
      10-13-2010, 08:43 PM   #10
MisterSkiMask
Lieutenant Colonel
 
Drives: I Can not say
Join Date: Nov 2005
Location: you must not know

Posts: 1,908
iTrader: (0)

I find the 335i to be a jerkey on take off, like the trans 'take up' is abrupt. It think it is better in DS, give that a try and see what you think.

Mine is stock.
MisterSkiMask is offline  
0
Reply With Quote
      10-13-2010, 09:50 PM   #11
TiAg335i
Trance Life
 
TiAg335i's Avatar
 
Drives: 2007 E92 335i
Join Date: Jan 2007
Location: Long Island, NY

Posts: 4,710
iTrader: (4)

Quote:
Originally Posted by MisterSkiMask View Post
I find the 335i to be a jerkey on take off, like the trans 'take up' is abrupt. It think it is better in DS, give that a try and see what you think.

Mine is stock.
I know what you are talking about...but this is definitely an abnormal amount of 'jerk'.
TiAg335i is offline   United_States
0
Reply With Quote
      10-14-2010, 01:42 PM   #12
brocken
Captain
 
Drives: 335i
Join Date: Nov 2006
Location: Seattle, WA

Posts: 605
iTrader: (5)

All this talk of jerking...

My 335i is currently having the same issue. Doesn't matter which fuel I use.
I have the AT and the 'surging' happens in all modes and usually is the worst between 2k-3k rpm.
It's sort of like lag but it's more like the engine is bogging down when it tries to pump fuel.
I think it's just another syptom of the fuel problems I've been having for the last couple years.
I wish you luck when you take it into the dealer. You might get lucky and they'll figure it out... or they might just act like you're crazy.
But you are not alone.
brocken is offline  
0
Reply With Quote
      11-12-2010, 02:59 PM   #13
TiAg335i
Trance Life
 
TiAg335i's Avatar
 
Drives: 2007 E92 335i
Join Date: Jan 2007
Location: Long Island, NY

Posts: 4,710
iTrader: (4)

I'm pretty sure the jerking stops when I take out the JB+. I recently put the JB+ back in and it's happening again. Almost feels like a giant pushing and pulling the car from behind really rapidly. It's REALLY unpleasant.

It's definitely not the fuel, or the way I am driving.

I'm going to take the JB+ out again and if the lurching/jerking stops I will be leaving it out...for good. If it's still there I will take the car to the dealer and ask for the newest software update (I read that one of the updates fixed a bucking issue).

At this point I almost 100% positive it's the JB+.
TiAg335i is offline   United_States
0
Reply With Quote
      11-12-2010, 07:08 PM   #14
Andrew@ET
Brigadier General
 
Drives: Red thing
Join Date: May 2007
Location: Earth

Posts: 4,041
iTrader: (9)

what setting do you have the jb+ set to?
Andrew@ET is offline  
0
Reply With Quote
      11-12-2010, 07:16 PM   #15
ihvabmr
Lieutenant
 
Drives: BMW
Join Date: Aug 2010
Location: Earth

Posts: 411
iTrader: (4)

I also experienced a similar problem with half engine light. Did a tool scan, and discovered it was the Vanos Solenoid on the exhasut side. You might want to check that out as well. My car drives fine after the reset, but i just ordered two to replace the intake side and exhaust side just so i don't have to deal with it in the future. Right now, my car does jerk a little when it hits past 3k rpm. I assume its the Vanos Solenoid not operating at its optimum level.
ihvabmr is offline  
0
Reply With Quote
      11-12-2010, 07:46 PM   #16
Mike@N54Tuning.com
BimmerPost Supporting Vendor

 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

Posts: 13,902
iTrader: (83)

50% is smoother than 100% but if you have noticeable jerking it's possible a wire in the JB+ itself is loose, etc. Worst case just send it back to BMS for inspection under its warranty.

Mike
__________________
BEST PRICES GUARANTEED - New N54 Performance Line Downpipes!!
JB4 **G5** On Sale - FREE Shipping Click Me - NEW JB4(N55) & DCI's $95.00
NEW F30 N20/N55 ER Downpipes and Chargepipes - BMS OCC (On Sale)
Mike@N54Tuning.com is offline   Canada
0
Reply With Quote
      11-16-2010, 08:10 PM   #17
TiAg335i
Trance Life
 
TiAg335i's Avatar
 
Drives: 2007 E92 335i
Join Date: Jan 2007
Location: Long Island, NY

Posts: 4,710
iTrader: (4)

the JB+ was set at 100%...would this effect the "smoothness" to the extent i described? no wires loose in the JB+ from a quick inspection..i am quite positive the JB+ itself is not damaged, nothing was done to damage it...
TiAg335i is offline   United_States
0
Reply With Quote
      11-16-2010, 08:13 PM   #18
Forcefed3
Banned
 
Drives: 2008 335i
Join Date: May 2010
Location: South

Posts: 4,742
iTrader: (2)

Garage List
2008 335i  [0.50]
I have the JB3, doesnt happen often, but sometimes I experience the rough take-off. Never really thought anything of it.
Forcefed3 is offline   No_Country
0
Reply With Quote
      11-16-2010, 08:33 PM   #19
Tzu
Major
 
Drives: 335i
Join Date: Jun 2010
Location: Toronto

Posts: 1,390
iTrader: (1)

I have a stock e90 335i and I get that jerkyness as well. A couple months back the car threw a camshaft position sensor code, but the dealer wouldnt do anything because the code wasnt present when I took it in.
Tzu is offline   Canada
0
Reply With Quote
      11-16-2010, 10:16 PM   #20
335iLI
Captain
 
Drives: 335i
Join Date: Nov 2009
Location: NY-LI

Posts: 634
iTrader: (5)

If I don't engage the clutch perfect in first or if the car isn't happy that day it jerks like crazy. The boost gauge jumps up n down like crazy. Only happens in first gear.
335iLI is offline  
0
Reply With Quote
      02-03-2011, 12:31 AM   #21
MeanMangoMan
German Spitz
 
MeanMangoMan's Avatar
 
Drives: 335i e92 Sport
Join Date: Jun 2010
Location: Draper, UT.

Posts: 219
iTrader: (0)

Garage List
2007 335i  [5.00]
Send a message via AIM to MeanMangoMan Send a message via Skype™ to MeanMangoMan
Did you ever figure out the issue? I have the same freaking problem, no engine light!
__________________
*Vishnu Exhaust/JB2 Tune
*BMW Performance Suspension/H&R Sport Springs/Eibach Spacers/19" Black M6 Rims
*GP Thunder 8500k Angel Eyes/Corners/CF Emblems
*Lexen LED Plate Lights/Black AutoTecknic Grille
MeanMangoMan is offline   United_States
0
Reply With Quote
      02-03-2011, 01:39 AM   #22
chappy
Lieutenant
 
chappy's Avatar
 
Drives: 335 M-SPORT COUPE
Join Date: Nov 2008
Location: Brisbane Australia

Posts: 568
iTrader: (0)

Quote:
Originally Posted by MeanMangoMan View Post
Did you ever figure out the issue? I have the same freaking problem, no engine light!
I had the same problem from putting into M1 using paddles then changing into M2 not going fast but around 3000rpm it would double jerk or miss no codes would show and that was on vishnu V4 but since then have updated to V5 old firmware,still did the same, but the latest beta 1-21 firmware has solved that issue completely,no jerking what so ever very smooth like stock.
I thought it was spark plugs,but i was wrong.
__________________
THE BEAST Vishnu Procede V5 2.5rev/Stage 2/ AFE DCI Intake /M3 suspension/Forge Intercooler/Alpina B3 AT Flash/Bird's B3 Suspension/BMW OEM M3 Steering Wheel and DCT Paddles
chappy is offline   Australia
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:10 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST