E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > JB4 killed my car....



Reply
 
Thread Tools Search this Thread
      11-12-2012, 08:17 PM   #23
ilirduka335xi
Second Lieutenant
United_States
5
Rep
268
Posts

 
Drives: 2008 bmw 335xi space gray
Join Date: Aug 2012
Location: Staten Island, New York

iTrader: (0)

Garage List
2008 bmw 335xi  [0.00]
your jb4 is def installed wrong in some sort of way because i install it the wrong also and it said my AWD was disabled and started throwing some other crazy codes but i re installed the jb4 the right way and everything was fine again lol
__________________
08 335xi e92, JB4 g5, Afe s2 DCI/scoops, AR catless dps, Helix FMIC, H&R sport springs
Appreciate 0
      11-12-2012, 09:29 PM   #24
Dr-Euro
Private First Class
Dr-Euro's Avatar
5
Rep
129
Posts

 
Drives: BMW
Join Date: Oct 2011
Location: Southern California

iTrader: (0)

How long did you have the unit on the car? Usually if the JB4 is installed wrong then you would get an immediate indication either by limp, SES, or both. Like others have stated, the unit is passive and cannot "kill your car".

If the unit has been on the car for some time and you are just now having problems communicating with the DME then I would say that your DME was not properly sealed after installation. Amateur installers may only lock the box on the front and rear and neglect to completely clip it from left to right. Condensation or water entering the ECU over time can cause corrosion to build and eventually cause communication problems and failure. There was alot of these types of problems on the E36 cars and sounds like you are experience the same symptoms.
__________________
Appreciate 0
      11-12-2012, 09:51 PM   #25
Eric335
Colonel
Eric335's Avatar
United_States
36
Rep
2,493
Posts

 
Drives: 2007 E92 SG 335i 6MT
Join Date: Apr 2011
Location: SW Florida

iTrader: (0)

Garage List
2007 BMW 335i  [3.83]
Quote:
Originally Posted by Dr-Euro View Post
How long did you have the unit on the car? Usually if the JB4 is installed wrong then you would get an immediate indication either by limp, SES, or both. Like others have stated, the unit is passive and cannot "kill your car".

If the unit has been on the car for some time and you are just now having problems communicating with the DME then I would say that your DME was not properly sealed after installation. Amateur installers may only lock the box on the front and rear and neglect to completely clip it from left to right. Condensation or water entering the ECU over time can cause corrosion to build and eventually cause communication problems and failure. There was alot of these types of problems on the E36 cars and sounds like you are experience the same symptoms.
Interesting, i will have to double check that to make sure i have it fully clipped on. Thanks!
__________________
Appreciate 0
      11-12-2012, 10:53 PM   #26
Indo Rider
Second Lieutenant
5
Rep
223
Posts

 
Drives: 135
Join Date: Apr 2012
Location: United States

iTrader: (0)

Typical stealership bs. These are the guys that blame injector failures on blow off valves and fuel pump failures on downpipes. Go to an indy shop or at lest another dealer. So your car was working when you drove it to the shop to get it looked at right? When exactly did your car die? What was the symptom? What you said didn't quite make sense at the end there...
Appreciate 0
      11-12-2012, 10:55 PM   #27
boostaholic786
Lieutenant
boostaholic786's Avatar
6
Rep
565
Posts

 
Drives: E92 JB4 G5 ISO RB's FBO+40%E85
Join Date: Dec 2011
Location: irving tx

iTrader: (0)

Come on man change that title you put for this thread. That is so ignorant of you to put a title like that when most probably your just an idiot and installed the JB4 wrong... If I'm not mistaken, Burger Tuning hasn't had a single JB4 cause a "DME failure". So your title is very misleading and ignorant to those who look thru this forum to decide what kind of tune they are going to choose.. Its not hard to change it so just change the title to a title that makes more sense.
__________________
A/W E92 335i M-sport with JB4 G5 ISO/ E40 WEDGE PERFORMANCE BACKEND FLASH, Alpina TCU flash for AT/Switch-tronic +AR Downpipes, Stett gen 1 intake, Wagner-Tuning FMIC+RB Turbo setup/ RB PCV Valve+ Akro exhaust+60% E85/93 mix,+ HRE P40S wheels, KW coilovers, M3 sways,+BMW performance CF Mirrors, BMW Performance CF deck lid spoiler,+ CF interior trim, p3 vent boost gauge,+ LUX angel eyes (11.73@119mph on street tires) NO METH!
Appreciate 0
      11-12-2012, 11:22 PM   #28
RockChalkKU
Major League Airpower. STRIKE EAGLE
United_States
3
Rep
79
Posts

 
Drives: 2007 BMW M5
Join Date: Sep 2012
Location: NC

iTrader: (1)

If you are going to call me a dumbass on my post, at least know how to spell. But thank you for the advice. I have taken it to a reputable shop who has dealt with this problem before and the way it was described to me was that although the jb4 may not have just shut it down completely, it may have been a major factor in the DME failure.

My original problem was misfires on 4-6, a 30BB code and the sensors reading lean. Car was in limp mode and we were unable to reset bank two after replacement of coils and spark plugs. Therefore I took it to a shop to see if their software could clear the code and that is what shot it down.
Appreciate 0
      11-12-2012, 11:25 PM   #29
RockChalkKU
Major League Airpower. STRIKE EAGLE
United_States
3
Rep
79
Posts

 
Drives: 2007 BMW M5
Join Date: Sep 2012
Location: NC

iTrader: (1)

Quote:
Originally Posted by Dr-Euro View Post
How long did you have the unit on the car? Usually if the JB4 is installed wrong then you would get an immediate indication either by limp, SES, or both. Like others have stated, the unit is passive and cannot "kill your car".

If the unit has been on the car for some time and you are just now having problems communicating with the DME then I would say that your DME was not properly sealed after installation. Amateur installers may only lock the box on the front and rear and neglect to completely clip it from left to right. Condensation or water entering the ECU over time can cause corrosion to build and eventually cause communication problems and failure. There was alot of these types of problems on the E36 cars and sounds like you are experience the same symptoms.
I actually had a JB3 running on the car when this happened. It was running on my car for probably 6 months or so. When going through the troubleshooting I upgraded to the jb4. It continued to fail so then I took it to the shop.
Appreciate 0
      11-13-2012, 12:48 AM   #30
BlueLion
she likes the flavor......
United_States
19
Rep
1,622
Posts

 
Drives: A51-E92
Join Date: Nov 2006
Location: Bradenton - FL

iTrader: (4)

Garage List
2007 BMW 335  [0.50]
either you went to a bad shop or had a bad install.....jb4 is not going to ruin your car
__________________

E92 Montego Blue silfa718 ..::STETT CAI|ADVAN RS|WAGNER FMIC|MS DP|VANGUARD|PROCEDE|FORGE DV|BMS OCC|KWV2|MICHELIN PSS|OOS::..

Appreciate 0
      11-13-2012, 04:15 AM   #31
RockChalkKU
Major League Airpower. STRIKE EAGLE
United_States
3
Rep
79
Posts

 
Drives: 2007 BMW M5
Join Date: Sep 2012
Location: NC

iTrader: (1)

If it was a bad install, how was I still able to use the tuner without a problem?
Appreciate 0
      11-13-2012, 05:19 AM   #32
cstavaru
Brigadier General
cstavaru's Avatar
94
Rep
3,237
Posts

 
Drives: 2009 335i M Sport Sedan 6MT
Join Date: Aug 2008
Location: Bucharest, Romania

iTrader: (0)

Quote:
Originally Posted by RockChalkKU View Post
Looks like the JB4 led to my car dying. Took it to the shop to get looked at and I have been told that the software ruined the DME at the minimum. Even after removing the JB4 the car wont communicate with the DME and wont clear any codes pertaining to those faults. LUCKY ME! Looks like the car is going to be sitting around for a while....

Has this happened to anyone else or am I just on an unlucky streak?
There are multiple DME failures on the forum. My personal opinion is that yes, piggybacks play a role in DME failures. I would like to see one person with DME failure who is not running a piggyback or has not ran it at some point in time. There are so many things that can happen: impedance mismatch (leading to high current through some of the output transistors), short circuits, statical electricity, etc.
Appreciate 0
      11-13-2012, 06:42 AM   #33
spool twice
Rainbow Racer
spool twice's Avatar
United_States
18
Rep
1,280
Posts

 
Drives: S65B40
Join Date: Sep 2010
Location: Sarasota, FL

iTrader: (7)

Quote:
Originally Posted by cstavaru View Post
There are multiple DME failures on the forum. My personal opinion is that yes, piggybacks play a role in DME failures. I would like to see one person with DME failure who is not running a piggyback or has not ran it at some point in time. There are so many things that can happen: impedance mismatch (leading to high current through some of the output transistors), short circuits, statical electricity, etc.
This has been on on the back of my mind as well, which is why I've been aching to change to a total reflash and do it the proper way instead of using a piggy.
__________________
'15 IS350 F-sport Ultra White/Rioja Red
'09 E90 M3 7-DCT Interlagos Blue/Novillo Silver
[MS Pullies|K&N drop-in|Test Pipes |Evolve Stage II tune|Evolve Servotronic Map|Evolve M3 GTS-DCT file]
Now gone
Appreciate 0
      11-13-2012, 07:02 AM   #34
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
480
Rep
15,057
Posts


 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

iTrader: (88)

Quote:
Originally Posted by RockChalkKU View Post
If you are going to call me a dumbass on my post, at least know how to spell. But thank you for the advice. I have taken it to a reputable shop who has dealt with this problem before and the way it was described to me was that although the jb4 may not have just shut it down completely, it may have been a major factor in the DME failure.

My original problem was misfires on 4-6, a 30BB code and the sensors reading lean. Car was in limp mode and we were unable to reset bank two after replacement of coils and spark plugs. Therefore I took it to a shop to see if their software could clear the code and that is what shot it down.
That is a known DME transistor problem, nothing to do with tuning. Someone posted a DIY fix for it here. BMW will also cover it under warranty on certain models. You should really change the subject of this thread as it's VERY misleading.

Mike
__________________
LOWEST PRICE GURANTEE ON ALL PRODUCTS - www.n54tuning.com - Email; Mike@n54tuning.com
NEW PERFORMANCE LINE N54 DOWNPIPES & M3/M4 & F30 ER DOWNPIPES NOW IN STOCK - ER N54 CHARPE PIPE SPECIALS - NEW JB4 G5 ISO for N54 and F30 N55 ON SALE - NEW S55 M3/M4 JB4 NOW SHIPPING
Appreciate 0
      11-13-2012, 07:06 AM   #35
#Tee
Chronic trollololer level 60
#Tee's Avatar
80
Rep
4,890
Posts

 
Drives: yes
Join Date: Oct 2011
Location: Socal

iTrader: (1)

lol wow op almost over reacted
__________________

#TeamStretchNpoke IG:Tee212

custom cf rear side diffuser add ons for sale (e9x,M3s,f3x) pm me for details. thread http://www.e90post.com/forums/showthread.php?t=962442
Appreciate 0
      11-13-2012, 07:14 AM   #36
Rotorocious
Major
Rotorocious's Avatar
32
Rep
1,461
Posts

 
Drives: 335i
Join Date: May 2010
Location: Florida

iTrader: (3)

Video killed the radio star
Appreciate 0
      11-13-2012, 07:37 AM   #37
demontwinz
Lieutenant
4
Rep
455
Posts

 
Drives: 335i e92
Join Date: Sep 2012
Location: Toronto

iTrader: (0)

good luck with your car. I had MIke n54tuning install my JB4 without any problems. He offers amazing service. I also got DCI and LED Angel eyes from him, I will be a returning customer after the winter.
Appreciate 0
      11-13-2012, 10:19 AM   #38
nailer335
Captain
nailer335's Avatar
United_States
10
Rep
690
Posts

 
Drives: alpine '08 e92 335xi
Join Date: Feb 2010
Location: Arizona

iTrader: (0)

RoadchalkKU,

Imagine that you owned a business and went above and beyond to help your largely technically inept customer base use your product. Imagine that the product that this hypothetical business you're running isn't proven to cause failure of any kind and has been proven on thousands of applications for anywhere from thousands to tens of thousands of miles on each of those thousands of applications. Despite all of this, also imagine that this business' marketing is highly dependent on the Internet. Yes, you're right. That can be unfortunate, because unfortunately everyone has opinions nowadays and can voice them publicly, in such a way that they actually influence sheeple who know as little about your hypothetical business' product, its application and effects on the system to which it applies, etc as the person who has the freedom to post ignorantly about your hypothetical business online. I agree, reading and learning will always be better than posting, and people who have un(der)qualified opinions should be ghost on Internet space.

Lesson #1: Change the title of your post
Lesson #2: Read/learn as much as you can and apply critical thinking equal to the consequences of the situation you're in and creating before posting online to avoid this in the future.


Ok, we're going to continue on the hypothetical examples here. Let's say that you owned a business that performed labor on machines in ways that a VAST majority of your customer base didn't understand any better than hieroglyphics. One day, someone with one of the generally perceived "nicer" or more complicated and technical machines comes in and asks for your help. He has made changes to the machine. He does not present himself as someone who understands the machine as a whole, nor does he appear to be the proactive or curious type. Since you observe that this person appears to have the right combination of money, general liking for the "costly" (subjective) machine, enough so to modify it from its original state, AND they aren't proactive, you decide to take advantage of their ignorance by blaming a technical issue on an easy target that you know this customer will eat up. You can run this person up and down and give them a reason they'll believe. You make more money doing so and this person never knows any better, they'll believe whatever you tell them. You can now plan a nice vacation.

Lesson #3: be proactive. First, if you modify the ECU, make sure that you have a way to diagnose problems. Your best choice is a BT cable. Some "tuners" have means whereby customers can read codes too. To me, a netbook, BT cable, and a JB3/4 or proceed are a team and any of the three independently would be considered incomplete.
Lesson #4: recognize that a shop will make as much money as it can. Generally speaking, people who care about money will make as much of it as possible. Do yourself a favor and take your car to another shop for a second opinion. Maybe you can look on the local forums, posting (better yet, searching first to see if your question has been asked before in the past six years) a request for a reference to a reputable shop from someone who has been taking their JB/PROcede tuned 335i to for service/diagnosis/etc


Just a few quick thoughts, hopefully this helps and hopefully you see the lessons to be learned from them and apply them like someone with decency would. I think I spelled everything right, let me know if I didn't and I'll correct myself. Good luck with your car, hopefully you straighten things out.
Appreciate 0
      11-13-2012, 10:34 AM   #39
eric@h
eric@h's Avatar
United_States
15
Rep
874
Posts

 
Drives: 01 M Coupe, 08 135i, '12 328i
Join Date: Jul 2007
Location: Philadelphia

iTrader: (0)

Quote:
Originally Posted by benzy89 View Post
User Install Error -- You probably connected the wires wrong & fried your DME. Don't blame a proven product for your mistakes. Good, quality vendors suffer from your quick judgement that there's something wrong with the product.
This.
Appreciate 0
      11-13-2012, 11:21 AM   #40
BoominChu
Fleming Automotive
0
Rep
26
Posts

 
Drives: 2008 335xi
Join Date: Nov 2012
Location: Maryland

iTrader: (0)

Things JB4 wil never do:

Give you up
Let you down
Run around
Desert you
Make you Cry
Say goodbye
Tell a lie
Hurt you


..... no wait thats rick astley
Appreciate 0
      11-13-2012, 11:51 AM   #41
bigdaddycane
I even mod my cereal
bigdaddycane's Avatar
United_States
34
Rep
2,608
Posts

 
Drives: 2007 335i Sedan
Join Date: Aug 2009
Location: Northern Va

iTrader: (34)

Garage List
2007 BMW 335  [0.00]
^ that tire story is funny as sh*t....I hope he's kidding tho....what a debacle.
__________________

COBB AP|CP-e|ETS|ER|Forge DVs|KW V1|M3 Sways|BBS CH|BMS|
Appreciate 0
      11-13-2012, 12:18 PM   #42
AK 335i
Major
AK 335i's Avatar
14
Rep
1,294
Posts

 
Drives: black 335i E90
Join Date: Sep 2012
Location: boynton beach

iTrader: (0)

Quote:
Originally Posted by bigdaddycane View Post
^ that tire story is funny as sh*t....I hope he's kidding tho....what a debacle.
lol yea I was bored and reading ridiculous threads such as this one, so I posted that fun story
__________________
- Proven Power Tampa Built 6466 ST N54 6AT WR 711whp 637wtq -
Appreciate 0
      11-13-2012, 08:10 PM   #43
RockChalkKU
Major League Airpower. STRIKE EAGLE
United_States
3
Rep
79
Posts

 
Drives: 2007 BMW M5
Join Date: Sep 2012
Location: NC

iTrader: (1)

I am not ashamed to say that I may be incorrect in my forum post. But what I really was hoping for was for the knowledgable people in the forum to tell me what to look for, not to criticize my post. I do not have the same businesses and help that the west coast has. Also, I don't have 2000 dollars to put towards my car. I will take it to anther shop and see what they say, but I am asking for help. I have put a lot of time looking into this problem through forums and part replacement and right now, this is where I am at. I would like suggestions as to what I need to do. It would be greatly appreciated.
Appreciate 0
      11-13-2012, 08:24 PM   #44
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
480
Rep
15,057
Posts


 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

iTrader: (88)

Quote:
Originally Posted by RockChalkKU View Post
I am not ashamed to say that I may be incorrect in my forum post. But what I really was hoping for was for the knowledgable people in the forum to tell me what to look for, not to criticize my post. I do not have the same businesses and help that the west coast has. Also, I don't have 2000 dollars to put towards my car. I will take it to anther shop and see what they say, but I am asking for help. I have put a lot of time looking into this problem through forums and part replacement and right now, this is where I am at. I would like suggestions as to what I need to do. It would be greatly appreciated.
I already told you what to do in my last post...

Mike
__________________
LOWEST PRICE GURANTEE ON ALL PRODUCTS - www.n54tuning.com - Email; Mike@n54tuning.com
NEW PERFORMANCE LINE N54 DOWNPIPES & M3/M4 & F30 ER DOWNPIPES NOW IN STOCK - ER N54 CHARPE PIPE SPECIALS - NEW JB4 G5 ISO for N54 and F30 N55 ON SALE - NEW S55 M3/M4 JB4 NOW SHIPPING
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:17 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST