E90Post
 


N54Tuning.com
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Marbles grinding sound at idle! Help!



Reply
 
Thread Tools Search this Thread
      11-15-2012, 03:07 PM   #1
Bagelfast
Lieutenant Colonel
Bagelfast's Avatar
40
Rep
1,537
Posts

 
Drives: BMW
Join Date: Sep 2008
Location: USA

iTrader: (0)

Marbles grinding sound at idle! Help!

At idle or when i rev slightly im getting a super annoying low tone marbles grinding sound from my dash area..

It gets fast with idle rev and at 1k rpm it goea away 100%.. I can repeat it 100 times.. At idle or below 1k rpm the sound is there..

Anyone have any clue? From the engine bay i cant realli hear it, too much noise..

Im fbo.. All cowls on.. No codes
Appreciate 0
      11-15-2012, 03:18 PM   #2
ETS Michael
ETS Michael's Avatar
United_States
29
Rep
1,160
Posts

 
Drives: 335i
Join Date: May 2009
Location: Vancouver, WA

iTrader: (4)

Send a message via AIM to ETS Michael
auto or manual?
Appreciate 0
      11-15-2012, 03:19 PM   #3
Bagelfast
Lieutenant Colonel
Bagelfast's Avatar
40
Rep
1,537
Posts

 
Drives: BMW
Join Date: Sep 2008
Location: USA

iTrader: (0)

Auto...

And listening to it closely from the engjne bay, it sounds like its coming from the front of the engine or by thr solenoids..

28k miles fbo..
Appreciate 0
      11-15-2012, 03:46 PM   #4
GoRomeo
Colonel
GoRomeo's Avatar
26
Rep
2,365
Posts

 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

iTrader: (0)

Garage List
2006 330i  [2.83]
Are you getting a faulty code? From what I ve learned and read on forums sounds like its the vanos solenoids. Easy DIY.Seems like they need to be reaplced but swap them first then change oil hopefully this will help. Search this forums under Vanos solenoids. Good luck!
Appreciate 0
      11-15-2012, 05:49 PM   #5
gtaccord
Major
United_States
14
Rep
1,100
Posts

 
Drives: 2009 BMW 335xi
Join Date: Feb 2012
Location: Maryland

iTrader: (7)

Garage List
I get exactly the same noise but only in the cold. No codes though. Still haven't figured out exactly what it is although many people suggest the VANOS solenoids or the VANOS system itself.
Appreciate 0
      11-15-2012, 10:05 PM   #6
Bagelfast
Lieutenant Colonel
Bagelfast's Avatar
40
Rep
1,537
Posts

 
Drives: BMW
Join Date: Sep 2008
Location: USA

iTrader: (0)

Quote:
Originally Posted by gtaccord View Post
I get exactly the same noise but only in the cold. No codes though. Still haven't figured out exactly what it is although many people suggest the VANOS solenoids or the VANOS system itself.
Not sure.. it only happens from idle to 1k rpms....

Im gonna keep looking into it.. Try to pinpoint the sound.. Try disabling the JB4 and chaging wastegate positions..

I might even disconnect each boost solenoid to see if its coming from them.
Appreciate 0
      11-16-2012, 07:34 AM   #7
spool twice
Rainbow Racer
spool twice's Avatar
United_States
18
Rep
1,280
Posts

 
Drives: S65B40
Join Date: Sep 2010
Location: Sarasota, FL

iTrader: (7)

same noise I get, check my VANOS failure thread and log your current state

it's not a constant grinding noise is it? Is it more like a WHIR WHIR WHIR WHIR WHIR WHIR noise? Does it get louder when you turn on the A/C compressor?
__________________
'15 IS350 F-sport Ultra White/Rioja Red
'09 E90 M3 7-DCT Interlagos Blue/Novillo Silver
[MS Pullies|K&N drop-in|Test Pipes |Evolve Stage II tune|Evolve Servotronic Map|Evolve M3 GTS-DCT file]
Now gone
Appreciate 0
      11-16-2012, 08:52 AM   #8
Bagelfast
Lieutenant Colonel
Bagelfast's Avatar
40
Rep
1,537
Posts

 
Drives: BMW
Join Date: Sep 2008
Location: USA

iTrader: (0)

Quote:
Originally Posted by spool twice
same noise I get, check my VANOS failure thread and log your current state

it's not a constant grinding noise is it? Is it more like a WHIR WHIR WHIR WHIR WHIR WHIR noise? Does it get louder when you turn on the A/C compressor?
Cool, ill check out the thread..

Not sure, once i hear it ill turn the ac on and see what happens..

It changes sound / intensity with rpms , so im thinking its not the boost solenoids...
Might be the vanos solenoids
Appreciate 0
      11-16-2012, 10:47 PM   #9
CoralRed335XI
First Lieutenant
3
Rep
389
Posts

 
Drives: 2008 E92 335XI Coupe
Join Date: Aug 2011
Location: NJ,MD

iTrader: (2)

Garage List
2008 BMW 335XI  [0.50]
Vanos solenoids fo SHo
__________________
2008 E92 335XI, Space Gray on Coral Red, Premium, Cold Weather, Comfort Access, iPod.
Appreciate 0
      11-17-2012, 02:34 AM   #10
cookiesowns
;)
cookiesowns's Avatar
Taiwan
1
Rep
95
Posts

 
Drives: 535i @ 12psi, BRZ Series.Blue
Join Date: Jan 2011
Location: Irvine, CA

iTrader: (0)

Send a message via AIM to cookiesowns
Quote:
Originally Posted by spool twice View Post
same noise I get, check my VANOS failure thread and log your current state

it's not a constant grinding noise is it? Is it more like a WHIR WHIR WHIR WHIR WHIR WHIR noise? Does it get louder when you turn on the A/C compressor?

Hm. Well this is interesting. E60 535i here, WHIR WHIR WHIR annoying whining sound at slow speeds around idle - 1400rpm. Auto. A/C compressor on will cause the sound to be amplified.

Do you know what might cause this?
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:34 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST