E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Vanos replaced



Reply
 
Thread Tools Search this Thread
      07-18-2012, 07:54 PM   #1
shiccobm
Neo
8

 
shiccobm's Avatar
 
Drives: 2007 335I
Join Date: Jul 2008
Location: GTA


Posts: 162
iTrader: (0)

Hey everyone ,

Need some help ....

I just picked up a 2007 335i last friday , when i was driving home later that night , I got the engine light on and I felt I lost some power to the engine . The car has only 60,000 km on it when i got it and it still had one year of warranty .

So I called my dealer and they asked me to bring it in . They had to replace both Vanos on the vehicle .... is that too soon to change the vanos .... has anyone replaced the vanos here more than once.... should i be worried that this could happen again after my warranty is done ...

I am planning to keep this car for a while , best practices would be grealty appreciated

Update
Engine light still came on after Vanos is replaced
__________________
Road 1'er
Appreciate 0
      07-18-2012, 07:58 PM   #2
be1ieve1111
Thread Killer
United_States
18

 
Drives: 2011 E92 335i
Join Date: May 2010
Location: Indiana


Posts: 921
iTrader: (9)

Send a message via AIM to be1ieve1111 Send a message via Yahoo to be1ieve1111 Send a message via Skype™ to be1ieve1111
Do you have the paper work? Pretty sure they just changed out the Vanos solenoid and not the whole system.

If it is the solenoid you will get limp mode and engine malfunction sign. I had my 07 335i from 34k miles to 68k miles and that solenoid was changed a couple times during the years under warranty.
__________________
Current:2011 BSM E92 335i
Sold: 2006 Midnight Blue Cayman S
Sold: 2012 Lightning Red WRX
Sold: 2007 Monaco Blue E92 335i
Sold: 2006 Aspen White STi
Appreciate 0
      07-18-2012, 08:15 PM   #3
cmyk
resident girl.
United_States
29

 
cmyk's Avatar
 
Drives: 2008 335i
Join Date: Dec 2011
Location: Dallas, Texas


Posts: 1,016
iTrader: (1)

Garage List
2008 BMW 335i  [4.38]
Vanos solenoids are a common point of failure. Mine went around 42,000 miles. Next time you need to replace them, the parts themselves are not expensive and it's a fairly straightforward DIY.
__________________


2008 E90 335i // Black Everything // photos
COBB tuned / QTP e-cutouts / Helix FMIC / cp-e DCI / AWE BOVs / Black M6 wheels + Toyo Proxes
(and yes, I am a girl)
Appreciate 0
      07-18-2012, 08:27 PM   #4
pracklam
Enlisted Member
0

 
Drives: 2006 e90 325i
Join Date: Jan 2009
Location: Fairway, KS


Posts: 34
iTrader: (0)

Vanos solenoid clogs are common. Dealer cleaned mine while still under warranty. When it happened again, car was out of warranty and dealer wanted to replace. Very easy DIY on my 325i. May be a bit harder if you have oil cooler as the lines run just above the solenoids. Took mine out, sprayed on brake cleaner, and blew out with compressed air. It is recommended to replace the engine oil and filter after cleaning as there is some thought that the dirty oil makes a clog more likely.
Appreciate 0
      07-18-2012, 08:48 PM   #5
shiccobm
Neo
8

 
shiccobm's Avatar
 
Drives: 2007 335I
Join Date: Jul 2008
Location: GTA


Posts: 162
iTrader: (0)

I do have the paper work , it said replaced both Vanos units and they did do an oil change and changed the filter as well .
__________________
Road 1'er
Appreciate 0
      11-12-2012, 09:05 PM   #6
spool twice
Rainbow Racer
United_States
39

 
spool twice's Avatar
 
Drives: S65B40
Join Date: Sep 2010
Location: Sarasota, FL


Posts: 1,277
iTrader: (7)

i have a feeling mines going out as well. I've started to have a 'marbles' in a can sound at start-up for a couple seconds, it's like a warble-warble rattling noise. I've located the noise at the top of the engine up front, similar to the noise from my E46 m3, a car known for vanos cam-gear failure.
__________________
'15 IS350 F-sport Ultra White/Rioja Red
'09 E90 M3 7-DCT Interlagos Blue/Novillo Silver
[MS Pullies|K&N drop-in|Test Pipes |Evolve Stage II tune|Evolve Servotronic Map|Evolve M3 GTS-DCT file]
Now gone
Appreciate 0
      11-13-2012, 03:28 PM   #7
kevinM1971
New Member
1

 
Drives: 07 328xi
Join Date: Nov 2012
Location: New York


Posts: 23
iTrader: (0)

Quote:
Originally Posted by spool twice View Post
i have a feeling mines going out as well. I've started to have a 'marbles' in a can sound at start-up for a couple seconds, it's like a warble-warble rattling noise. I've located the noise at the top of the engine up front, similar to the noise from my E46 m3, a car known for vanos cam-gear failure.
Tell me more because I think I have the same exact problem
Appreciate 0
      11-13-2012, 07:13 PM   #8
m603
Second Lieutenant
8

 
m603's Avatar
 
Drives: avoiding pot holes
Join Date: Mar 2008
Location: NYC


Posts: 288
iTrader: (1)

^^ x2...
Appreciate 0
      11-13-2012, 07:27 PM   #9
DanielGonz
Lieutenant
14

 
Drives: AW E92 335i 6 speed
Join Date: Apr 2012
Location: SoCal (OC)


Posts: 564
iTrader: (0)

^^ x3... but only for a like half a second on startup. Ahhhhhh!!

Read this in a few threads "335i wastegates are open when the engine is off, but they close at idle / start.

It takes a few seconds for the vacuum pump to suck the wastgates closed and they rattle as they shut."
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:17 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST