E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Suspension | Brakes | Chassis > E92 xi KW V1 review/problem (spring clunk)



Reply
 
Thread Tools Search this Thread
      06-21-2012, 06:49 AM   #1
Eb_xi
New Member
United_States
1
Rep
9
Posts

 
Drives: 2008 335xi
Join Date: Jun 2012
Location: Massachusetts

iTrader: (0)

E92 xi KW V1 review/problem (spring clunk)

First off is the problem. When I turn my wheel either way I can hear the spring bind and clunk. I've search and I believe it's the strut bearing. It seemed fine when I installed them yesterday and didnt start making the noise until last night when I lowered my car about another inch. Idea's?

REVIEW: I'm going to try to answer all the questions people had that i couldnt find answers for. we'll for 1500$ they look as though they were made in a toy factory and I truly hate the plastic spring adjuster. Also if you raise the rear the top adjuster spins which you have to hold with something. It's the biggest PITA. Install was also kinda rough. I've got about a 1 inch wheel gap in the front and back. If you just put them in the back will be slammed and up ur front will have about a 1.5-2" wheel gap. As for lowering hight, I can bring my back down and tuck fender no problem. Same with the front, so if your wondering, yes you can slam the hell out of your car with these. Ride quality: my first thought was omg I can't believe these are coilovers. Feels like stock suspention on a 911. I've rides in a lot of cars with coilovers e9x e36 e46, my srt, my sti (both BC's) the bimmers were e46H&R (horrible) e36 idk e9x pss9 alright but the KW V1 blow all of these out of the water. I literally can't stop smiling when I drive my car. Beyond worth the 1500$ if your debating on buying these, just do it.
Appreciate 0
      06-24-2012, 10:14 PM   #2
Signal513
Sarging 24/7
Signal513's Avatar
3
Rep
360
Posts

 
Drives: e92 TiAg, 2014 Grand Cherokee
Join Date: Aug 2007
Location: Austin, TX

iTrader: (0)

Garage List
I just installed ST1s and had the same issue. I researched here and outside of the forums and it seems to be a fairly common thing with coilovers.

I installed a set of thruster bearings. The sounds are gone...

http://www.jegs.com/i/QA1/122/7888-109/10002/-1
__________________
HIIT and Weight Training:http://www.highintensityworkouts.org
30 Minute Workouts:http://www.maxworkoutsguide.com
Appreciate 0
      11-12-2012, 08:15 PM   #3
avenger2540
First Lieutenant
avenger2540's Avatar
United_States
5
Rep
398
Posts

 
Drives: 2014 F30 335i Xdrive
Join Date: Aug 2011
Location: boston

iTrader: (3)

Garage List
Quote:
Originally Posted by Signal513 View Post
I just installed ST1s and had the same issue. I researched here and outside of the forums and it seems to be a fairly common thing with coilovers.

I installed a set of thruster bearings. The sounds are gone...

http://www.jegs.com/i/QA1/122/7888-109/10002/-1
Hi there,question whrere u put those bearing, between the spring and the perch?
__________________
09 e92 335xi Alpine White, Saddle Interior, Sport pkg, Cold pkg, Comfort pkg, Premium pkg, Adactive Headlights, Black Kidney Grill, M3front, Mtech rear, M3side skirts, CF Performance spoiler, Kw v1, 19" M6 Replicas Hankook Ventus v12 evo...

Last edited by avenger2540; 11-13-2012 at 09:47 AM.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:42 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST