E90Post
 


Alpine HID
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Crankshaft sensor failure / malfunction on E90



Reply
 
Thread Tools Search this Thread
      11-13-2012, 09:32 AM   #1
makkan00
Major General
 
makkan00's Avatar
 
Drives: E90
Join Date: Dec 2011
Location: Essex

Posts: 6,076
iTrader: (37)

Crankshaft sensor failure / malfunction on E90

I am having few issues with my car (only 320i) since last week and here are those:

1- Car hesitates on acceleration and RPM drops for 1-2 seconds and regains it. It happens on heavy acceleration though.
2- As above, but car has died twice while on the road (dangerous). The only way to bring it back to life, is to find a safe place and and restart it after taking out / reinserting the key. Engine light comes on.
3- Car failed to start on one ocassion and long cranks on that ocassion.

Inpa suggests:
Crankshaft sensor error

(recorded three times in three different weather temperatures)

I have read few threads on it and my symptoms are similar to those who have had it.

I have already ordered the sensor today and it will be with me tomorrow.

Now on 320i / 325i/ 330i it is below manifold intake. Few threads suggest that it can be changed if you approach it under the engine (should have tiny hands though).

I have few questions:

1- Has anybody had the same issue? Can you share your experience?
2- Has anybody actually managed to change it by himself?
3- I have been quoted 180 + VAT by my local indy. I think that is a fair price considering if manifold has to be removed / tilted. Any suggestions on the price?


Any suggestions / experiences?
__________________
<img src=http://i1259.photobucket.com/albums/ii559/makkan00/New-6_zpscbec0353.jpg border=0 alt= />
RETROFITS: LCI Conversion - LCI Xenons - LCI Tail lights - Memory heated seats
- Folding mirrors with auto-dip - CIC DAB Plus - Combox - 6FL - 6NF - 6NR - BMW
live & Internet MODS: Eibach Sportsline - AluFelgens CS7 - MS-8 - SWS-8 - Gladen
makkan00 is offline   United Kingdom
0
Reply With Quote
      11-13-2012, 01:43 PM   #2
Dragon88
Private First Class
 
Dragon88's Avatar
 
Drives: BMW E92 320i M-Sport
Join Date: Jun 2012
Location: West London

Posts: 161
iTrader: (0)

Was this a recall on the 320i?
Dragon88 is offline   United Kingdom
0
Reply With Quote
      11-13-2012, 02:02 PM   #3
makkan00
Major General
 
makkan00's Avatar
 
Drives: E90
Join Date: Dec 2011
Location: Essex

Posts: 6,076
iTrader: (37)

Quote:
Originally Posted by Dragon88 View Post
Was this a recall on the 320i?
Not sure Dragon. Not according to VOSA
__________________
<img src=http://i1259.photobucket.com/albums/ii559/makkan00/New-6_zpscbec0353.jpg border=0 alt= />
RETROFITS: LCI Conversion - LCI Xenons - LCI Tail lights - Memory heated seats
- Folding mirrors with auto-dip - CIC DAB Plus - Combox - 6FL - 6NF - 6NR - BMW
live & Internet MODS: Eibach Sportsline - AluFelgens CS7 - MS-8 - SWS-8 - Gladen
makkan00 is offline   United Kingdom
0
Reply With Quote
      11-13-2012, 02:25 PM   #4
Dragon88
Private First Class
 
Dragon88's Avatar
 
Drives: BMW E92 320i M-Sport
Join Date: Jun 2012
Location: West London

Posts: 161
iTrader: (0)

Only reason I ask is because when I asked my dealer what recalls have been carried out on my car, they told me 'four coilpacks' and 'cam(something) sensor'.

Don't quite remember exactly what sensor they mentioned, perhaps worth giving them a call?

According to VOSA, the ignition coilpack recall is not listed.
Dragon88 is offline   United Kingdom
0
Reply With Quote
      11-13-2012, 02:29 PM   #5
makkan00
Major General
 
makkan00's Avatar
 
Drives: E90
Join Date: Dec 2011
Location: Essex

Posts: 6,076
iTrader: (37)

It happened again this evening. Same error.

I am glad that I kept my coding gear with me and after resetting the error, car started.

One symptom of crankshaft sensor failure is not charging the battery when car is running. (hope somebody can explain the reason for it)

And in depth of code reading revealed that on 2 ocassions my battery voltage dropped down to 10.6 volt.

Awaiting sensor delivery.
__________________
<img src=http://i1259.photobucket.com/albums/ii559/makkan00/New-6_zpscbec0353.jpg border=0 alt= />
RETROFITS: LCI Conversion - LCI Xenons - LCI Tail lights - Memory heated seats
- Folding mirrors with auto-dip - CIC DAB Plus - Combox - 6FL - 6NF - 6NR - BMW
live & Internet MODS: Eibach Sportsline - AluFelgens CS7 - MS-8 - SWS-8 - Gladen
makkan00 is offline   United Kingdom
0
Reply With Quote
      11-13-2012, 02:31 PM   #6
makkan00
Major General
 
makkan00's Avatar
 
Drives: E90
Join Date: Dec 2011
Location: Essex

Posts: 6,076
iTrader: (37)

Quote:
Originally Posted by Dragon88 View Post
Only reason I ask is because when I asked my dealer what recalls have been carried out on my car, they told me 'four coilpacks' and 'cam(something) sensor'.

Don't quite remember exactly what sensor they mentioned, perhaps worth giving them a call?

According to VOSA, the ignition coilpack recall is not listed.
Thanks mate. I asked them about recalls on my car when I bought this car.
The response was that coilpacks work has been carried out. No other recall is due on your car.

But I will still give them a call tomorrow.
__________________
<img src=http://i1259.photobucket.com/albums/ii559/makkan00/New-6_zpscbec0353.jpg border=0 alt= />
RETROFITS: LCI Conversion - LCI Xenons - LCI Tail lights - Memory heated seats
- Folding mirrors with auto-dip - CIC DAB Plus - Combox - 6FL - 6NF - 6NR - BMW
live & Internet MODS: Eibach Sportsline - AluFelgens CS7 - MS-8 - SWS-8 - Gladen
makkan00 is offline   United Kingdom
0
Reply With Quote
      11-15-2012, 05:51 PM   #7
badsha
Private
 
badsha's Avatar
 
Drives: BMW E90 318d 2006
Join Date: Nov 2010
Location: Norway

Posts: 87
iTrader: (0)

hey makkan gice of some pics of ur car how it looks like now
badsha is offline  
0
Reply With Quote
      04-18-2013, 04:06 PM   #8
jmaville
Private First Class
 
Drives: 335xi Sedan
Join Date: Oct 2011
Location: CT

Posts: 184
iTrader: (-1)

Garage List
What ended up happening I am having similar problems with my 335xi..... I have a subwoofer and amp installed in my car as well do you think that has anything do do with the sensor not functioning properly?
jmaville is online now  
0
Reply With Quote
      04-18-2013, 04:15 PM   #9
makkan00
Major General
 
makkan00's Avatar
 
Drives: E90
Join Date: Dec 2011
Location: Essex

Posts: 6,076
iTrader: (37)

Quote:
Originally Posted by jmaville
What ended up happening I am having similar problems with my 335xi..... I have a subwoofer and amp installed in my car as well do you think that has anything do do with the sensor not functioning properly?
Funny, you said that. I have 3 amplifiers and speakers / subs.
I don't think its to do with additional strain on the electrical system of the car.
Its more to do with contamination in the oil or high mileages cars.
I have added UV chemical in my oil to check any oil leaks but ended up having this issue.
Is your car on high mileages?
__________________
<img src=http://i1259.photobucket.com/albums/ii559/makkan00/New-6_zpscbec0353.jpg border=0 alt= />
RETROFITS: LCI Conversion - LCI Xenons - LCI Tail lights - Memory heated seats
- Folding mirrors with auto-dip - CIC DAB Plus - Combox - 6FL - 6NF - 6NR - BMW
live & Internet MODS: Eibach Sportsline - AluFelgens CS7 - MS-8 - SWS-8 - Gladen
makkan00 is offline   United Kingdom
0
Reply With Quote
      11-12-2013, 07:45 AM   #10
Mikex101
Private First Class
 
Drives: e90 320i
Join Date: Sep 2013
Location: england

Posts: 110
iTrader: (0)

Quote:
Originally Posted by makkan00 View Post
Funny, you said that. I have 3 amplifiers and speakers / subs.
I don't think its to do with additional strain on the electrical system of the car.
Its more to do with contamination in the oil or high mileages cars.
I have added UV chemical in my oil to check any oil leaks but ended up having this issue.
Is your car on high mileages?
Makkano

Did you get this sorted? Ive just ordered a sensor after a couple of dodgy moments this morning. Hoping its just the sensor, but im going to check the battery voltage now.

Thanks
Mikex101 is offline  
0
Reply With Quote
      11-12-2013, 07:47 AM   #11
makkan00
Major General
 
makkan00's Avatar
 
Drives: E90
Join Date: Dec 2011
Location: Essex

Posts: 6,076
iTrader: (37)

Quote:
Originally Posted by Mikex101 View Post
Makkano

Did you get this sorted? Ive just ordered a sensor after a couple of dodgy moments this morning. Hoping its just the sensor, but im going to check the battery voltage now.

Thanks
Yes, its sorted mate.
makkan00 is offline   United Kingdom
0
Reply With Quote
      11-12-2013, 07:53 AM   #12
Mikex101
Private First Class
 
Drives: e90 320i
Join Date: Sep 2013
Location: england

Posts: 110
iTrader: (0)

Quote:
Originally Posted by makkan00 View Post
Yes, its sorted mate.
And was it the crankshaft sensor?
Mikex101 is offline  
0
Reply With Quote
      11-12-2013, 09:58 AM   #13
makkan00
Major General
 
makkan00's Avatar
 
Drives: E90
Join Date: Dec 2011
Location: Essex

Posts: 6,076
iTrader: (37)

Quote:
Originally Posted by Mikex101
Quote:
Originally Posted by makkan00 View Post
Yes, its sorted mate.
And was it the crankshaft sensor?
Yes.
__________________
<img src=http://i1259.photobucket.com/albums/ii559/makkan00/New-6_zpscbec0353.jpg border=0 alt= />
RETROFITS: LCI Conversion - LCI Xenons - LCI Tail lights - Memory heated seats
- Folding mirrors with auto-dip - CIC DAB Plus - Combox - 6FL - 6NF - 6NR - BMW
live & Internet MODS: Eibach Sportsline - AluFelgens CS7 - MS-8 - SWS-8 - Gladen
makkan00 is offline   United Kingdom
0
Reply With Quote
      11-12-2013, 10:57 AM   #14
Russbmw
First Lieutenant
 
Russbmw's Avatar
 
Drives: '09 e92 335
Join Date: Aug 2013
Location: Surrey, UK

Posts: 305
iTrader: (0)

Just to add a bit incase anyone reads this in future.

I was going to say, yes sounds like a suspect crank sensor.

I had one fail on my e39 528, and the symntoms were very similar as it was failing - especially the random loss of power/hesitancy on acceleration and the long cranking to start.
__________________
Make it idiot proof, and someone will build a better idiot.

Click here for my detailing page!
Russbmw is offline   United Kingdom
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:59 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST