E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Cosmetic and Lighting Modifications (exterior/interior) > REVIEW: IJDMTOY Cree 10W angel eye LED H8 bulbs



Reply
 
Thread Tools Search this Thread
      04-23-2012, 01:03 PM   #1
EvolvedMR
New Member
 
Drives: 2009 328i xdrive
Join Date: Apr 2012
Location: B-more

Posts: 6
iTrader: (0)

REVIEW: IJDMTOY Cree 10W angel eye LED H8 bulbs

My review of the IJDMTOY Cree 10 watt LED H8 Angel Eye bulbs:

After ordering it took a full 24 hours to ship so my two day shipping upgrade was somewhat wasted.

the units as received looked very well manufactured, the bulbs are machined out of aluminum. My only complaint was the flimsy connectors and tiny wiring used to connect the bulb to the power supply and the resistor (i imagine) to the connector. One of the units had to have the pins actually installed in the connector as it was loose upon receipt.

After installing they actually looked great (i will post pics later as I only have phone shots) brighter than stock halogens and very even inner to outer. I was initially very please with the outcome.

However, after one day of use I received a code on my dash that the running lamp was out. upon inspection the right side had already burnt out. because of the wiring, i removed the unit and did a double check on the connections. the power supply was burning HOT!! I allowed it to cool, reinstalled, and even tried the left side to no avail. reconnected the stock halogen and it worked fine, so no fuse blown.

Unfortunately for me had to wait the weekend to contact the company. they were nice enough, but asked me to install the various parts in the left side to trouble shoot and identify the faulty part. I asked that they just send a replacement. I was told that i must return the faulty bulb before a replacement would be sent, and that a replacement may take a few weeks as they are sold out!!! to add insult to injury when I asked them to email a label so I could return the bulb I was told i had to return at my expense.

Will keep you all posted on the outcome, but not so happy right now.






Last edited by EvolvedMR; 04-23-2012 at 05:35 PM. Reason: added pics, update title.
EvolvedMR is offline   United_States
0
Reply With Quote
      04-23-2012, 05:36 PM   #2
EvolvedMR
New Member
 
Drives: 2009 328i xdrive
Join Date: Apr 2012
Location: B-more

Posts: 6
iTrader: (0)

update added pics. cloudy and rainy out. looks brighter in person to me than pictures show.
EvolvedMR is offline   United_States
0
Reply With Quote
      04-23-2012, 06:06 PM   #3
EvolvedMR
New Member
 
Drives: 2009 328i xdrive
Join Date: Apr 2012
Location: B-more

Posts: 6
iTrader: (0)

more pics - 7PM no flash on the camera.






EvolvedMR is offline   United_States
0
Reply With Quote
      05-06-2012, 02:45 PM   #4
Vesar
Lieutenant
 
Vesar's Avatar
 
Drives: 320i Ε92 M-Sport
Join Date: May 2011
Location: Thessaloniki, Greece

Posts: 488
iTrader: (0)

Garage List
2007 BMW 320i  [5.00]
Send a message via Yahoo to Vesar Send a message via Skype™ to Vesar
I think they look great but what about the burnt bulb? Will they replace it?
Vesar is offline   Greece
0
Reply With Quote
      05-06-2012, 03:48 PM   #5
Dziqsek_
Banned
 
Drives: e91 320d
Join Date: Feb 2012
Location: Jelenia Gora ( Lower Silesia )

Posts: 413
iTrader: (0)

On last photo LEd are almost invisible! Somethings wrong with them or its just something wrong with white balance ??
Dziqsek_ is offline   Poland
0
Reply With Quote
      05-06-2012, 04:21 PM   #6
FlashMonkey929
BMW Noob
 
FlashMonkey929's Avatar
 
Drives: 2011 AW E90 335i PPK
Join Date: Jan 2011
Location: Honolulu

Posts: 75
iTrader: (0)

White Balance wouldn't affect brightness that drastically in a photo. Looks like it was either shot at an angle where that side isn't illuminating straight towards the lens, or they were dimming already because of faulty parts.
FlashMonkey929 is offline   United_States
0
Reply With Quote
      05-08-2012, 02:49 PM   #7
EvolvedMR
New Member
 
Drives: 2009 328i xdrive
Join Date: Apr 2012
Location: B-more

Posts: 6
iTrader: (0)

I noticed that in taking multiple photos with a fast lens d-slr in some it seemed dimmer than others. I suspect that there is a high frequency flicker that is not apparent to the naked eye, similar to taking a picture of a television.
EvolvedMR is offline   United_States
0
Reply With Quote
      05-08-2012, 02:55 PM   #8
EvolvedMR
New Member
 
Drives: 2009 328i xdrive
Join Date: Apr 2012
Location: B-more

Posts: 6
iTrader: (0)

Update:

After shipping back at my cost, and their testing they agreed that the item was defective. I was told that the customer service reps boss was going to bring a unit from home as they did not have any to ship, WEIRD??

the following day I was told that they tested the components by switching the parts with a new unit, and discovered that it was working again. they suspected it was a connecton issue (see my orig post I did not like the flimsy connectors). they then said they were shipping my unit back to me. I said that i hope they tested in a vehicle and not just in a lab setting, because I feared the problem would return after being subjected to heat and vibration under normal operating conditions.

I received my unit back, reinstalled and it has been working for about a week now. I will follow up in another week or two with an updated picture for comparison.

Overall not 100% happy with the timing and the shipping policy, but the quality (aside from the connectors) is decent and it is a good value at $150.

we shall see
EvolvedMR is offline   United_States
0
Reply With Quote
      06-03-2012, 01:54 PM   #9
tomarse
New Member
 
Drives: E90 LCI 330i
Join Date: May 2012
Location: Austria

Posts: 8
iTrader: (0)

Are they still working?

And one more question...
the original halogen angel eyes look as if they are only set on parking light brightness (because corner leds are running and the angel eyes are too yellow for drl), is this right?

Could you maybe post some pictures where both bulbs (original and ijdmtoy led) are operating at drl brightness?
tomarse is offline  
0
Reply With Quote
      08-20-2012, 12:15 AM   #10
OMEGAPA
New Member
 
Drives: BMW 5 Series
Join Date: Aug 2012
Location: Pennsylvania

Posts: 5
iTrader: (0)

All these lights come from china

Here's where all these lights come from (CHINA JUNK)

http://product.madeinchina.com/super...13480872.shtml

I'm so disappointed! This is why it takes 3 weeks to get in when they are out of stock.

mine don't work either! They only work for about a month the die out.

Paid about 140 for these lights that should only be about 23 dollars.
OMEGAPA is offline  
0
Reply With Quote
      11-05-2012, 08:53 PM   #11
JasonDCarton
Captain
 
JasonDCarton's Avatar
 
Drives: BMW E90
Join Date: Jul 2012
Location: San Diego

Posts: 756
iTrader: (0)

Garage List
2006 BMW E90  [4.75]
I ordered the same 10w Cree, my right side went out 5 months later. any suggestions?
__________________
JasonDCarton is offline   United_States
0
Reply With Quote
      11-12-2012, 05:40 PM   #12
JasonDCarton
Captain
 
JasonDCarton's Avatar
 
Drives: BMW E90
Join Date: Jul 2012
Location: San Diego

Posts: 756
iTrader: (0)

Garage List
2006 BMW E90  [4.75]
Quote:
Originally Posted by EvolvedMR View Post
Update:

After shipping back at my cost, and their testing they agreed that the item was defective. I was told that the customer service reps boss was going to bring a unit from home as they did not have any to ship, WEIRD??

the following day I was told that they tested the components by switching the parts with a new unit, and discovered that it was working again. they suspected it was a connecton issue (see my orig post I did not like the flimsy connectors). they then said they were shipping my unit back to me. I said that i hope they tested in a vehicle and not just in a lab setting, because I feared the problem would return after being subjected to heat and vibration under normal operating conditions.

I received my unit back, reinstalled and it has been working for about a week now. I will follow up in another week or two with an updated picture for comparison.

Overall not 100% happy with the timing and the shipping policy, but the quality (aside from the connectors) is decent and it is a good value at $150.

we shall see

I had a very similar issue, I had these installed and 6 months later the right bulb burnt out. Not sure if it is a connector issue yet or the bulb, I will get it checked out when I get home. If the case is that it is burnt out, the company offered to re install 2 new ones for both headlights for 75$ flat. I was curious if your's still working?
__________________
JasonDCarton is offline   United_States
0
Reply With Quote
      11-13-2012, 01:26 PM   #13
LuxAngelEyes
BimmerPost Supporting Vendor

 
LuxAngelEyes's Avatar
 
Drives: 2006 325xi, Sparkling Graphite
Join Date: Jan 2011
Location: New Haven, CT

Posts: 3,028
iTrader: (12)

If these keep failing we also offer our LUX E90 LCI Halogen angel eyes
LuxAngelEyes is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:09 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST