E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > LED Dome Lights will not stay on Please Help



Reply
 
Thread Tools Search this Thread
      03-05-2012, 08:08 PM   #1
KNmiami
Enlisted Member
 
Drives: 335i
Join Date: Feb 2012
Location: Miami

Posts: 38
iTrader: (0)

LED Dome Lights will not stay on Please Help

I have a 2011 E90. I just installed a LED light kit. Every light works just fine except for when the car is ON. i turn the Dome light on all the lights come on just fine then after 10 secs the front and back dome lights turn off and will not turn back on till you turn the car off. All the other light still turn on and off. Anyone run into this problem? I tried putting the original light back in to see if it would light but no luck.
KNmiami is offline  
0
Reply With Quote
      03-05-2012, 08:19 PM   #2
MrRetep
First Lieutenant
 
MrRetep's Avatar
 
Drives: 435i M-Sport
Join Date: Jan 2012
Location: Irvine CA

Posts: 358
iTrader: (3)

Same problem, no solution.
MrRetep is offline  
0
Reply With Quote
      03-05-2012, 08:26 PM   #3
VMRWheels
BimmerPost Supporting Vendor

 
VMRWheels's Avatar
 
Drives: BMW
Join Date: Jun 2007
Location: Anaheim, CA

Posts: 13,493
iTrader: (4)

Garage List
2014 BMW F22  [0.00]
2013 BMW F06  [0.00]
2013 BMW F30  [0.00]
What an odd problem. It's probably something to do with resistors between certain bulbs.
__________________

VMR | Wheels - Mitch A. | p. 714-442-7916 extension 107 | e. Mitch@velocitymotoring.com | ** VMR Winter Wheel/Tire Sale! **
VMRWheels is offline  
0
Reply With Quote
      11-13-2012, 07:47 PM   #4
BLK_ATL335
Private
 
BLK_ATL335's Avatar
 
Drives: Black LCI
Join Date: Mar 2012
Location: ATL

Posts: 95
iTrader: (1)

Bump for a problem that never got a solution. I'm having this issue now and I must say it is quite annoying.
__________________
2009 Black E90 /navi/L7/and much more/mods to come
BLK_ATL335 is offline   United_States
0
Reply With Quote
      11-13-2012, 07:49 PM   #5
DetectiveLoki
Second Lieutenant
 
DetectiveLoki's Avatar
 
Drives: 2008 BMW 335i Convertible
Join Date: Jan 2012
Location: Orange County - SOCAL

Posts: 297
iTrader: (4)

Could it possibly be that the LED is bad quality?
DetectiveLoki is online now  
0
Reply With Quote
      11-13-2012, 07:59 PM   #6
SilverII
Colonel
 
Drives: '11 335IS
Join Date: Jun 2010
Location: DFW

Posts: 2,336
iTrader: (0)

Garage List
2011 BMW 335IS  [4.83]
get some LED with resistor built in. It is not pulling enough juice and the car is turning the light off
SilverII is offline   United_States
0
Reply With Quote
      11-13-2012, 08:34 PM   #7
jacobsed
Lieutenant
 
Drives: 2006 330xi
Join Date: Feb 2012
Location: United States

Posts: 425
iTrader: (2)

I got mine from topgearsolutions and it works great.
jacobsed is offline  
0
Reply With Quote
      11-13-2012, 09:08 PM   #8
Dark_Knight_335
Came to the N55 Darkside
 
Dark_Knight_335's Avatar
 
Drives: 2011 335 E93 M-Sport
Join Date: May 2010
Location: NY/NJ

Posts: 10,144
iTrader: (26)

I did have this problem once and ended up getting a third-party Chinese LED canbus peanut bulb to solve the issue.
Dark_Knight_335 is offline   United_States
0
Reply With Quote
      11-13-2012, 11:32 PM   #9
idrift4wd
Brigadier General
 
Drives: Three Hundred and Thirty Five
Join Date: Jul 2010
Location: Yonkers NY

Posts: 3,334
iTrader: (0)

Garage List
2007 BMW  [3.50]
solution=canbus light. if have canbus light you need canbus type 2 light. earlier model cars still have some issues but works 95% of the time.
idrift4wd is offline  
0
Reply With Quote
      11-14-2012, 07:14 AM   #10
Dark_Knight_335
Came to the N55 Darkside
 
Dark_Knight_335's Avatar
 
Drives: 2011 335 E93 M-Sport
Join Date: May 2010
Location: NY/NJ

Posts: 10,144
iTrader: (26)

High-performance bulbs supposedly had a canbus dome light guaranteed to work (both the high powered and regular dome). I tried both, they did not work for me (2011 E93).
Dark_Knight_335 is offline   United_States
0
Reply With Quote
      11-14-2012, 01:05 PM   #11
KNmiami
Enlisted Member
 
Drives: 335i
Join Date: Feb 2012
Location: Miami

Posts: 38
iTrader: (0)

I got a kit from Modmy3 and it works great.. Never have a problem now.
KNmiami is offline  
0
Reply With Quote
      11-14-2012, 03:16 PM   #12
mump
Second Lieutenant
 
mump's Avatar
 
Drives: '11 E93 335is/'01 986S/'13 F30
Join Date: Jul 2012
Location: Johnstown, PA

Posts: 284
iTrader: (5)

^ same here. Modmy3 ones work great for me.
mump is offline   United_States
0
Reply With Quote
      11-14-2012, 03:32 PM   #13
Dark_Knight_335
Came to the N55 Darkside
 
Dark_Knight_335's Avatar
 
Drives: 2011 335 E93 M-Sport
Join Date: May 2010
Location: NY/NJ

Posts: 10,144
iTrader: (26)

Those failed as well.
Dark_Knight_335 is offline   United_States
0
Reply With Quote
      11-15-2012, 08:22 PM   #14
KNmiami
Enlisted Member
 
Drives: 335i
Join Date: Feb 2012
Location: Miami

Posts: 38
iTrader: (0)

did you install them right? that was a problem i ran into at first.
KNmiami is offline  
0
Reply With Quote
      11-15-2012, 08:38 PM   #15
Dark_Knight_335
Came to the N55 Darkside
 
Dark_Knight_335's Avatar
 
Drives: 2011 335 E93 M-Sport
Join Date: May 2010
Location: NY/NJ

Posts: 10,144
iTrader: (26)

Yep. Flipped them around, the whole nine.
2011 E93s are finicky it seems...
Dark_Knight_335 is offline   United_States
0
Reply With Quote
      11-15-2012, 08:41 PM   #16
e90328i
Banned
 
Drives: 07 E90 335i
Join Date: May 2011
Location: socal

Posts: 387
iTrader: (4)

my 07 does the same i could care less as logn as they come on when i unlock the car
e90328i is offline  
0
Reply With Quote
      11-16-2012, 07:16 AM   #17
mump
Second Lieutenant
 
mump's Avatar
 
Drives: '11 E93 335is/'01 986S/'13 F30
Join Date: Jul 2012
Location: Johnstown, PA

Posts: 284
iTrader: (5)

Quote:
Originally Posted by Dark_Knight_335 View Post
Yep. Flipped them around, the whole nine.
2011 E93s are finicky it seems...
Mine is a '11 E93.... still no issues.
mump is offline   United_States
0
Reply With Quote
      11-16-2012, 07:26 AM   #18
shiori
Registered
 
Drives: E93 335
Join Date: Apr 2012
Location: Taiwan

Posts: 3
iTrader: (0)

have the same issue
shiori is offline  
0
Reply With Quote
      11-16-2012, 07:27 AM   #19
Dark_Knight_335
Came to the N55 Darkside
 
Dark_Knight_335's Avatar
 
Drives: 2011 335 E93 M-Sport
Join Date: May 2010
Location: NY/NJ

Posts: 10,144
iTrader: (26)

Quote:
Originally Posted by mump
Quote:
Originally Posted by Dark_Knight_335 View Post
Yep. Flipped them around, the whole nine.
2011 E93s are finicky it seems...
Mine is a '11 E93.... still no issues.
If you lived close to me, I'd buy em off ya
But they still probably wouldn't work.
Dark_Knight_335 is offline   United_States
0
Reply With Quote
      11-16-2012, 07:36 AM   #20
mump
Second Lieutenant
 
mump's Avatar
 
Drives: '11 E93 335is/'01 986S/'13 F30
Join Date: Jul 2012
Location: Johnstown, PA

Posts: 284
iTrader: (5)

you can come get them - i'll even pick you up at the airport. we'll drive the e93 the way it suppose to be driven.
mump is offline   United_States
0
Reply With Quote
      11-16-2012, 07:49 AM   #21
Dark_Knight_335
Came to the N55 Darkside
 
Dark_Knight_335's Avatar
 
Drives: 2011 335 E93 M-Sport
Join Date: May 2010
Location: NY/NJ

Posts: 10,144
iTrader: (26)

Haha, it's cool man. My peanut bulb is working just fine. Much appreciated though
Dark_Knight_335 is offline   United_States
0
Reply With Quote
      11-16-2012, 08:06 AM   #22
mump
Second Lieutenant
 
mump's Avatar
 
Drives: '11 E93 335is/'01 986S/'13 F30
Join Date: Jul 2012
Location: Johnstown, PA

Posts: 284
iTrader: (5)

Ok, your loss. I would have let you go out on the 'Ring. Tough titty to you.
mump is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:29 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST