E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Bulb is good but still not working .. Please Help!



Reply
 
Thread Tools Search this Thread
      01-07-2012, 05:21 PM   #1
///Chris
Enlisted Member
3
Rep
35
Posts

 
Drives: '07 328xi
Join Date: Jul 2011
Location: East Coast

iTrader: (0)

Bulb is good but still not working .. Please Help!

I began getting a "Left taillight malfunction" warning. The warning comes and goes but the light simply doesn't work. I determined that it's the highest light in the headlight assembly - the same one as the brake light but it comes on with all the lights and half the brightness of the brake light.

The bulb is good and it works when I apply brakes, so obviously I know it's good. But when I let off the brakes, if the lights are on, the right side stays illuminated but the left doesn't.

Anyone have any idea how to fix this?? It's a 921 bulb, not one of the LEDs.

Last edited by ///Chris; 01-07-2012 at 05:34 PM.
Appreciate 0
      01-08-2012, 02:02 PM   #2
Chriztofor
Colonel
Chriztofor's Avatar
United_States
42
Rep
2,720
Posts

 
Drives: '06 325i Auto
Join Date: Feb 2010
Location: Chicago Burbs

iTrader: (1)

It may be the socket. My passenger side turn signal socket was burnt. Take out the bulb and take a look on the inside to see if the contacts are burnt or rusted/rotted. By the way, they are cheap to replace, about $8 at the dealer. NO CUTTING OF WIRES REQUIRED.
__________________
If no codes are being thrown use Chevron Techron fuel injector cleaner (concentrate). It solves rpm fluctuating upon cold start-up. Also, for most BMW problems start off by scanning your car with the Peake Research Tool. It contains the actual BMW codes. If you want to register a newly installed battery for free (just buy a $10 cable) and google/download BMWLogger
Appreciate 0
      01-08-2012, 02:09 PM   #3
avocet
Lieutenant
6
Rep
565
Posts

 
Drives: 2007 328i
Join Date: Sep 2010
Location: Vancouver bc

iTrader: (0)

and it might be a dual filament bulb. your brake light is still functioning but your running light has burnt out?
Appreciate 0
      01-08-2012, 02:11 PM   #4
///Chris
Enlisted Member
3
Rep
35
Posts

 
Drives: '07 328xi
Join Date: Jul 2011
Location: East Coast

iTrader: (0)

Quote:
Originally Posted by Chriztofor View Post
It may be the socket. My passenger side turn signal socket was burnt. Take out the bulb and take a look on the inside to see if the contacts are burnt or rusted/rotted. By the way, they are cheap to replace, about $8 at the dealer. NO CUTTING OF WIRES REQUIRED.

Thanks for the reply. I did look at the socket and it looks like new. Plus the bulb/socket works when braking, so I have no idea what's going on.
Appreciate 0
      01-08-2012, 02:17 PM   #5
///Chris
Enlisted Member
3
Rep
35
Posts

 
Drives: '07 328xi
Join Date: Jul 2011
Location: East Coast

iTrader: (0)

Quote:
Originally Posted by avocet View Post
and it might be a dual filament bulb. your brake light is still functioning but your running light has burnt out?
Correct ... I replaced the bulb (with a 921 - according to the dealer); and still, it works as a brake light but not as a "running light" (thanks, couldn't figure out what to call it - running light though)

I also tried switching the lights with the other side, which works properly, and still the running light doesn't come on so I'm wondering if there's a fuse just for that side's running light somewhere?

And finally, the warning light no longer comes on but the running light is still out ... so I'm thoroughly confused
Appreciate 0
      01-08-2012, 02:18 PM   #6
Chriztofor
Colonel
Chriztofor's Avatar
United_States
42
Rep
2,720
Posts

 
Drives: '06 325i Auto
Join Date: Feb 2010
Location: Chicago Burbs

iTrader: (1)

For the hell of it, try switching bulbs around.
__________________
If no codes are being thrown use Chevron Techron fuel injector cleaner (concentrate). It solves rpm fluctuating upon cold start-up. Also, for most BMW problems start off by scanning your car with the Peake Research Tool. It contains the actual BMW codes. If you want to register a newly installed battery for free (just buy a $10 cable) and google/download BMWLogger
Appreciate 0
      01-08-2012, 02:19 PM   #7
Chriztofor
Colonel
Chriztofor's Avatar
United_States
42
Rep
2,720
Posts

 
Drives: '06 325i Auto
Join Date: Feb 2010
Location: Chicago Burbs

iTrader: (1)

Quote:
Originally Posted by ///Chris View Post
Correct ... I replaced the bulb (with a 921 - according to the dealer); and still, it works as a brake light but not as a "running light" (thanks, couldn't figure out what to call it - running light though)
Oh, wow, that is weird.
__________________
If no codes are being thrown use Chevron Techron fuel injector cleaner (concentrate). It solves rpm fluctuating upon cold start-up. Also, for most BMW problems start off by scanning your car with the Peake Research Tool. It contains the actual BMW codes. If you want to register a newly installed battery for free (just buy a $10 cable) and google/download BMWLogger
Appreciate 0
      01-08-2012, 02:20 PM   #8
Chriztofor
Colonel
Chriztofor's Avatar
United_States
42
Rep
2,720
Posts

 
Drives: '06 325i Auto
Join Date: Feb 2010
Location: Chicago Burbs

iTrader: (1)

Ok, did you mod the lights in any way? If so then there is your problem.
__________________
If no codes are being thrown use Chevron Techron fuel injector cleaner (concentrate). It solves rpm fluctuating upon cold start-up. Also, for most BMW problems start off by scanning your car with the Peake Research Tool. It contains the actual BMW codes. If you want to register a newly installed battery for free (just buy a $10 cable) and google/download BMWLogger
Appreciate 0
      01-08-2012, 06:36 PM   #9
///Chris
Enlisted Member
3
Rep
35
Posts

 
Drives: '07 328xi
Join Date: Jul 2011
Location: East Coast

iTrader: (0)

Nope, they're bone stock ... here's a pic:



It's the top part that doesn't light up (except when I brake), but it won't come on when I unlock the car, whereas the driver side does
Appreciate 0
      01-08-2012, 06:55 PM   #10
avocet
Lieutenant
6
Rep
565
Posts

 
Drives: 2007 328i
Join Date: Sep 2010
Location: Vancouver bc

iTrader: (0)

do you have a multimeter or circuit tester? see if there is voltage at the socket. maybe the terminal inside the socket is a little bent back or something that is prevent contact.
Appreciate 0
      01-08-2012, 09:38 PM   #11
CubanJJ09
Banned
United_States
133
Rep
12,692
Posts

 
Drives: like an asshole
Join Date: Feb 2008
Location: Chicago Burbs

iTrader: (2)

Garage List
2007 BMW 335i  [3.09]
Send a message via AIM to CubanJJ09
Buy a whole new light assembly its 20-30 bucks. It'll save you the headache
Appreciate 0
      01-08-2012, 09:41 PM   #12
fdriller9
Banned
United_States
103
Rep
7,090
Posts

 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

iTrader: (4)

Garage List
2006 330xi  [3.22]
There was a service bulletin out for a faulty bulb holder. But I think your problem is with the lines? They can't be replaced. At least to my knowledge.
Appreciate 0
      01-09-2012, 06:43 PM   #13
///Chris
Enlisted Member
3
Rep
35
Posts

 
Drives: '07 328xi
Join Date: Jul 2011
Location: East Coast

iTrader: (0)

Thanks everyone for the help.

So I went to the dealer and the service dude comes out like he's in a huge hurry and I'm a big waste of his time and takes one look at it and says condescendingly, "Your light's not out, that's a European fog light" and he walks away.

Anyway, I get him back and show him it's definitely not a fog light and he says I'll have to bring it in .. so I guess I'll try replacing the fixture and hopefully that fixes it cause I'm definitely not gonna let BMW charge me probably $400 to fix a "European fog light"
Appreciate 0
      01-09-2012, 07:35 PM   #14
Hey Ant
Form & Function
Hey Ant's Avatar
United_States
32
Rep
2,088
Posts

 
Drives: AWE92
Join Date: Nov 2010
Location: 818 Los Angeles

iTrader: (15)

Quote:
Originally Posted by ********* View Post
There was a service bulletin out for a faulty bulb holder. But I think your problem is with the lines? They can't be replaced. At least to my knowledge.
soo does that mean the dealer will replace the bad unit even though most of us are out of warranty?
Appreciate 0
      01-09-2012, 07:55 PM   #15
Juiced46
Major
20
Rep
1,032
Posts

 
Drives: 03 Turbo Cobra, 2011 335xi
Join Date: Jun 2010
Location: Wallingford CT

iTrader: (3)

Quote:
Originally Posted by Hey Ant View Post
soo does that mean the dealer will replace the bad unit even though most of us are out of warranty?
No, that would be a recall. Bulletins do not apply and if you are out of warranty you pay.

Its most likely a bad bulb holder or worst case a bad FRM. Can you get me the part # off of the sticker on it? There is a white sticker on the bulb holder, I can tell you if its a newer or older style. Can you turn on the lights take a pic and show me which one you are seeing on and off on both sides.
Appreciate 0
      01-09-2012, 08:59 PM   #16
fdriller9
Banned
United_States
103
Rep
7,090
Posts

 
Drives: '06 AW 330xi
Join Date: Mar 2009
Location: North Jersey/Philly/NYC

iTrader: (4)

Garage List
2006 330xi  [3.22]
Quote:
Originally Posted by Juiced46 View Post
No, that would be a recall. Bulletins do not apply and if you are out of warranty you pay.

Its most likely a bad bulb holder or worst case a bad FRM. Can you get me the part # off of the sticker on it? There is a white sticker on the bulb holder, I can tell you if its a newer or older style. Can you turn on the lights take a pic and show me which one you are seeing on and off on both sides.
Nail on the head.
Appreciate 0
      01-09-2012, 11:11 PM   #17
TheTal0n
Lieutenant
TheTal0n's Avatar
9
Rep
535
Posts

 
Drives: 2006 330i
Join Date: Sep 2011
Location: Utah

iTrader: (0)

Buy a new bulb and plug it in, or plug it into the right tail lamp. and see if the code goes away. If that doesnt work check your light bulb fluid.
Appreciate 0
      01-09-2012, 11:22 PM   #18
Express
Major General
Express's Avatar
Israel
129
Rep
8,701
Posts

 
Drives: 06 330i
Join Date: Dec 2008
Location: The Promise Land

iTrader: (17)

Garage List
2006 BMW 330i  [4.15]
sounds like a two stage bulb and one is out.
Appreciate 0
      01-10-2012, 07:45 AM   #19
Juiced46
Major
20
Rep
1,032
Posts

 
Drives: 03 Turbo Cobra, 2011 335xi
Join Date: Jun 2010
Location: Wallingford CT

iTrader: (3)

Quote:
Originally Posted by TheTal0n View Post
Buy a new bulb and plug it in, or plug it into the right tail lamp. and see if the code goes away. If that doesnt work check your light bulb fluid.
I really hope this is a joke
Appreciate 0
      01-10-2012, 08:32 AM   #20
Timothy J
Captain
Timothy J's Avatar
United_States
11
Rep
732
Posts

 
Drives: 08 335xi
Join Date: Sep 2010
Location: West Point, NY

iTrader: (1)

Garage List
2008 BMW 335xi  [0.00]
I'd be willing to bet it's that service bulletin. I had mine done too.
__________________
2001 Chevy 2500HD Duramax
2008 BMW 335xi Coupe 6MT | Jet Black | Loaded Sold
Appreciate 0
      01-10-2012, 08:40 PM   #21
///Chris
Enlisted Member
3
Rep
35
Posts

 
Drives: '07 328xi
Join Date: Jul 2011
Location: East Coast

iTrader: (0)

Quote:
Originally Posted by Juiced46 View Post
No, that would be a recall. Bulletins do not apply and if you are out of warranty you pay.

Its most likely a bad bulb holder or worst case a bad FRM. Can you get me the part # off of the sticker on it? There is a white sticker on the bulb holder, I can tell you if its a newer or older style. Can you turn on the lights take a pic and show me which one you are seeing on and off on both sides.
Here are pics: you can see it out when the brakes aren't on then it comes on with the breaks
Attached Images
  
Appreciate 0
      01-15-2012, 04:27 PM   #22
Juiced46
Major
20
Rep
1,032
Posts

 
Drives: 03 Turbo Cobra, 2011 335xi
Join Date: Jun 2010
Location: Wallingford CT

iTrader: (3)

Something is not right. That light on the left upper part of the taillight is NOT supposed to come on with just the lights on. That is the brake light. I'm still guessing there is something wrong with that bulb holder.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:57 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST