E90Post
 


Bimmertech
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > 1/2 CEL at 4500 to 5000 RPM w/o JB4



Reply
 
Thread Tools Search this Thread
      12-08-2012, 06:03 PM   #1
GTstunna612
Lieutenant
 
GTstunna612's Avatar
 
Drives: BMW
Join Date: Feb 2008
Location: Tampa, FL

Posts: 404
iTrader: (0)

Garage List
E90 335i  [0.00]
Exclamation 1/2 CEL at 4500 to 5000 RPM w/o JB4

Hello all I just had my E90 335i with 60K in at the dealer for a new transmission gasket and mechatronic sleeve. They did a full inspection and found that my oil filter housing is leaking which I will fix on my own. Before taking the car in I removed my JB4 just to be on the safe side. Well today I was driving on the highway and everytime I punch it at any speed from 4500 to 5000 RPM the 1/2 CEL comes on without the JB4 installed. Feels like the car goes into limp mode when the 1/2 CEL is on. The only way I can get it back to normal is if I shut the car off and restart it. No long cranks at startup or any other thing unusal. Not sure what to do or if the stealership did anything weird and I don't have any CPO.
__________________
E90 335i Alpine White, Cyba Scoops, JB4 G5, BMS DCI, Alpina AT Flash, New OEM Turbos
E90 328i Titanium Silver
GTstunna612 is offline   United_States
0
Reply With Quote
      12-08-2012, 06:11 PM   #2
Beemw335
Colonel
 
Drives: 335i
Join Date: Mar 2011
Location: My car is my home

Posts: 2,016
iTrader: (2)

Reinstall your jb4 so that you can read the codes.
Beemw335 is offline  
0
Reply With Quote
      12-08-2012, 06:14 PM   #3
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,266
iTrader: (5)

Send a message via Yahoo to cn555ic
Its exactly like my symptoms of my car when my Low pressure sensor was bad and needed to be replaced...Here is the thread. You also need to check for codes and if you see 29DC or 29F3 there is your issue!

http://www.e90post.com/forums/showthread.php?t=724147
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      12-08-2012, 06:14 PM   #4
GTstunna612
Lieutenant
 
GTstunna612's Avatar
 
Drives: BMW
Join Date: Feb 2008
Location: Tampa, FL

Posts: 404
iTrader: (0)

Garage List
E90 335i  [0.00]
Quote:
Originally Posted by Beemw335 View Post
Reinstall your jb4 so that you can read the codes.
I was thinking about that but how about taking it to advance auto for a scan before installing the JB4? Before when the JB4 was installed no issued what so ever and car was running good
__________________
E90 335i Alpine White, Cyba Scoops, JB4 G5, BMS DCI, Alpina AT Flash, New OEM Turbos
E90 328i Titanium Silver
GTstunna612 is offline   United_States
0
Reply With Quote
      12-08-2012, 06:18 PM   #5
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,266
iTrader: (5)

Send a message via Yahoo to cn555ic
Quote:
Originally Posted by GTstunna612 View Post
I was thinking about that but how about taking it to advance auto for a scan before installing the JB4? Before when the JB4 was installed no issued what so ever and car was running good
check the codes..That is first and foremost. I mean it could be a coincidence that this happened but like I said to really diagnose what the issue is, you need the fault codes from the DME
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      12-08-2012, 06:20 PM   #6
GTstunna612
Lieutenant
 
GTstunna612's Avatar
 
Drives: BMW
Join Date: Feb 2008
Location: Tampa, FL

Posts: 404
iTrader: (0)

Garage List
E90 335i  [0.00]
Quote:
Originally Posted by cn555ic View Post
Its exactly like my symptoms of my car when my Low pressure sensor was bad and needed to be replaced...Here is the thread. You also need to check for codes and if you see 29DC or 29F3 there is your issue!

http://www.e90post.com/forums/showthread.php?t=724147
yes I'm gonna have to get it scanned to see exactly what the issue is...was thinking about talking to my service advisor and taking it back in $$$
__________________
E90 335i Alpine White, Cyba Scoops, JB4 G5, BMS DCI, Alpina AT Flash, New OEM Turbos
E90 328i Titanium Silver
GTstunna612 is offline   United_States
0
Reply With Quote
      12-08-2012, 06:21 PM   #7
GTstunna612
Lieutenant
 
GTstunna612's Avatar
 
Drives: BMW
Join Date: Feb 2008
Location: Tampa, FL

Posts: 404
iTrader: (0)

Garage List
E90 335i  [0.00]
Quote:
Originally Posted by cn555ic View Post
check the codes..That is first and foremost. I mean it could be a coincidence that this happened but like I said to really diagnose what the issue is, you need the fault codes from the DME
yea I'm gonna have to do that
__________________
E90 335i Alpine White, Cyba Scoops, JB4 G5, BMS DCI, Alpina AT Flash, New OEM Turbos
E90 328i Titanium Silver
GTstunna612 is offline   United_States
0
Reply With Quote
      12-08-2012, 06:49 PM   #8
cn555ic
BimmerPost Supporting Vendor

 
cn555ic's Avatar
 
Drives: 917-939-4980
Join Date: Jun 2007
Location: New York

Posts: 18,266
iTrader: (5)

Send a message via Yahoo to cn555ic
If you have INPA working and have the Dcan cable this would be a quick diagnosis
__________________

Coding E and F New York 917-939-4980
cn555ic is offline   United_States
0
Reply With Quote
      12-08-2012, 06:59 PM   #9
GTstunna612
Lieutenant
 
GTstunna612's Avatar
 
Drives: BMW
Join Date: Feb 2008
Location: Tampa, FL

Posts: 404
iTrader: (0)

Garage List
E90 335i  [0.00]
Quote:
Originally Posted by cn555ic
If you have INPA working and have the Dcan cable this would be a quick diagnosis
I'm not sure what your talking about. Just took into Advance auto for a scan but they didn't find anything. I'm gonna reinstall the jb4 and see what happens. Not sure if its a vac leak, coils, plugs, or injectors. The car doesn't feel like a misfire
__________________
E90 335i Alpine White, Cyba Scoops, JB4 G5, BMS DCI, Alpina AT Flash, New OEM Turbos
E90 328i Titanium Silver
GTstunna612 is offline   United_States
0
Reply With Quote
      12-08-2012, 07:00 PM   #10
Jeff@TopGearSolutions
BimmerPost Supporting Vendor

 
Jeff@TopGearSolutions's Avatar
 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

Posts: 16,805
iTrader: (31)

Send a message via AIM to Jeff@TopGearSolutions
Just so we dont miss the obvious, if your spark plugs are older then 25K miles they may need replacement from misfires. As the spark plugs age the gap gets larger.
Jeff@TopGearSolutions is offline   United_States
0
Reply With Quote
      12-08-2012, 07:02 PM   #11
GTstunna612
Lieutenant
 
GTstunna612's Avatar
 
Drives: BMW
Join Date: Feb 2008
Location: Tampa, FL

Posts: 404
iTrader: (0)

Garage List
E90 335i  [0.00]
Quote:
Originally Posted by Jeff@topgearsolutions
Just so we dont miss the obvious, if your spark plugs are older then 25K miles they may need replacement from misfires. As the spark plugs age the gap gets larger.
Yea the plugs were replaced at 40k and the car now has 60,800 miles. Got that from the service files
__________________
E90 335i Alpine White, Cyba Scoops, JB4 G5, BMS DCI, Alpina AT Flash, New OEM Turbos
E90 328i Titanium Silver
GTstunna612 is offline   United_States
0
Reply With Quote
      12-08-2012, 07:49 PM   #12
GTstunna612
Lieutenant
 
GTstunna612's Avatar
 
Drives: BMW
Join Date: Feb 2008
Location: Tampa, FL

Posts: 404
iTrader: (0)

Garage List
E90 335i  [0.00]
Not sure what to do...gonna reinstall the jb4 and see what happens...hopefully I can read delete the code or auto clear it out.
__________________
E90 335i Alpine White, Cyba Scoops, JB4 G5, BMS DCI, Alpina AT Flash, New OEM Turbos
E90 328i Titanium Silver
GTstunna612 is offline   United_States
0
Reply With Quote
      12-09-2012, 09:23 PM   #13
GTstunna612
Lieutenant
 
GTstunna612's Avatar
 
Drives: BMW
Join Date: Feb 2008
Location: Tampa, FL

Posts: 404
iTrader: (0)

Garage List
E90 335i  [0.00]
giving you all a update not sure why the 1/2 CEL light came on, I reinstalled the jb4 and cleared the codes and now the car runs great. building boost and no limp mode even in the higher RPMs. will def keep an eye on it and check for codes...what a relief feel better now
__________________
E90 335i Alpine White, Cyba Scoops, JB4 G5, BMS DCI, Alpina AT Flash, New OEM Turbos
E90 328i Titanium Silver
GTstunna612 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:11 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST