E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N57 / M57 Turbo Diesel Discussions - 335d > Missing at idle on cold start



Reply
 
Thread Tools Search this Thread
      11-22-2012, 03:54 PM   #1
ihbase
Private
 
Drives: 335d
Join Date: Sep 2012
Location: Oregon

Posts: 70
iTrader: (0)

Missing at idle on cold start

40 degree overnight. Engine missing lightly on cold start and evens out as soon as it warms up. 5k miles. Anyone else with this issue? I'm guessing injector.

Other modern diesels run glow plugs or intake heater grid sometimes after startup without triggering the indicator light. Does this engine use glow plugs sometimes without illuminating the glow plug light? If so, could be a bad glow plug.

$0.35 premium for diesel today. Now a cylinder miss. Still hate the auto box. This appeal of this car is waning fast...

425 ft. lbs is pretty cool. But the car is beginning to feel more like a fashion accessory than a solid piece of equipment.

Has anyone else had an engine miss when cold and, if so, what was the remedy?

Thanks-

-Michael
ihbase is offline  
0
Reply With Quote
      11-24-2012, 06:35 PM   #2
SomeRandomer123
Colonel
 
SomeRandomer123's Avatar
 
Drives: F30 328i Luxury - Sport Auto
Join Date: May 2011
Location: Lancashire, North West England, UK

Posts: 2,539
iTrader: (0)

My old E90 LCI 330d did this.
Glow plug control unit failed.
On the diagnosis tool, it will say that all 6 glow plugs have failed but as you would expect, this is not the case and it's the control unit.
New one was fitted and it was good to go again!
__________________

Gone: 2006 BMW E60 520d SE 6MT
Gone: 2009 BMW E90-LCI 330d SE 6MT
Current: 2012 F30 328i Luxury 8AT
My 328i initial thoughts + media!http://www.f30post.com/forums/showthread.php?t=712673
SomeRandomer123 is offline   England
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:08 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST