E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Battery/Electrical Issues?



Reply
 
Thread Tools Search this Thread
      11-24-2012, 11:04 AM   #1
ir0nmanx
New Member
Philippines
0
Rep
11
Posts

 
Drives: 2013 328i
Join Date: Jun 2012
Location: Alhambra, CA

iTrader: (0)

Battery/Electrical Issues?

I have a 2007 328xi with 40000 miles and have been having problems with the car just suddenly dying when I turn the car off. This has happened 4 times, the car starts and drives without a problem but when I turn the engine off, it loses all power, nothing can be turned on, key stuck in ignition. I also had a case when I was driving on the freeway and the car loses power for a fraction of a second but comes back on.. . I did buy a battery charger that gave me the voltage, percentage and alternator reading. Its still at 12.3-12.7 voltage when the car is off and around 14.3 when on, battery percentage around 55-60, alternator reading at 100.

I've heard about cars not starting when the battery is dead but not when I turn the car off, the battery dies..

Any suggestions?
__________________
2013 F30 328i - Current
2007 E90 328xi - Sold
2001 S2000 - Sold
2001 E46 325ci - Sold
Appreciate 0
      11-24-2012, 01:49 PM   #2
mike3000fl
Colonel
mike3000fl's Avatar
United_States
40
Rep
2,376
Posts

 
Drives: 06 330i
Join Date: Feb 2010
Location: Tampa

iTrader: (0)

Do yourself (and others) a favor... do not drive that car until you get it fixed. Someone is going to get hurt.
__________________
2006 330i - Jet Black - 19" E46 M3 wheels - HR Sport - 206,000 Miles...

Appreciate 0
      11-24-2012, 04:53 PM   #3
PTinVT
armchair enthusiast
PTinVT's Avatar
United_States
13
Rep
596
Posts

 
Drives: 07 328xi, 02 325Cic
Join Date: Feb 2009
Location: Burlington, VT

iTrader: (1)

Do you get a low battery warning? Lately I've been getting the yellow battery icon after just (for example) listening to the radio for one minute after turning the car off, and occasionally right after turning the car off. I suspect my battery is dying, I also have a 2007 328 with 4x,xxx miles and I assume it's the original battery (bought 2009 CPO)
__________________
07 328xi coupe SG/Dakota leather, 6-speed manual, sport/premium/cold
02 325Cic vert AW/Montana leather, 5-speed manual, premium/removable hardtop
93 850Ci Oxford Green/Parchment, auto
71 Buick Riviera, 455 V8 land yacht
Appreciate 0
      11-24-2012, 05:06 PM   #4
BoStoNe90
Private First Class
BoStoNe90's Avatar
2
Rep
164
Posts

 
Drives: 2007 BMW 335xi
Join Date: Aug 2010
Location: Boston

iTrader: (0)

Could be this...... next time the car dies, go into the glove box and get to your fuse. There should be a thick red gauge wire on the right of the fuse box. Pull it back towards you and see if power comes back. If it does then this is your problem. The b cable is fried and you would need a new one and a new fuse box. Here's the link with a diy. http://www.e90post.com/forums/showth...=549735&page=5
Appreciate 0
      11-24-2012, 06:04 PM   #5
SpeedBuggy
Comfortably Numb
SpeedBuggy's Avatar
United_States
6
Rep
423
Posts

 
Drives: 06 e90 330i & 06 e90 325i
Join Date: Mar 2009
Location: Cortland, Ohio

iTrader: (0)

See Post #11
http://www.e90post.com/forums/showthread.php?t=566291
__________________
06 e90 330i /Alpine White/Terra Dakota Leather/Steptronic/Cold Weather Package/Premium Package/Sport Package/CA/PDC/Xenon/Logic 7/Style 162's

06 e90 325i /Jet Black/Black Leatherette/Steptronic/Cold Weather Package/Style 197's
Appreciate 0
      11-25-2012, 03:40 AM   #6
sebaNYC
Second Lieutenant
3
Rep
229
Posts

 
Drives: BMW 328xi
Join Date: Jan 2012
Location: New York

iTrader: (2)

I have the same car, same year, same issue, is the "distribution box" (fuse box) and the B+ cable (the one that's going from the battery to the fuse box.

The dealer was charging me more than $2200.

I bought the parts online, I went to an Indy shop (I knew the mechanic guy) after a few hours, my car running perfect, I spent $450 in total (parts and labor)

If u need more info pm me
Appreciate 0
      11-25-2012, 10:47 AM   #7
volkswackin
Lieutenant Colonel
United_States
19
Rep
1,914
Posts

 
Drives: too broke for a BMW
Join Date: Jan 2008
Location: i get around..

iTrader: (1)

Quote:
Originally Posted by sebaNYC View Post
I have the same car, same year, same issue, is the "distribution box" (fuse box) and the B+ cable (the one that's going from the battery to the fuse box.

The dealer was charging me more than $2200.

I bought the parts online, I went to an Indy shop (I knew the mechanic guy) after a few hours, my car running perfect, I spent $450 in total (parts and labor)

If u need more info pm me
its possibly the cable..id suggest you take it to a shop and have the cable inspected at the junction box...
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:42 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST