E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Cosmetic and Lighting Modifications (exterior/interior) > Please help! Headlight keeps flicking then shuts off



Reply
 
Thread Tools Search this Thread
      11-20-2012, 12:12 AM   #1
MyE92
El Presidente
 
MyE92's Avatar
 
Drives: your mom wild.
Join Date: May 2007
Location: NJ

Posts: 6,814
iTrader: (24)

Please help! Headlight keeps flicking then shuts off

Hi there,
I've had this problem on and off for a couple months now, but haven't had the chance to take a look at it.
So my driver side headlight seems to shut off while I'm driving. First it'll flicker, then a couple seconds/mins later it would shut off. The angel eyes and everything else stay on, but the headlight HID shuts off completely. When I turn the headlights off and on, it comes back on for a couple seconds/mins again, then shuts off. Sometimes when I hit a bump, it'll flicker then shut off

Has anyone else had this problem, or can think of what the problem might be?

Ballast? New HID bulbs?

Hope someone can help me!

Thanks!
MyE92 is offline   United_States
0
Reply With Quote
      11-20-2012, 08:47 AM   #2
Admir328xiCT
Private First Class
 
Drives: 2007 BMW 328xi
Join Date: Sep 2011
Location: Central Area of CT

Posts: 104
iTrader: (0)

Happen toe too. Soon it will completely go out and it's not fuse or bulb or ballast. Sounds like a module which apparently is like 1,200.

Keep me posted and ill let u know if I figure mine out. I will lost likely take it into BMW
Admir328xiCT is offline  
0
Reply With Quote
      11-20-2012, 08:32 PM   #3
MyE92
El Presidente
 
MyE92's Avatar
 
Drives: your mom wild.
Join Date: May 2007
Location: NJ

Posts: 6,814
iTrader: (24)

Quote:
Originally Posted by Admir328xiCT View Post
Happen toe too. Soon it will completely go out and it's not fuse or bulb or ballast. Sounds like a module which apparently is like 1,200.

Keep me posted and ill let u know if I figure mine out. I will lost likely take it into BMW
Do you have a E90 or E92/E93?
MyE92 is offline   United_States
0
Reply With Quote
      11-20-2012, 10:37 PM   #4
Admir328xiCT
Private First Class
 
Drives: 2007 BMW 328xi
Join Date: Sep 2011
Location: Central Area of CT

Posts: 104
iTrader: (0)

E90
Admir328xiCT is offline  
0
Reply With Quote
      11-21-2012, 02:21 PM   #5
willypongtb
Enlisted Member
 
Drives: e90 330i
Join Date: Sep 2011
Location: los alamitos

Posts: 34
iTrader: (0)

i have e90 330i. i have the same problem when i upgrade my hid. i have a bad hid doa after i replaced it. every thing works just fine for over a year now. hope you have the same problem i have.
willypongtb is offline   United_States
0
Reply With Quote
      11-22-2012, 11:21 AM   #6
MyE92
El Presidente
 
MyE92's Avatar
 
Drives: your mom wild.
Join Date: May 2007
Location: NJ

Posts: 6,814
iTrader: (24)

Can anyone help me out? I have an E93.
MyE92 is offline   United_States
0
Reply With Quote
      11-22-2012, 11:56 AM   #7
Dhoffm80
Private First Class
 
Drives: 09,e92,335i,6m,nav,sprt,cw,19"
Join Date: Sep 2012
Location: Hoover, AL

Posts: 100
iTrader: (0)

Quote:
Originally Posted by MyE92
Can anyone help me out? I have an E93.
Hello I've chased this around with my Audi doing the same thing it was the hid bulb going bad.
Would say left headlight dipped!

First I thought it was my level sensors cause I drove in deep snow and on unlplowed roads in Maine a lot. Then when to modules well long story short if it happens to one bulb swap them left to right and wait for the problem to change locations . Then you will need two new bulbs because they won't match the new will be brighter and different color then the older good bulb. Last go with a name brand bulb like Osram, Phillips or GE cause ebay and other sites generic brands are cheap plus they don't last that long may start to fail under a year and HID bulbs should let around 6yrs depending on use. The reason this happens with the cheap no name brands is because the salts they use are expensive so they don't use the correct amount or type causing bad hues in the beam, incorrect color and reduced life.

Last edited by Dhoffm80; 11-22-2012 at 12:11 PM.
Dhoffm80 is offline   United_States
0
Reply With Quote
      11-23-2012, 09:17 PM   #8
delacruzAAe90
New Member
 
Drives: 06 e90
Join Date: Nov 2012
Location: richmond

Posts: 24
iTrader: (0)

I started having this today?I drive a 06 e90! The right side Headlight was flickering and then shut off? Did you fix it already? What'd you do? And how much?
delacruzAAe90 is offline  
0
Reply With Quote
      11-28-2012, 12:27 AM   #9
MyE92
El Presidente
 
MyE92's Avatar
 
Drives: your mom wild.
Join Date: May 2007
Location: NJ

Posts: 6,814
iTrader: (24)

Anyone with an E92/E93 run into this problem?
MyE92 is offline   United_States
0
Reply With Quote
      12-06-2012, 01:12 AM   #10
MyE92
El Presidente
 
MyE92's Avatar
 
Drives: your mom wild.
Join Date: May 2007
Location: NJ

Posts: 6,814
iTrader: (24)

MyE92 is offline   United_States
0
Reply With Quote
      12-07-2012, 03:49 PM   #11
Admir328xiCT
Private First Class
 
Drives: 2007 BMW 328xi
Join Date: Sep 2011
Location: Central Area of CT

Posts: 104
iTrader: (0)

Quote:
Originally Posted by delacruzAAe90
I started having this today?I drive a 06 e90! The right side Headlight was flickering and then shut off? Did you fix it already? What'd you do? And how much?
When it goes out,,, you turn the car off and back on the light comes back on ?
Admir328xiCT is offline  
0
Reply With Quote
      01-11-2013, 12:11 AM   #12
MyE92
El Presidente
 
MyE92's Avatar
 
Drives: your mom wild.
Join Date: May 2007
Location: NJ

Posts: 6,814
iTrader: (24)

MyE92 is offline   United_States
0
Reply With Quote
      01-11-2013, 04:08 PM   #13
98RACE
Enlisted Member
 
Drives: 06 325i
Join Date: Apr 2012
Location: Burlington, Ont

Posts: 45
iTrader: (0)

I had the same issue, new bulbs fixed the problem.
__________________
Dave
06 325i
98RACE is offline  
0
Reply With Quote
      01-13-2013, 06:53 PM   #14
hobbymike
New Member
 
Drives: 06 325i Sparkling Graphite
Join Date: Mar 2008
Location: Stockton, CA

Posts: 10
iTrader: (1)

Quote:
Originally Posted by 98RACE View Post
I had the same issue, new bulbs fixed the problem.
What bulbs did you buy? My right one just started.
hobbymike is offline  
0
Reply With Quote
      01-14-2013, 03:32 PM   #15
E92-Lighting
BimmerPost Supporting Vendor

 
E92-Lighting's Avatar
 
Drives: Next Generation LED Lighting
Join Date: May 2008
Location: Walnut

Posts: 25,910
iTrader: (317)

Send a message via AIM to E92-Lighting Send a message via MSN to E92-Lighting Send a message via Yahoo to E92-Lighting Send a message via Skype™ to E92-Lighting
in most cases its just a simple D1S 100% plug and play replacement, have you tried that?
__________________
E92-Lighting is offline   United_States
0
Reply With Quote
      09-27-2013, 03:50 AM   #16
Bigwen
Private
 
Bigwen's Avatar
 
Drives: 2008 335I E90
Join Date: Jun 2011
Location: North Hollywood

Posts: 91
iTrader: (0)

HID out on Passager Side

I have the same issue on my E90 335i 2008.
When it went out I had aftermarket bulbs in it I had them tested they work and I even had the stock put back in on that side and it still did not come on. And I know the stocks work fine.

I am in a battle with BMW but, its getting old
I think its the control Module what do you guys think?
__________________
BWProductions MBR LTMW aFe HKS COBB Tuning ST VMR YOKOHOMA MFest TOPstitch PACIFICBMW Don-Nguyen GetBMWparts ER BSH
Bigwen is offline   United_States
0
Reply With Quote
      09-27-2013, 01:27 PM   #17
dave0352usmc
U.S. Marine
 
Drives: Alpine White 325i
Join Date: Jan 2013
Location: North Carolina

Posts: 55
iTrader: (0)

One of my xenons turned pink before doing that. Bulb wouldn't ignite to right temperature anymore so I replaced it. Works great now.
__________________



06' Alpine White 325i | 18x8.5 Malloy 5's | H&R Sports | BMS 12,18MM | M3 Front Bumper
dave0352usmc is offline  
0
Reply With Quote
      09-27-2013, 03:16 PM   #18
kisho
Lieutenant
 
Drives: E90 325xi
Join Date: Mar 2009
Location: MD

Posts: 594
iTrader: (6)

Garage List
2006 325xi  [4.50]
Aftermarket kits are a PITA to troubleshoot. It could be the bulb, ballast, loose/faulty connections. Best way to do this is test things on the side that still works.

I went through similar problems an when I had enough of troubleshooting, I just went OEM an coded the car. Only difference is that I threw in Osram CBI bulbs. Cleaner and easier to maintain.
kisho is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:20 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST