E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Service rear brakes light on.. Grrr



Reply
 
Thread Tools Search this Thread
      11-21-2012, 01:31 PM   #1
MrBeetleman
New Member
 
Drives: 2006 e90
Join Date: Feb 2012
Location: Nova Scotia

Posts: 21
iTrader: (0)

Service rear brakes light on.. Grrr

I was in the service menu of my 2006 e90 resetting the oil change light. That went well, but I must have done something wrong. Right after, I got the large red "car on a lift" message. I checked and the rear brake service light was triggered. When I checked, there were no kms left, and when I try to reset it, the kms at the bottom stay blank. What can I do?
Attached Images
  
MrBeetleman is offline  
0
Reply With Quote
      11-21-2012, 08:38 PM   #2
fun2drive
BMWCCA 149159
 
fun2drive's Avatar
 
Drives: E93 335 Vert E36 M3/4
Join Date: Jul 2006
Location: Florida Panhandle

Posts: 574
iTrader: (1)

You tripped the sensor on the right rear brake. That means you need to replace your pads and maybe your rotors too as well as your brake pad sensor...
fun2drive is offline   United_States
0
Reply With Quote
      11-21-2012, 10:44 PM   #3
Braumin
First Lieutenant
 
Drives: 2009 335i xDrive Sedan
Join Date: Oct 2012
Location: Regina, SK, CAN

Posts: 321
iTrader: (0)

When I bought some aftermarket wagner pads for my e46 rear brakes, it came with the sensor. When you buy some, see if they do come with the sensor or not. The OEM ones of course don't, and then they gouge you on the actual sensor.

You can't reset the brake sensor - it's a destructive process to trip that sensor because rotor actually hits the sensor when the brakes are worn enough.
Braumin is offline  
0
Reply With Quote
      11-22-2012, 07:25 AM   #4
MrBeetleman
New Member
 
Drives: 2006 e90
Join Date: Feb 2012
Location: Nova Scotia

Posts: 21
iTrader: (0)

Hmm. I'll check it, but the pads are quite new, & it showed up only when I was in the menu, resetting the oil change light...
MrBeetleman is offline  
0
Reply With Quote
      11-22-2012, 07:58 AM   #5
jacobsed
Lieutenant
 
Drives: 2006 330xi
Join Date: Feb 2012
Location: United States

Posts: 425
iTrader: (2)

Sounds like you accidentally reset the brake sensor. You're screwed and need a new one now. Or you can un-clip it from the caliper, cut the end off, strip back the wires and tie them together. That will make the car think there is a new sensor and make the light go away.

If you get a new one and your brakes are pretty worn already, the sensor will get crushed and break due to excess travel. They are designed to gradually wear down as the pads wear down.

I think another option is to buy a new one, plug it in, reset to get the car programmed for that sensor, then hook your old one back up and reset again. I don't believe the car will remember the old one after you reset with a new one. And you'll have a new sensor waiting for your next brake job.
jacobsed is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:43 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST