E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > BMW Coding > Combox coding ! Fun inside !



Reply
 
Thread Tools Search this Thread
      02-24-2017, 02:36 AM   #1
Aus335iguy
Lieutenant
Aus335iguy's Avatar
48
Rep
515
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

Combox coding ! Fun inside !

Hello all
Iím hoping someone here can help me - Iím at a loss at the moment. Ive installed a combox in my 06/09 335i e92. The car started out with the USB and phone cradle and has individual hifi as well as voice control et al.
I wanted to have spotify and smsís on the screen but It had a mul2 high and Iíve now fitted a combox.
The model of the combox is 8410925716301 and its a bn2000 could this be incorrect?

I changed all the pins around and now its working in that the bluetooth hooks up and sounds great. i can take phone calls etc all good. Not so good though is that the USB isnít working.

Ive checked the usb at the combox itself and no power. Also the BMW live and internet comes up with a thing that says activate bluetooth data.

My phone wasnít initially pairing but Iíve since found that the PAN profile code wasnít active and now when i pair my phone(iPhone 7) i get the tick box for data as well.

So my issues are that bluetooth data isnít working and USB isnít working.

Ive checked my VO
E92_#0311&LCSW%0475$1CA$205$226$2KE$2XA$302$313$42 3$428$431$441$459$481$493$4AT$502$508$520$521$522$ 534$544$563$609$614$615$620$644$654$694$6FL$6NF$6N R$6VA$6VC$760$7SP$812$850$853$863$877$880$8S3$8SM* WB72+TELD-B080

Ive attached two other files both are the tac from the cic and media(combox)
any and all assistance is appreciated in advance !!!!
With the help of dstrickland i "think" we managed to code a russian vin to my combox but i have no way to tell?
What more do i need to do ?


for reference

Vehicle information
VIN WBAXXXXXXXXXXXX
Type code WB72
Type 335I (EUR)
E series E92 ()
Series 3
Type COUPE
Steering RL
Doors 2
Engine N54
Displacement 3.00
Power 225
Drive HECK
Transmission MECH
Colour SPACEGRAU METALLIC (A52)
Upholstery LEDER DAKOTA/CREAMBEIGE (LCGE)
Prod.date 2009-06-09

Vehicle options
S1CA Selection of COP relevant vehicles
S1CB CO2 package
S1CD Brake Energy Regeneration
S230 Extra package, EU-specific
S2MP BMW alloy wheel, M double spoke 225
S2PA Wheel bolt retainer
S2TC Sport transmission w/ dual-plate clutch
S322 Comfort access
P337 M Sports package
S403 Glass roof, electrical
S428 Warning triangle and first aid kit
S431 Interior mirror with automatic-dip
S441 Smoker package
S488 Lumbar support, driver and passenger
S493 Storage compartment package
Vehicle options
S4AB Fine wood trim burr walnut
S4AE Armrest front, retractable
S508 Park Distance Control (PDC)
S521 Rain sensor
S524 Adaptive Headlights
S534 Automatic air conditioning
S541 Active cruise control
S548 Kilometer-calibrated speedometer
S563 Light package
S5AC High-beam assistant
S601 TV function
S609 Navigation system Professional
S620 Voice control
S644 Preparation f mobile phone w Bluetooth
S672 CD changer for 6 CDs
Vehicle options
S6FL USB/Audio interface
S700 Area-Code 4 for DVD
S715 M Aerodynamics package
S752 Individual audio system
S760 High gloss shadow line
S775 Headlining anthracite
S7CF BMW Repair Inclusive
P7RS Package Comfort
S7XA M Leathr. wheel+shift paddle+multifunc.
L810 National version Australia
S818 Battery master switch
S825 Radio control Oceania
S845 Acoustic belt warning
S864 Retailer Directory Overseas
S876 Radio frequency 315 MHz
Vehicle options
S880 On-board vehicle literature English
S8S3 Automatic locking when driving off
S8SM Car ident. number visible from outside
S8SP Control unit COP
S8SX Providersteuerung Telematik
S8TG Thiefproofing device
S925 Dummy-SALAPA
Vehicle options
S459 Seat adjuster, electric, with memory
S481 Sports seat
S502 Headlight cleaning system
S522 Xenon Light
S704 M Sports suspension
S853 Language version English
Attached Files
File Type: txt ciclast.txt (17.0 KB, 21 views)
File Type: txt media.txt (3.1 KB, 18 views)
Appreciate 0
      02-24-2017, 08:12 AM   #2
ptpending
Captain
41
Rep
835
Posts

Drives: e91
Join Date: Dec 2013
Location: vilnius

iTrader: (0)

you do not need to add +tel if you have $644
and i believe that 6NR options is not compatible with 6NF, you should leave only last one.
to which if the combox connector you connected hsd cable from mulf ? black or blue ?
__________________
E91 2006. Retrofits:High beam assistant,Individual Audio,Autodim mirrors,CIC,Combox(USB and Bluetooth),Electric Sport Seats,Light package,Front PDC, Heated Steering Wheel,Happy Robot,Climate Comfort Windscreen,Black Line rear lights.
Appreciate 0
      02-24-2017, 02:30 PM   #3
Aus335iguy
Lieutenant
Aus335iguy's Avatar
48
Rep
515
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

Quote:
Originally Posted by ptpending View Post
you do not need to add +tel if you have $644
and i believe that 6NR options is not compatible with 6NF, you should leave only last one.
to which if the combox connector you connected hsd cable from mulf ? black or blue ?
I'll try that thanks! Both black and blue have no output
__________________
There's no problem that 2 German turbos can't fix
Appreciate 0
      02-24-2017, 05:18 PM   #4
Aus335iguy
Lieutenant
Aus335iguy's Avatar
48
Rep
515
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

Just to be clear all I want to do is control Spotify from iDrive. I have BMW services showing on my dash and I want to remove that and add connected drive which is BMW apps. I've got the hardware just need to code it !
__________________
There's no problem that 2 German turbos can't fix
Appreciate 0
      02-24-2017, 05:38 PM   #5
E60525d
Captain
E60525d's Avatar
United Kingdom
48
Rep
825
Posts

Drives: E90 BMW 330d M Sport LCI
Join Date: Mar 2010
Location: UK

iTrader: (0)

You need the correct firmware for BMW apps, I believe it's c13.
Appreciate 0
      02-24-2017, 05:39 PM   #6
Aus335iguy
Lieutenant
Aus335iguy's Avatar
48
Rep
515
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

How can I update my CIC if I can't even get my USB working? Should I revert to the old USB first without 6nr ?
__________________
There's no problem that 2 German turbos can't fix
Appreciate 0
      02-24-2017, 05:44 PM   #7
ptpending
Captain
41
Rep
835
Posts

Drives: e91
Join Date: Dec 2013
Location: vilnius

iTrader: (0)

there is such possibility that your combox have too new firmware for your CIC
CIC should be upgraded using ICOM or other MOST-enabled interface
__________________
E91 2006. Retrofits:High beam assistant,Individual Audio,Autodim mirrors,CIC,Combox(USB and Bluetooth),Electric Sport Seats,Light package,Front PDC, Heated Steering Wheel,Happy Robot,Climate Comfort Windscreen,Black Line rear lights.
Appreciate 0
      02-24-2017, 05:44 PM   #8
Aus335iguy
Lieutenant
Aus335iguy's Avatar
48
Rep
515
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

Does anyone on the North shore SYDNEY have an ICOM interface ? I have heard that but I thought once i get USB working ill update via USB(theres a CIC update you can do. Once thats done id have the correct CIC software and all id need to do is spoof an FSC code ..... will that work ?


I just want USB functionality back
current VO
my current VO is this correct ?


E92_#0311&LCGE%0A52*WB72$1CA$1CB$1CD$230$2MP$2PA$2 TC$322$337 $403$428$431$441$459$481$488$493$4AB$4AE$502$508$5 21$522$524$534$541$548$563$5AC$601$609$614$615$620 $644$672$6AL$6FL$6NR$6VC$700$704$715$752$760$775$7 RS$7SP$7XA$810$818$825$845$853$864$876$880$8S3$8SM $8SX$8TG$925-A080
__________________
There's no problem that 2 German turbos can't fix
Appreciate 0
      02-24-2017, 07:19 PM   #9
Aus335iguy
Lieutenant
Aus335iguy's Avatar
48
Rep
515
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

So it seems that you need the better cic version c16 to have connected drive
so now i have removed everything related to online from my VO and written a blank MAN to both the combox and cic. Ive attached my vo, my combox and cic trace. USB is still not working

when i changed the VO i did an FA write to the CAS module but when i tried selecting other modules i got an error...does that matter ?

so again - the objective is to have iPod/iphone connectivity on the USB and bluetooth streaming by bluetooth. i can confirm that the streaming and phone calls work but USB remains without power
Attached Files
File Type: txt removed allcic.txt (17.1 KB, 11 views)
File Type: txt removed all combox.txt (3.2 KB, 12 views)
File Type: txt faallremoved.txt (261 Bytes, 9 views)
Appreciate 0
      02-24-2017, 07:21 PM   #10
BimmerGeeks
BimmerPost Supporting Vendor
BimmerGeeks's Avatar
529
Rep
748
Posts


Drives: Bmw
Join Date: Feb 2017
Location: Atlanta

iTrader: (3)

Quote:
Originally Posted by Aus335iguy View Post
So it seems that you need the better cic version c16 to have connected drive
so now i have removed everything related to online from my VO and written a blank MAN to both the combox and cic. Ive attached my vo, my combox and cic trace. USB is still not working

when i changed the VO i did an FA write to the CAS module but when i tried selecting other modules i got an error...does that matter ?

so again - the objective is to have iPod/iphone connectivity on the USB and bluetooth streaming by bluetooth. i can confirm that the streaming and phone calls work but USB remains without power
You can only write FA to Cas & Frm. These are the two modules that store the FA.
__________________
BimmerGeeks!
Remote & Local Coding, Flashing, Diagnostics & Software Installation
Alpina | PPK | Feature Coding | Dvd In Motion | Error Delete | Retrofits | Trans Swap Coding | Fault Troubleshooting | Calibrations
Appreciate 1
      02-25-2017, 02:17 AM   #11
Levanime
Levanime's Avatar
United_States
73
Rep
543
Posts

Drives: E92 335
Join Date: Dec 2014
Location: Bay Area, California

iTrader: (0)

Garage List
2007 BMW 335  [0.00]
looks like u have connection problem,
double check
Appreciate 0
      02-25-2017, 04:45 AM   #12
iCstyle
Private
16
Rep
89
Posts

Drives: 335i E92
Join Date: Oct 2014
Location: Switzerland

iTrader: (0)

I'll compare the TRC files with mine later and see what the differences are. Will also check VO against mine.
Appreciate 0
      02-25-2017, 05:14 AM   #13
ptpending
Captain
41
Rep
835
Posts

Drives: e91
Join Date: Dec 2013
Location: vilnius

iTrader: (0)

the only reason can be that combox have two usb ports - blue - unpowered and black - powered
after mulf2high you have one usb cable from mulf which goes to drivers footwell where it is connected to powered usb hub in industrial box, this hub have power circuit which is connected to mulf power circuit in parallel
so you need to clarify what does mean "unpowered" to you ? you do not have +5v on usb socket in armrest when combox is connected or you have power but usb data no accessed
__________________
E91 2006. Retrofits:High beam assistant,Individual Audio,Autodim mirrors,CIC,Combox(USB and Bluetooth),Electric Sport Seats,Light package,Front PDC, Heated Steering Wheel,Happy Robot,Climate Comfort Windscreen,Black Line rear lights.
Appreciate 0
      02-25-2017, 05:31 AM   #14
Aus335iguy
Lieutenant
Aus335iguy's Avatar
48
Rep
515
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

Quote:
Originally Posted by ptpending View Post
the only reason can be that combox have two usb ports - blue - unpowered and black - powered
after mulf2high you have one usb cable from mulf which goes to drivers footwell where it is connected to powered usb hub in industrial box, this hub have power circuit which is connected to mulf power circuit in parallel
so you need to clarify what does mean "unpowered" to you ? you do not have +5v on usb socket in armrest when combox is connected or you have power but usb data no accessed
I had no power at the USB socket on the combox. I'm going to check the wiring tomorrow but if anybody can tell me what's connected on pin 11 MULF2 high it might be power for that hub. But I don't think so. When I put my mulf back in the USB in the armrest worked I measured the voltage on that pin 11 blue black wire and it was zero. I earthed it with my combox in case it was that... nothing


I really appreciate you taking guys taking the time to help though..
__________________
There's no problem that 2 German turbos can't fix
Appreciate 0
      02-25-2017, 05:55 AM   #15
iCstyle
Private
16
Rep
89
Posts

Drives: 335i E92
Join Date: Oct 2014
Location: Switzerland

iTrader: (0)

Quote:
Originally Posted by Aus335iguy View Post
I had no power at the USB socket on the combox. I'm going to check the wiring tomorrow but if anybody can tell me what's connected on pin 11 MULF2 high it might be power for that hub. But I don't think so. When I put my mulf back in the USB in the armrest worked I measured the voltage on that pin 11 blue black wire and it was zero. I earthed it with my combox in case it was that... nothing


I really appreciate you taking guys taking the time to help though..
MULF Pin 11 is not needed. Thats a black wire right? I don't have it hooked up and both of my USB ports work. I don't use SnapIn though.

This is how I code retrofitted combox after several testing:

Remove $606, $612, $619, $644 from VO
Add #0311, $609, $614, $615, $616, $620, $633, $6AA, $6AB, $6FL, $6NF, $6VC, $7SP, $8TN to VO
Code CIC and MEDIA

Then code this:
MEDIA/TELEMATIK_VIN -> coding_vin
MEDIA/MAIN_BOARD_ALONE -> mainboard_alone
MEDIA/USB1_IPOD_AUDIO -> digital
MEDIA/USB2_IPOD_AUDIO -> digital
CIC/ONLINE_BROWSER_C0D -> beide_aktiv

This works for me 100% (on newest CIC = C1A and COMBOX = C05 though).

It is though without BMW Apps. For BMW Apps repeat the steps above, but in VO add $6AL instead $616, and add $6NS instead $6NF, maybe also add $6NR.

Last edited by iCstyle; 02-25-2017 at 06:17 AM. Reason: corrected VO
Appreciate 0
      02-25-2017, 04:50 PM   #16
Aus335iguy
Lieutenant
Aus335iguy's Avatar
48
Rep
515
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

Quote:
Originally Posted by iCstyle View Post
Quote:
Originally Posted by Aus335iguy View Post
I had no power at the USB socket on the combox. I'm going to check the wiring tomorrow but if anybody can tell me what's connected on pin 11 MULF2 high it might be power for that hub. But I don't think so. When I put my mulf back in the USB in the armrest worked I measured the voltage on that pin 11 blue black wire and it was zero. I earthed it with my combox in case it was that... nothing


I really appreciate you taking guys taking the time to help though..
MULF Pin 11 is not needed. Thats a black wire right? I don't have it hooked up and both of my USB ports work. I don't use SnapIn though.

This is how I code retrofitted combox after several testing:

Remove $606, $612, $619, $644 from VO
Add #0311, $609, $614, $615, $616, $620, $633, $6AA, $6AB, $6FL, $6NF, $6VC, $7SP, $8TN to VO
Code CIC and MEDIA

Then code this:
MEDIA/TELEMATIK_VIN -> coding_vin
MEDIA/MAIN_BOARD_ALONE -> mainboard_alone
MEDIA/USB1_IPOD_AUDIO -> digital
MEDIA/USB2_IPOD_AUDIO -> digital
CIC/ONLINE_BROWSER_C0D -> beide_aktiv

This works for me 100% (on newest CIC = C1A and COMBOX = C05 though).

It is though without BMW Apps. For BMW Apps repeat the steps above, but in VO add $6AL instead $616, and add $6NS instead $6NF, maybe also add $6NR.
Thanks iCstyle. Without the cic software update, I've given up on connected drive and I just want my USB to work.
__________________
There's no problem that 2 German turbos can't fix
Appreciate 0
      02-26-2017, 01:00 AM   #17
Aus335iguy
Lieutenant
Aus335iguy's Avatar
48
Rep
515
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

Well I'm one step closer to figuring this out. One of the guys here was generous with his time and to cut a long story short we ended up trying his combox in my car. The USB worked. The differences between the two have been narrowed to wiring and the fact his wasn't a telematic version. So either that fact makes a difference or I have a faulty combox. Given that others have struggled with this beforehand managed to solve it I'm in two minds on what to do. Replace the combox or keep trying to code it into submission. We've compared the two trace files and they were extremely similar, updated and still nothing. It could also be that the wiring combo I have works for his but not for mine. Any clues ?

Thanks for your time today reisf !

Does anyone on the North shore in SYDNEY have a working combox telematics ? If so can I borrow it for 2 mins ? If yours works then it's mine.....
__________________
There's no problem that 2 German turbos can't fix
Appreciate 0
      02-26-2017, 04:23 AM   #18
iCstyle
Private
16
Rep
89
Posts

Drives: 335i E92
Join Date: Oct 2014
Location: Switzerland

iTrader: (0)

Are you giving power to both pin 1 + 2? I heard this was neccessary on Telematics, not sure though.
Appreciate 0
      02-26-2017, 04:24 AM   #19
Aus335iguy
Lieutenant
Aus335iguy's Avatar
48
Rep
515
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

Yes both. I tried removing it from pin 2 as well.... nothing different
__________________
There's no problem that 2 German turbos can't fix
Appreciate 0
      03-09-2017, 03:58 AM   #20
Aus335iguy
Lieutenant
Aus335iguy's Avatar
48
Rep
515
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

New combox in and everything except apps and office are working. I'll post trc files later... in the mean time I'm going for a drive...
__________________
There's no problem that 2 German turbos can't fix
Appreciate 1
      03-09-2017, 04:07 AM   #21
iCstyle
Private
16
Rep
89
Posts

Drives: 335i E92
Join Date: Oct 2014
Location: Switzerland

iTrader: (0)

Did you try modifying VO like I've written before and then code CIC and COMBOX? Works perfectly for me.

BTW, how did you solve the USB problem, was it a faulty combox?
Appreciate 0
      03-09-2017, 04:33 AM   #22
Aus335iguy
Lieutenant
Aus335iguy's Avatar
48
Rep
515
Posts

Drives: 2009 e92 335i MSport DCT
Join Date: Jul 2015
Location: Sydney Aus

iTrader: (0)

Yeah the VO was correct. The combox must have been faulty. Plugging the USB in to the phone drops the Bluetooth out and then I have to re-pair which is a PITA...
Album art and Apple Music via USB works. Bluetooth audio, phone calls looks ok.
Want office which shouldn't be hard and the cherry on top would be apps. Spotify specifically....
__________________
There's no problem that 2 German turbos can't fix
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:37 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST