E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > Cosmetic and Lighting Modifications (exterior/interior) > Blown HID ballast?



Reply
 
Thread Tools Search this Thread
      06-13-2012, 09:12 AM   #1
Jabber88
Private First Class
 
Jabber88's Avatar
 
Drives: E90 335xi
Join Date: Mar 2012
Location: St Louis

Posts: 107
iTrader: (0)

Blown HID ballast?

So last night I changed my stock bulbs. They both went in fine, but when I turned on the lights the passenger low beam didn't fire up. It was late last night and I was upset so I just left it. I haven't had time to look at the fuses, ofcourse im working a 12 hour shift today and I can't get it off my mind. I'm worried its the ballast, becuase the angel eyes still work. But does anyone know if it was a blown fuse would my angel eyes still work?
Jabber88 is offline   United_States
0
Reply With Quote
      06-16-2012, 10:37 AM   #2
denali335
New Member
 
Drives: 335xi
Join Date: Dec 2010
Location: Washington, DC

Posts: 16
iTrader: (0)

I'm definitely curious as to what happened... I have the same exact issue. I never thought to check a fuse but my best guess is the ballast. The BMW dealership here said that there was a crack on one of the tabs of the compartment cover and that moisture got into my headlight and then quoted me $3k for a new one. I almost punched him in the face.
denali335 is offline  
0
Reply With Quote
      06-18-2012, 01:02 AM   #3
Jabber88
Private First Class
 
Jabber88's Avatar
 
Drives: E90 335xi
Join Date: Mar 2012
Location: St Louis

Posts: 107
iTrader: (0)

3k holly Jesus That's crazy! But yea I checked my fuses and everything looked good. So I just bought an oem ballast and going to hope for for the best. But if that's not it I guess I'm going to have to take it to the dealer
Jabber88 is offline   United_States
0
Reply With Quote
      06-18-2012, 09:37 AM   #4
rollinstone157
Brotographer
 
rollinstone157's Avatar
 
Drives: 2010 328i xDrive Sedan
Join Date: Mar 2011
Location: NJ, USA

Posts: 1,647
iTrader: (0)

Garage List
Quote:
Originally Posted by Jabber88 View Post
3k holly Jesus That's crazy! But yea I checked my fuses and everything looked good. So I just bought an oem ballast and going to hope for for the best. But if that's not it I guess I'm going to have to take it to the dealer
There are a few components that could be broken. One is the ballast for sure.

Have someone else turn the car on, stand at the front of the car, switch the headlights on, and have someone start the car. You should see a "self-check" of the xenon auto-leveling system (beams move up and down, takes a few seconds). Does the dead side still move? If not, it could be indicitive of the ballast and other components--perhaps the auto-stepper controller (disclaimer: i may have butchered the name of that part, but it's the piece that actually moves the projector up/down/left/right)
__________________
Reviews -|- HPB "Ultimate" LED Interior Kit -|- Noyka Cornering Bulbs -|- HPB 20W AE [OLD] -|- LUX H8 V4 -|- DTEC V7 AE's and MORE coming soon! Reviews to continue in March of 2014.
rollinstone157 is offline   United_States
0
Reply With Quote
      12-02-2012, 01:41 PM   #5
98RACE
Enlisted Member
 
Drives: 06 325i
Join Date: Apr 2012
Location: Burlington, Ont

Posts: 35
iTrader: (0)

Did you ever get it fixed? Just happened to me this morning and got a CC-ID 121 code, did not have much time to play around as it started to rain so I popped in the old bulb and it still did not work.
Any help would be greatly apreciated.

Dave
__________________
Dave
06 325i
98RACE is online now  
0
Reply With Quote
      12-02-2012, 03:26 PM   #6
denali335
New Member
 
Drives: 335xi
Join Date: Dec 2010
Location: Washington, DC

Posts: 16
iTrader: (0)

It took me three dealerships but they finally covered the ballast and the bulb under CPO. My issue was that they were refusing to do the diagnostic to check if it was the ballast or not unless I agreed to pay $600 in labor in the case that it wasn't covered. Funny thing is that the first two dealerships were dead set against it and trying to find ways to blame it on other things and the final one was really cool about it and actually even covered the replacement HID bulb which everyone else said was definitely not covered... Although now my halo eyes on the passenger side are out so I'm hoping that's just the bulb and not anything to do with the ballast again.
denali335 is offline  
0
Reply With Quote
      12-02-2012, 08:51 PM   #7
Delta0311
Brigadier General
 
Delta0311's Avatar
 
Drives: 2011 BMW 335xi E92
Join Date: Apr 2009
Location: NJ

Posts: 3,123
iTrader: (1)

Quote:
Originally Posted by denali335 View Post
It took me three dealerships but they finally covered the ballast and the bulb under CPO. My issue was that they were refusing to do the diagnostic to check if it was the ballast or not unless I agreed to pay $600 in labor in the case that it wasn't covered. Funny thing is that the first two dealerships were dead set against it and trying to find ways to blame it on other things and the final one was really cool about it and actually even covered the replacement HID bulb which everyone else said was definitely not covered... Although now my halo eyes on the passenger side are out so I'm hoping that's just the bulb and not anything to do with the ballast again.
The ballast does not control the halo bulbs. Halo bulbs are seperate
__________________
Space Gray 2011 335xi E92
Delta0311 is offline  
0
Reply With Quote
      12-02-2012, 09:08 PM   #8
Tomz_M3
Lieutenant Colonel
 
Drives: 08 Jet Black E90 M3
Join Date: Jul 2010
Location: Queens, NY

Posts: 1,726
iTrader: (11)

Sounds like the cable that connects the ballast to the HID bulb is not connected either on the ballast or bulb side. Make sure you check the connection on both sides. Halo bulb is an H7, condensation wouldnt really affect that.
__________________
Stock....
Tomz_M3 is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:58 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST