E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Help Please. JB4



Reply
 
Thread Tools Search this Thread
      11-27-2012, 06:43 PM   #1
awesome82
Private
 
awesome82's Avatar
 
Drives: gtr
Join Date: May 2012
Location: long island ny

Posts: 87
iTrader: (0)

Help Please. JB4

Current Mods

JB4 G5 board
DCI
Catless downpipe
Muffler delete
Charge Pipe w BOV

So i have a local muffler shop install my Catless downpipe and when they did they crossed the O2 sensors. as may of you know the car throws a code and starts running incredibly rough with this

I had the o2 sensors put back correctly and the car still doesnt run right ONLY WITH THE JB4 (any map it does the same thing)

with the JB4 off, the car runs great (throws a CEL i am assuming bc the catless dp) but runs great, slow but great

As soon as i up the JB4 on the CELS go away, and once the car goes into full boost, the car starts shaking and throws another cel. This happens on any map

Any ideas?

the car is at TKX currently and they are waiting for someone to come down and read the code
awesome82 is offline  
0
Reply With Quote
      11-27-2012, 06:47 PM   #2
MrRetep
First Lieutenant
 
MrRetep's Avatar
 
Drives: 435i M-Sport
Join Date: Jan 2012
Location: Irvine CA

Posts: 353
iTrader: (2)

the JB4 can be used to read the codes. maybe a misfire?
MrRetep is offline  
0
Reply With Quote
      11-27-2012, 06:51 PM   #3
awesome82
Private
 
awesome82's Avatar
 
Drives: gtr
Join Date: May 2012
Location: long island ny

Posts: 87
iTrader: (0)

Quote:
Originally Posted by MrRetep View Post
the JB4 can be used to read the codes. maybe a misfire?
i was thinking the same thing.. I guess i will have 2 call them tomorrow

I would think they would know that
awesome82 is offline  
0
Reply With Quote
      11-27-2012, 09:04 PM   #4
AK 335i
Major
 
AK 335i's Avatar
 
Drives: black 335i E90
Join Date: Sep 2012
Location: boynton beach

Posts: 1,294
iTrader: (0)

__________________
- Proven Power Tampa Built 6466 ST N54 6AT WR 711whp 637wtq -
AK 335i is offline  
0
Reply With Quote
      11-27-2012, 09:11 PM   #5
Exzackt
Second Lieutenant
 
Exzackt's Avatar
 
Drives: n54 e92 335i/e39 540i6
Join Date: Feb 2012
Location: SF Bay

Posts: 256
iTrader: (2)

Definitely sounds like a misfire.. When adding lbs of boost, parts that would often need to be replaced, because they were already on their way out. Try spark plugs first. Then ignition coils. If neither of these two then high pressure fuel pump or injectors. How smooth does your car idle? If rough than you might want to clean your intake valves.
__________________
2007 BSM 335i ZSP/ZPP l JB4 G5 ISO l E85 l BMS FLASH l METH l DCI l DPs l Twin BOVs l
Scoops l 18" Forgestar F14sl Koni Yellows l Swift Spec-R l GForce Rivals/Slicks l Quaife LSD

Last edited by Exzackt; 11-27-2012 at 10:47 PM.
Exzackt is offline   United_States
0
Reply With Quote
      11-28-2012, 12:55 AM   #6
CHECKERED
Racing is life, everything else is just waiting.
 
CHECKERED's Avatar
 
Drives: 335i E92, 05 Audi S4
Join Date: Oct 2012
Location: a Treacherous Canyon Road in SoCal

Posts: 368
iTrader: (5)

Garage List
2005 Audi S4  [0.00]
2007 BMW 335i  [0.00]
I would like some clarification,
- The car had a JB4 installed and was running ok
-after downpipes install with incorrect O2’s runs bad
-O2 sensors corrected but still runs bad (how was it discovered that the O2 sensors were switched, it’s possible they were damaged and now need replacement)

You might need to do a hard rest of the DME by unplugging the battery overnight
__________________
Garage Queen: 2005 Audi S4 4.2L V8, Vortech Supercharger, Vented CF Hood, PSS9 Coilovers, Sway-bars, RS4 brakes, Fast Intentions - Cat-less Downpipes & Full Exhaust, 505AWTQ
Daily Driver: E92 335i N54: JB4 G5 ISO28 w/BMS Flash, quaife LSD, BMS Meth, AA sport IC, BMS Charge Pipe, BMS OCC, Euro Light Switch, M-Sport Kit; 12.1@117mph (stock intake stock exhaust, 225ís RFT)
CHECKERED is online now   United_States
0
Reply With Quote
      11-28-2012, 11:47 AM   #7
awesome82
Private
 
awesome82's Avatar
 
Drives: gtr
Join Date: May 2012
Location: long island ny

Posts: 87
iTrader: (0)

Quote:
Originally Posted by CHECKERED View Post
I would like some clarification,
- The car had a JB4 installed and was running ok
-after downpipes install with incorrect O2’s runs bad
-O2 sensors corrected but still runs bad (how was it discovered that the O2 sensors were switched, it’s possible they were damaged and now need replacement)

You might need to do a hard rest of the DME by unplugging the battery overnight
-Yes Jb4 was in for several months and car ran great
-correct
-I went to autocature in NJ and they check the code and corrected the issue (the car ran fine with the jb4 off after this as prior the car ran like shit constantly)

I might add that it doesnt happen EVERY pull... id say 98% of the time

i am thinking it either

Bad o2 sensors from when they were switched (idk if they go bad)

or plugs and or coils.

Car has 45k on it and im sure were never changed (bought it used)
awesome82 is offline  
0
Reply With Quote
      11-28-2012, 11:51 AM   #8
Jeff@TopGearSolutions
BimmerPost Supporting Vendor

 
Jeff@TopGearSolutions's Avatar
 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

Posts: 16,800
iTrader: (31)

Send a message via AIM to Jeff@TopGearSolutions
Probably spark plugs if they are original.
Jeff@TopGearSolutions is offline   United_States
0
Reply With Quote
      11-28-2012, 11:56 AM   #9
WilliamS
GoofBall
 
Drives: 2008 E92 N54 Xdrive
Join Date: Jun 2012
Location: Tampa, FL

Posts: 748
iTrader: (1)

First you can reset all learned values by using Category 1 selection 7 will clear adaptations. Try that bcuase you might not be fueling properly due the air amounts. Are you 100% sure the 02's are in the right place. Turn off the Autoclear Check light codes. If you dont know if you have it on go to screen 1 and use option 4 and get out of the menu as normal when you use the track down button on your steering wheel.

Car idle do the 1/7 clear adaptations let it idle for a little bit. Go to map 4, which is factory boost but allows the JB4 to keep track of codes and such. Drive the car 10 miles, some boost some without. From there go to map 5 and drive again. If your still getting a stumble use the JB4 to figure out what codes. If it throws a code, use the JB4 to figure out what it did and why. If its a missfire use the cable to see what your long term and short term fuel trims are. As well note which cylinder the missfire was on.

Report back when your done.
WilliamS is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:09 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST