E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > 5DE0 5DE1 after software update



Reply
 
Thread Tools Search this Thread
      11-23-2012, 05:54 PM   #1
allotherareused
Enlisted Member
0
Rep
43
Posts

 
Drives: 320d, e90
Join Date: Jul 2012
Location: Santiago

iTrader: (0)

5DE0 5DE1 after software update

Hi,

Will try to write short story what is done, may be relevant for final error. I hope someone can help with some advice :

I had some MRS error, that for bough cable with software. Somehow, by finding that error and coding door close on certain speed have disabled the car, wasn't able to start it (finally, was some random key between two modules, but I wasn't able to find that).

As car is 320d 2005 year, and software probably from 2009 there were 14 modules to be updated (else, progman were rejecting to do some things). Well, I've updated modules, 12 sucesfull and 2 wasn't able to update (BO, and CDC, this is user interface in radio unit).

Finally, has to reintialize couple modules, windows, calibrate steering wheel sensor etc and this is all done but now have two errors :

5DE0 Brake pad wear, plausibility, front axle
5DE1 Brake pad wear, plausibility, rear axle

I've found that brake pads data in CBS module are wrong after update, Front Brakes 255%, Rear Brakes 255%. That was supposed to be corrected by entering correct values, but this is not working.

Somehow, I managed to put correct value for front brake and this now show 93% (13 mm, I've aproximated that, have changed 4 months ago) but when I am trying to put correct value for rear brake getting rejecting message which is confusing because sometime is talking about front brake sensor and sometime about rear brake sensor.

So, to explain brake status :
I've changed discs and brake pads 4 months ago but haven't changed sensors because that was in good condition. Since then didn't had any message about brake problem until software is updated.

Message when I am trying to reset REAR brake is : (pay attention on front brake in message)

SCBS_6004 / Offset_rear_brakes
Attention !
The control unit recognises that brake pad wear sensor on the front axle is looped through. The control unit ignores the reset procedure until the brake pad wear sensor is replaced. The control unit recognises the replacement of the brake pad wear sensor only after a terminal change has taken place !
<blah blah irrelevant>

Also, sometime is message that rear sensor is damaged, I don't have exact message to put it in but after all of that I have couple question :

1. What is exact meaning of "looped trough" in this message ?
2. What is meaning of "terminal" in this message and how car recognize that "terminal change place" ?

This is not a problem to change sensors on brake pads, I haven't done that because connectors are dirty and was trying to avoid bigger problem by replacing sensors in good conditions, also, I am confused why problem appear after update and wasn't present before, so, maybe sensors are OK and this is just bug ?

3. If this is bug how to correct that ?

Thank you in advance,
Dejan
Appreciate 0
      11-28-2012, 01:14 AM   #2
allotherareused
Enlisted Member
0
Rep
43
Posts

 
Drives: 320d, e90
Join Date: Jul 2012
Location: Santiago

iTrader: (0)

I've replaced rear sensor and problem is solved.

That seems BMW have hired microsoft programmers

- old version of software wasn't detecting problem in rear sensor (bug)
- current version of software is wrong detecting problem in front sensor when rear sensor need to be replaced

Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:36 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST