E90Post
 


TireRack
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Car jerking at WOT as well as 29F2 code - Help!!



Reply
 
Thread Tools Search this Thread
      11-26-2012, 03:17 PM   #1
AndyDaBoss
Lieutenant
AndyDaBoss's Avatar
7
Rep
485
Posts

 
Drives: TiAg 08' E90 335i
Join Date: Oct 2011
Location: Houston

iTrader: (3)

Garage List
2008 BMW 335i  [2.25]
Car jerking at WOT as well as 29F2 code - Help!!

This problem started after i installed the ER charge pipe and synapse BOV however it might be coincidental . So this happens pretty much most of the time when i'm on map 2 or map 5 (sometimes on map 0) with my jb4 and only happens when i accelerate hard. it feels like the car is cutting fuel hence the 29F2 code - "Fuel high pressure system, fuel pressure". On some occasions after jerking, the car would go into limp mode. i'm not really to sure how to describe this jerking movement but it feels like the car loses power for a quick second and then continues to accelerate. what are the possible problems that could cause this and is there any solutions to try. car is out of warranty and my extended warranty doesnt cover maintenance.
__________________
08' E90 335i TiAg | 19' VMR V710 | JB4 PnP | Injen DCI | Mtec V3 | Black Grills | CF ACS Roof Spoiler | ER Charge pipe w/ Synapse BOV | Muffler delete

Appreciate 0
      11-26-2012, 04:52 PM   #2
NoQuarter
Second Lieutenant
United_States
2
Rep
221
Posts

 
Drives: 2007 530xi / 2008 535xi
Join Date: Jan 2011
Location: Indiana

iTrader: (0)

Quote:
Originally Posted by AndyDaBoss View Post
Car jerking at WOT
Now that takes some talent. Must be an automatic.
Appreciate 0
      11-26-2012, 04:55 PM   #3
e90328i
Banned
10
Rep
387
Posts

 
Drives: 07 E90 335i
Join Date: May 2011
Location: socal

iTrader: (4)

Do you get 29dc as well? I had reoccurring 29f2 and 29dc codes with tune only and the dealer tested the fuel system and everything checked out fine.. I would only get 29dc or 29f2 with jb4.. Cars runs amazing stock still havent figured it out! does it happen without tune??
Appreciate 0
      11-26-2012, 05:02 PM   #4
Deemo
Second Lieutenant
Deemo's Avatar
4
Rep
293
Posts

 
Drives: 07 E90 335i
Join Date: May 2012
Location: Plano, Texas

iTrader: (1)

i would get these codes on map 5, I think it was from running to much e85 causing my lpfp to max out.
__________________
07 E90 335i 6AT
Appreciate 0
      11-27-2012, 03:53 AM   #5
AndyDaBoss
Lieutenant
AndyDaBoss's Avatar
7
Rep
485
Posts

 
Drives: TiAg 08' E90 335i
Join Date: Oct 2011
Location: Houston

iTrader: (3)

Garage List
2008 BMW 335i  [2.25]
Quote:
Originally Posted by NoQuarter View Post
Now that takes some talent. Must be an automatic.
lol yes it is an automatic
__________________
08' E90 335i TiAg | 19' VMR V710 | JB4 PnP | Injen DCI | Mtec V3 | Black Grills | CF ACS Roof Spoiler | ER Charge pipe w/ Synapse BOV | Muffler delete

Appreciate 0
      11-27-2012, 03:55 AM   #6
AndyDaBoss
Lieutenant
AndyDaBoss's Avatar
7
Rep
485
Posts

 
Drives: TiAg 08' E90 335i
Join Date: Oct 2011
Location: Houston

iTrader: (3)

Garage List
2008 BMW 335i  [2.25]
Quote:
Originally Posted by e90328i View Post
Do you get 29dc as well? I had reoccurring 29f2 and 29dc codes with tune only and the dealer tested the fuel system and everything checked out fine.. I would only get 29dc or 29f2 with jb4.. Cars runs amazing stock still havent figured it out! does it happen without tune??
no i don't get the 29dc code . only 29f2
__________________
08' E90 335i TiAg | 19' VMR V710 | JB4 PnP | Injen DCI | Mtec V3 | Black Grills | CF ACS Roof Spoiler | ER Charge pipe w/ Synapse BOV | Muffler delete

Appreciate 0
      11-28-2012, 12:09 AM   #7
E92Freak101
Enlisted Member
0
Rep
32
Posts

 
Drives: 08 bmw 335i coupe
Join Date: Mar 2012
Location: uniontown

iTrader: (0)

I'm having this same issue I see u had this problem after the charge pipe n bov dose anyone know if this could be a boost leake causing this?
Appreciate 0
      11-28-2012, 07:10 AM   #8
Mike@N54Tuning.com
BimmerPost Supporting Vendor
Canada
476
Rep
15,007
Posts


 
Drives: 07335i
Join Date: Dec 2008
Location: Earth

iTrader: (88)

False 29F2 code is a common setting problem and is covered in the firmware notes on BMS forum.

Mike
__________________
LOWEST PRICE GURANTEE ON ALL PRODUCTS - www.n54tuning.com - Email; Mike@n54tuning.com
NEW PERFORMANCE LINE N54 DOWNPIPES & M3/M4 & F30 ER DOWNPIPES NOW IN STOCK - ER N54 CHARPE PIPE SPECIALS - NEW JB4 G5 ISO for N54 and F30 N55 ON SALE - NEW S55 M3/M4 JB4 NOW SHIPPING
Appreciate 0
      11-28-2012, 10:47 AM   #9
drm916
Second Lieutenant
2
Rep
226
Posts

 
Drives: 335
Join Date: Jul 2012
Location: atlanta

iTrader: (2)

Quote:
Originally Posted by AndyDaBoss View Post
This problem started after i installed the ER charge pipe and synapse BOV however it might be coincidental . So this happens pretty much most of the time when i'm on map 2 or map 5 (sometimes on map 0) with my jb4 and only happens when i accelerate hard. it feels like the car is cutting fuel hence the 29F2 code - "Fuel high pressure system, fuel pressure". On some occasions after jerking, the car would go into limp mode. i'm not really to sure how to describe this jerking movement but it feels like the car loses power for a quick second and then continues to accelerate. what are the possible problems that could cause this and is there any solutions to try. car is out of warranty and my extended warranty doesnt cover maintenance.

I say its just coincidence. But try going back to stock charge pipe and see if that resolves it.
Appreciate 0
      11-28-2012, 02:01 PM   #10
335i E92
Captain
20
Rep
686
Posts

 
Drives: 335i E92 SE
Join Date: Mar 2010
Location: Manchester

iTrader: (1)

Traction control kicking in?
Appreciate 0
      11-28-2012, 02:25 PM   #11
Gugs
Cynical
Gugs's Avatar
United_States
4
Rep
431
Posts

 
Drives: E92 JetBlack
Join Date: Jul 2012
Location: Long island

iTrader: (1)

This is random but you said you did Cp-
Did u damage the tmap sensor at all? Plugged it back in? Seated correctly?
Appreciate 0
      11-29-2012, 01:14 PM   #12
AndyDaBoss
Lieutenant
AndyDaBoss's Avatar
7
Rep
485
Posts

 
Drives: TiAg 08' E90 335i
Join Date: Oct 2011
Location: Houston

iTrader: (3)

Garage List
2008 BMW 335i  [2.25]
Quote:
Originally Posted by Gugs View Post
This is random but you said you did Cp-
Did u damage the tmap sensor at all? Plugged it back in? Seated correctly?
yes i did i broke the a tab that holds it in place, however i was told i didnt really need the tab. it sits snug on the cp. could that cause this to happen?
__________________
08' E90 335i TiAg | 19' VMR V710 | JB4 PnP | Injen DCI | Mtec V3 | Black Grills | CF ACS Roof Spoiler | ER Charge pipe w/ Synapse BOV | Muffler delete

Appreciate 0
      11-29-2012, 01:16 PM   #13
AndyDaBoss
Lieutenant
AndyDaBoss's Avatar
7
Rep
485
Posts

 
Drives: TiAg 08' E90 335i
Join Date: Oct 2011
Location: Houston

iTrader: (3)

Garage List
2008 BMW 335i  [2.25]
Quote:
Originally Posted by 335i E92 View Post
Traction control kicking in?
definitely not traction control . i'm sure i would have grip at 4th gear at around 6k rpm
__________________
08' E90 335i TiAg | 19' VMR V710 | JB4 PnP | Injen DCI | Mtec V3 | Black Grills | CF ACS Roof Spoiler | ER Charge pipe w/ Synapse BOV | Muffler delete

Appreciate 0
      11-29-2012, 01:18 PM   #14
AndyDaBoss
Lieutenant
AndyDaBoss's Avatar
7
Rep
485
Posts

 
Drives: TiAg 08' E90 335i
Join Date: Oct 2011
Location: Houston

iTrader: (3)

Garage List
2008 BMW 335i  [2.25]
Quote:
Originally Posted by Mike@N54Tuning.com View Post
False 29F2 code is a common setting problem and is covered in the firmware notes on BMS forum.

Mike
yes i have checked up on that but would i still be having the jerking issue even if it was a false 29F2?
__________________
08' E90 335i TiAg | 19' VMR V710 | JB4 PnP | Injen DCI | Mtec V3 | Black Grills | CF ACS Roof Spoiler | ER Charge pipe w/ Synapse BOV | Muffler delete

Appreciate 0
      11-29-2012, 02:10 PM   #15
GetSomeE92
Major
United_States
12
Rep
1,141
Posts

 
Drives: '09 Space Gray E92
Join Date: Mar 2011
Location: Miami, FL

iTrader: (7)

Are you running any E85? If so, you may be running too much for your pump to handle.
Appreciate 0
      11-29-2012, 02:20 PM   #16
AndyDaBoss
Lieutenant
AndyDaBoss's Avatar
7
Rep
485
Posts

 
Drives: TiAg 08' E90 335i
Join Date: Oct 2011
Location: Houston

iTrader: (3)

Garage List
2008 BMW 335i  [2.25]
Quote:
Originally Posted by GetSomeE92 View Post
Are you running any E85? If so, you may be running too much for your pump to handle.
None at all .
__________________
08' E90 335i TiAg | 19' VMR V710 | JB4 PnP | Injen DCI | Mtec V3 | Black Grills | CF ACS Roof Spoiler | ER Charge pipe w/ Synapse BOV | Muffler delete

Appreciate 0
      11-29-2012, 02:29 PM   #17
akotten
Major
akotten's Avatar
13
Rep
1,043
Posts

 
Drives: 2007 335xi
Join Date: Mar 2011
Location: Rapid City, SD

iTrader: (2)

Quote:
Originally Posted by AndyDaBoss View Post
None at all .
I have similar issues with my Procede on 91 only. It only happens if I turn the boost up. Makes me wonder if my LPFP is going out or the low pressure fuel sensor is bad.
__________________
TC Kline S/A | Vorshlag Camber Plates | ///M Bushings & ARB | CP-e DPs | VRSF FMIC | Procede 2.5 w/ OpenFlash | DCI |
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:08 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST