E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > HSF-4 to Procede setup check (Hopefully a future DIY guide)



Reply
 
Thread Tools Search this Thread
      07-11-2012, 09:56 PM   #1
dblrguy
Private
United_States
2
Rep
90
Posts

Drives: 2010 335i & 06 330i
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

HSF-4 to Procede setup (Mostly a DIY guide)

UPDATE: The HSF-4 can be controled by the Procede Rev3. I've updated this first post as needed. I've left the original info in my initial post and added the corrected information in bold.


Chargepipe with meth bungs arrives on Friday. Want to make sure that I fully understand all the connections and settings so the install goes smoothly.

I've searched the forum, read the Procede Tuning instructions, sent an email to Vishnu Tuning (still no response after a week) and contacted Aquamist to confirm these connections and settings. Any users out there PLEASE chime in if there are any errors in my plan or to offer suggestions. I bolded important points and my personal questions, those with experience please skim and help me and the community.

I wrote this so that it can easily be turned into a DIY if I have everything correct. As of this writing I have only installed the tank and gauge. Following this as instructions without confirming proper function is at the individual users own risk!

I have the Howerton Engineering kit installed in the trunk, all wires ran through the cabin on the passenger side. Fuel line ran under the car to the engine bay.
Name:  Tank Far.jpg
Views: 1257
Size:  87.5 KB

Gauge installed in the center tray, wire tapped from the trunk release button for gauge dimming.
Name:  Inside.jpg
Views: 1116
Size:  89.8 KB


There is a new/corrected diagram on page 2 of this thread.

Following this diagram from Richard L at Aquamist I created a primary ground near the tank location behind the left hand trunk liner and ran the power wire to the battery. (I'm aware that it says V3, I specifically told him Rev3.)
Name:  HFS4-N54-procede-v3.gif
Views: 1399
Size:  163.5 KB

I plan to use pin 2 of the green connector in the ECU box for power, the same connector with pin 8 providing power to the Procede, as I don't want to tap any factory wires.
Name:  Green connector.jpg
Views: 1034
Size:  16.7 KB

Ground wires will be figured out during install, any suggestions?

>>>>>>> This connection is wrong. I will attach the Green wire from the ECU harness of the HSF-4 to the Green wire on the 9 pin connector on the Rev3 Procede harness.
Also the White wire from the User harness of the HSF-4 to the Blue wire of the 9 pin connector on the Procede
. <<<<<<< >>> Correct connections are White from HSF-4 to Green on the Procede, and Green from the HSF-4 to Blue on the Procede.
Name:  9 pin connector.png
Views: 1496
Size:  382.0 KB

Richards remaining instructions are:
Quote:
Originally Posted by Richard L View Post
It is not necessary to use the restrictor if your are running two 1mm jets. It is better to leave some upper ceiling in case you want to increase flow via the controller.

If the circuit is not already pre-configured from your suppler, you need to do the following:

Procede Piggy-back:
3. Set the "Threshold" trimmer to 12% (fully counter clockwise).
4. Link "DFS" to disable failsafe activation since Procede takes care of this.
Turn the Threshold all the way counter clockwise (Circle on the Left)
Move the link from PRK (Parking, its an extra link) to the last slot on failsafe, DFS. (To prime your system with the HSF-4 box open remove the 6mm "In" hose from the FAV and move the link from FAV to SYS.)
Name:  HSF-4 Controller.gif
Views: 1052
Size:  106.9 KB

Next I will update my firmware on the Procede to "pro5v111_Dedicated PWM i_o_Rev3only" and load Stage 2 map.

Following step 21 of the PWM install instructions I will adjust the following in the User Adjustable Menu:
- Methanol Mode to 1 for PWM
- Injection Mode to 36 (Just a place for me to start until I know my flow rate.)
Change the following settings under Map 2:
- Start Boost to 58% (The suggested start point is 65% for 16.5 PSI, I want meth to start flowing a little earlier. I have a problem in my local area to get and keep my RPMs up high enough to properly test function in 3rd legally. Is it a bad idea to change this?
- Ignition Correction to 0%

That is it. Think it took me longer to research and write this than the remainder of my install will take. Help and suggestions are always appreciated.

~Nate

Last edited by dblrguy; 09-24-2012 at 01:32 PM. Reason: Update with corrected connection info
Appreciate 0
      07-11-2012, 10:04 PM   #2
Lulz_M3
Banned
United_States
13
Rep
1,029
Posts

Drives: AW 335i 6MT
Join Date: Oct 2011
Location: Jax, Fl

iTrader: (0)

When priming the system remove the hose from the "IN" side of the FAV, not the meth nozzles.
Appreciate 0
      07-11-2012, 10:12 PM   #3
dblrguy
Private
United_States
2
Rep
90
Posts

Drives: 2010 335i & 06 330i
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

Quote:
Originally Posted by Lulz_M3 View Post
When priming the system remove the hose from the "IN" side of the FAV, not the meth nozzles.
Original post corrected.

Thanks!
Appreciate 0
      07-11-2012, 10:26 PM   #4
dblrguy
Private
United_States
2
Rep
90
Posts

Drives: 2010 335i & 06 330i
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

Forgot a very important question...

With PWM enabled is there a way for meth to flow on a conservative map? I want to be able to fully test the flow of the system before I run a map requiring or expecting to see the meth. I'd really like to run distilled water with the nozzles secured where I can see them spraying while I drive, is this possible?
Appreciate 0
      07-12-2012, 10:46 AM   #5
dblrguy
Private
United_States
2
Rep
90
Posts

Drives: 2010 335i & 06 330i
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

Or, is it safe to assume that the first couple of times meth is used there is no flow while the air is being pushed out and that the procede is not changing maps until the other engine sensors see the benefits of it flowing?

Does this make sense? I want to see flow, know that everything is working 100% before my maps change to be too aggressive and risk any engine damage if there is a flow or delivery problem? How do I do this?

~Nate
Appreciate 0
      07-12-2012, 06:21 PM   #6
JMARS
Not Baned
Brazil
24
Rep
1,326
Posts

Drives: Single-T WTCC e90
Join Date: Aug 2008
Location: Boca Raton, FL

iTrader: (5)

Sinse you have the Rev.3 why dont you use the PWM Methanol PnP Adapter instead of pulling the wires?
This:


into this:


Just a suggestion for a cleaner install... also can't you run power off this same little PnP Adapter harness?
Appreciate 0
      07-12-2012, 10:09 PM   #7
F80M
Major
F80M's Avatar
24
Rep
1,358
Posts

Drives: love to piss on fucker's face
Join Date: Aug 2011
Location: are you that fucker? lol

iTrader: (2)

Please keep us posted. I'm buying this kit in the next month. Thanks much.
Appreciate 0
      07-13-2012, 07:58 AM   #8
JMARS
Not Baned
Brazil
24
Rep
1,326
Posts

Drives: Single-T WTCC e90
Join Date: Aug 2008
Location: Boca Raton, FL

iTrader: (5)

Let us know how it goes. I'll be putting in my system next week when it gets here.
This is a really cool write up.
__________________
Motiv-900 HTA3794R | Motiv PI | Motiv/Fuel-IT! Stg3+ LPFP | Motiv Cobb AEM EMS | DSS Carbon Drive Shaft | Spec SuperTwin-disc
**** Front Mount | **** Charge Pipe | **** Oil Cooler | JRZ Coilover | ECS Performance Rear Trailing Arm | UUC Tans Mount | Full M3 Suspension | AR Line Lock | 5 Point Welded in Cage
Appreciate 0
      07-13-2012, 05:48 PM   #9
dblrguy
Private
United_States
2
Rep
90
Posts

Drives: 2010 335i & 06 330i
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

No good news for the first outing.

As the title states, my first outing did not end with positive results.

No meth flow.

Having read the forum as much as I have, I triple checked all of my connections during the install. Especially the wiring. I did continuity checks from the primary Procede harness to the male connectors on the Aquamist harnesses. Everything checked out. On the road I got nothing. No flashers, no flow on the gauge. I even tried choosing PPS as the methanol mode. That got me flashers but no flow. Here is a log showing that the injector was given proper instructions. The flow line is incorrect, I did not use any meth, the tanks are exactly where they were when I left.

This is a solid 3rd gear pull on map 4. AIT's continue to raise. This tells me no meth flowed.
Name:  3rd gear pull.png
Views: 892
Size:  147.2 KB

I don't know where to go from here. I'll re-load my firmware and map. Everyone's first answer is install error so I'll check the wiring again. I really need someone to chime in and tell me that this will work. Has anyone done this? Do I have to use PPS or can I use PWM with the HSF-4? After those checks Its back to the HSF-4. There are so many different configurations maybe Richard left a jumper or solder out for proper operation by the procede.

Thanks for looking everyone!
Appreciate 0
      07-13-2012, 05:57 PM   #10
JMARS
Not Baned
Brazil
24
Rep
1,326
Posts

Drives: Single-T WTCC e90
Join Date: Aug 2008
Location: Boca Raton, FL

iTrader: (5)

Good Luck!
__________________
Motiv-900 HTA3794R | Motiv PI | Motiv/Fuel-IT! Stg3+ LPFP | Motiv Cobb AEM EMS | DSS Carbon Drive Shaft | Spec SuperTwin-disc
**** Front Mount | **** Charge Pipe | **** Oil Cooler | JRZ Coilover | ECS Performance Rear Trailing Arm | UUC Tans Mount | Full M3 Suspension | AR Line Lock | 5 Point Welded in Cage
Appreciate 0
      07-13-2012, 06:18 PM   #11
JMARS
Not Baned
Brazil
24
Rep
1,326
Posts

Drives: Single-T WTCC e90
Join Date: Aug 2008
Location: Boca Raton, FL

iTrader: (5)

I would hit up Jeff at:
Howerton Engineering, LLC
871 Cotting Court, Suite D
Vacaville CA, 95688
Phone : 707.685.6279 Pacific Time

I'm planning on running the SAME Exact Setup as you except with the HFS 3 Unit.
Jeff is actually soldering a jumper or something on the board now so that I'm able to run it with my Procede Rev.3.
Jeff is VERY knowledgeable with these systems, he might be able to help you out.
__________________
Motiv-900 HTA3794R | Motiv PI | Motiv/Fuel-IT! Stg3+ LPFP | Motiv Cobb AEM EMS | DSS Carbon Drive Shaft | Spec SuperTwin-disc
**** Front Mount | **** Charge Pipe | **** Oil Cooler | JRZ Coilover | ECS Performance Rear Trailing Arm | UUC Tans Mount | Full M3 Suspension | AR Line Lock | 5 Point Welded in Cage
Appreciate 0
      07-13-2012, 07:13 PM   #12
dblrguy
Private
United_States
2
Rep
90
Posts

Drives: 2010 335i & 06 330i
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

FAV and meth lines...

Here is how I mounted the FAV and ran the meth lines.
Name:  FAV.jpg
Views: 882
Size:  72.9 KB

Need to send props out to Jeff @ Howerton again. He called me up and helped me do a little troubleshooting over the phone. Everything seems to be connected correctly just need more time to play with my procede settings to get it flowing.
Appreciate 0
      07-13-2012, 08:56 PM   #13
dblrguy
Private
United_States
2
Rep
90
Posts

Drives: 2010 335i & 06 330i
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

more props!

Need to send out a thanks to Richard L from Aquamist. Jeff forwarded him this thread and he gave me a call, from the UK! Gave me some things to check and offered to help me over the weekend. That is customer service! Ill update again in the morning. I know I'm close.
Appreciate 0
      07-15-2012, 11:09 PM   #14
JMARS
Not Baned
Brazil
24
Rep
1,326
Posts

Drives: Single-T WTCC e90
Join Date: Aug 2008
Location: Boca Raton, FL

iTrader: (5)

Yes please keep up posted!
__________________
Motiv-900 HTA3794R | Motiv PI | Motiv/Fuel-IT! Stg3+ LPFP | Motiv Cobb AEM EMS | DSS Carbon Drive Shaft | Spec SuperTwin-disc
**** Front Mount | **** Charge Pipe | **** Oil Cooler | JRZ Coilover | ECS Performance Rear Trailing Arm | UUC Tans Mount | Full M3 Suspension | AR Line Lock | 5 Point Welded in Cage
Appreciate 0
      07-17-2012, 11:25 AM   #15
JMARS
Not Baned
Brazil
24
Rep
1,326
Posts

Drives: Single-T WTCC e90
Join Date: Aug 2008
Location: Boca Raton, FL

iTrader: (5)

Any Update?
__________________
Motiv-900 HTA3794R | Motiv PI | Motiv/Fuel-IT! Stg3+ LPFP | Motiv Cobb AEM EMS | DSS Carbon Drive Shaft | Spec SuperTwin-disc
**** Front Mount | **** Charge Pipe | **** Oil Cooler | JRZ Coilover | ECS Performance Rear Trailing Arm | UUC Tans Mount | Full M3 Suspension | AR Line Lock | 5 Point Welded in Cage
Appreciate 0
      07-18-2012, 10:00 PM   #16
dblrguy
Private
United_States
2
Rep
90
Posts

Drives: 2010 335i & 06 330i
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

YES!!!!!

Ok all, it works!

Here is a log I did today. This is a 3rd gear pull on map 4 with meth flowing.
Name:  3rd Meth Log.png
Views: 808
Size:  205.9 KB

There were two problems with my system. The first was that my flow sensor wire was bad from the factory. This was solved by Richard from Aquamist during a two hour call, on a Saturday, from the UK. New wire sent out by Jeff from Howerton Engineering first thing Monday.

I've said it before but I'll say it again, Richard from Aquamist has provided the best customer service I could possibly imagine from any company. We have exchanged at least 25 emails and he has probably paid for over 4 hours of long distance from the UK to Texas to help me solve my problems.

My other problem was that this picture was slightly misleading...
Name:  9 pin connector.png
Views: 707
Size:  382.0 KB
I thought "In" was for the flow sensor signal and "Out" was for the injector driver, this was an incorrect assumption. These two wires are reversed. The white wire (flow sensor) from the HSF-4 connects to the green wire of the Procede Rev3 9 pin connector. The green wire (PWM signal) from the HSF-4 connects to the blue on the Procede.

Richard is working on a new HSF-4 to Procede diagram. I will post it up and modify my original post with the correct connection information once he is finished.

Any questions?

~Nate
Appreciate 0
      07-18-2012, 10:05 PM   #17
dblrguy
Private
United_States
2
Rep
90
Posts

Drives: 2010 335i & 06 330i
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

Small side note...

For anyone on the fence about meth, GET IT! During my troubleshooting I was able to use it a bit without map switching by procede and I could see the IATs drop during flow. After I was able to get my problems sorted and utilize map switching I was blown away. I can confirm others comments about feeling the nose of the car lift and you just go when it starts to flow.
Appreciate 0
      07-18-2012, 10:17 PM   #18
6MTE92
Banned
6MTE92's Avatar
0
Rep
64
Posts

Drives: E92 6MT
Join Date: Jul 2012
Location: Florida

iTrader: (0)

Where are your nozzles mounted in the charge pipe? What size nozzles are you running?
Appreciate 0
      07-18-2012, 10:22 PM   #19
dblrguy
Private
United_States
2
Rep
90
Posts

Drives: 2010 335i & 06 330i
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

Quote:
Originally Posted by 6MTE92 View Post
Where are your nozzles mounted in the charge pipe? What size nozzles are you running?
Right where ER places them in the Long charge pipe for the N54. They are as far from the manifold as they could get. Two 1mm nozzles.
Appreciate 0
      07-18-2012, 10:41 PM   #20
6MTE92
Banned
6MTE92's Avatar
0
Rep
64
Posts

Drives: E92 6MT
Join Date: Jul 2012
Location: Florida

iTrader: (0)

Quote:
Originally Posted by dblrguy
Quote:
Originally Posted by 6MTE92 View Post
Where are your nozzles mounted in the charge pipe? What size nozzles are you running?
Right where ER places them in the Long charge pipe for the N54. They are as far from the manifold as they could get. Two 1mm nozzles.
And what concentration of meth/h2o are you using? I'm surprised to see your IAT's drop so much, mine never drop but just don't go up as fast, granted mine are about 3 inches more towards the front of the car.
Appreciate 0
      07-18-2012, 11:04 PM   #21
dblrguy
Private
United_States
2
Rep
90
Posts

Drives: 2010 335i & 06 330i
Join Date: Jun 2006
Location: Virginia

iTrader: (0)

Quote:
Originally Posted by 6MTE92 View Post
And what concentration of meth/h2o are you using?
I'm close to a 70/30 Meth/Water mix.

Do you see any problems with my log?
Appreciate 0
      07-18-2012, 11:09 PM   #22
6MTE92
Banned
6MTE92's Avatar
0
Rep
64
Posts

Drives: E92 6MT
Join Date: Jul 2012
Location: Florida

iTrader: (0)

Everything looks great but I would want to see fuel trims and timing also just to be sure.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 05:27 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST