E90Post
 


Lux Angel Eyes
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > 320i Rough on idle, EML flash, Codes



Reply
 
Thread Tools Search this Thread
      11-28-2012, 09:04 AM   #1
320icoupe
New Member
0
Rep
13
Posts

 
Drives: 320i Coupe Auto
Join Date: Nov 2012
Location: UK

iTrader: (0)

320i Rough on idle, EML flash, Codes

Got myself a 2009 320i a month ago, drives beautifully but car shakes violently at idle especially in cold mornings.
Obviously heard about the infamous coil issues and BMW changed them for me for free. New coil pack did not make any difference at all.
Today the shaking got even worse, RPM was all over the place and the engine management light flashed and then went off. Anyone experienced a similar problem? Checked codes and got:

2AAF - Fuel pump, plausibility
29DC - Cylinder injection cutout
2A2D - Fuel low pressure system fuel pressure
29D0 - Combustion misfire on cylinder 4

Mechanic suspecting spark plugs. What do you think guys? thanks.
Appreciate 0
      11-30-2012, 05:08 AM   #2
320icoupe
New Member
0
Rep
13
Posts

 
Drives: 320i Coupe Auto
Join Date: Nov 2012
Location: UK

iTrader: (0)

Bump. Anyone? please
Appreciate 0
      11-30-2012, 06:22 PM   #3
slowSwede
Lieutenant
Sweden
6
Rep
549
Posts

 
Drives: 335 coupe
Join Date: Jan 2010
Location: Skåne

iTrader: (0)

I'd guess a new fuel pump could do the trick. Spark plugs sound far fetched with your fueling codes.
Appreciate 0
      11-30-2012, 07:23 PM   #4
E92 M Sport
E92 FTW
E92 M Sport's Avatar
United_States
1
Rep
120
Posts

 
Drives: 2010 335i E92
Join Date: Aug 2012
Location: NJ

iTrader: (0)

My car idled rough at start up as it got colder, but not to the extent you describe and didn't throw any codes. Dealer replaced all 3 injectors in bank 1 and it's smooth now fwiw.
__________________
2010 335i Coupe
Appreciate 0
      12-02-2012, 07:50 PM   #5
cage911
Lieutenant
cage911's Avatar
United Kingdom
6
Rep
426
Posts

 
Drives: e93 Msport
Join Date: Dec 2011
Location: London

iTrader: (1)

I had this issue, the low fuel pressure sensor needed replacing. It was fine for about 4 weeks, the I needed to replace one of the fuel injector.
__________________
BMW E93 Sold but not forgotten.
Appreciate 0
      12-03-2012, 08:14 AM   #6
320icoupe
New Member
0
Rep
13
Posts

 
Drives: 320i Coupe Auto
Join Date: Nov 2012
Location: UK

iTrader: (0)

Thanks everyone. Mechanic is playing the guessing game. Will sort out the low fuel pressure sensor and change fuel filter and spark plugs and report back.
Appreciate 0
      05-14-2013, 07:07 AM   #7
mattathm
Registered
0
Rep
1
Posts

 
Drives: 320i E90
Join Date: Feb 2013
Location: NZ

iTrader: (0)

Bump
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 10:30 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST