E90Post
 


Horizon LED
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > HELP! Car turning on and off multiple times!



Reply
 
Thread Tools Search this Thread
      12-01-2012, 08:30 PM   #1
MstrRogers330i
Private First Class
MstrRogers330i's Avatar
3
Rep
109
Posts

 
Drives: 2006 BMW 330i
Join Date: Apr 2011
Location: Columbia, MO

iTrader: (0)

Garage List
2006 330i  [0.00]
HELP! Car turning on and off multiple times!

So I'm driving down the road and all of a sudden my car turns off and on about 8-10 times in the matter of a few seconds, then it works. Has happened twice before. Any ideas?
Appreciate 0
      12-02-2012, 07:52 AM   #2
MstrRogers330i
Private First Class
MstrRogers330i's Avatar
3
Rep
109
Posts

 
Drives: 2006 BMW 330i
Join Date: Apr 2011
Location: Columbia, MO

iTrader: (0)

Garage List
2006 330i  [0.00]
Bump. Hoping for some answers since this has happened on a highway and practically stalled me for a few seconds without any lights
Appreciate 0
      12-02-2012, 09:56 AM   #3
John 070
Lieutenant General
157
Rep
11,517
Posts

 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

iTrader: (0)

Not sure about turning on and off in rapid succession, but a faulty DME can be the cause of unexplained stalling (no codes, etc.).
Appreciate 0
      12-03-2012, 09:00 AM   #4
MstrRogers330i
Private First Class
MstrRogers330i's Avatar
3
Rep
109
Posts

 
Drives: 2006 BMW 330i
Join Date: Apr 2011
Location: Columbia, MO

iTrader: (0)

Garage List
2006 330i  [0.00]
Quote:
Originally Posted by John 070
Not sure about turning on and off in rapid succession, but a faulty DME can be the cause of unexplained stalling (no codes, etc.).
That would be unfortunate
Appreciate 0
      12-05-2012, 05:54 PM   #5
MstrRogers330i
Private First Class
MstrRogers330i's Avatar
3
Rep
109
Posts

 
Drives: 2006 BMW 330i
Join Date: Apr 2011
Location: Columbia, MO

iTrader: (0)

Garage List
2006 330i  [0.00]
bump.....really trying to figure this out
Appreciate 0
      12-05-2012, 05:57 PM   #6
Amini77
Brigadier General
Amini77's Avatar
United_States
63
Rep
4,611
Posts

 
Drives: SGM E90 330xi
Join Date: Nov 2011
Location: Tarzana, CA

iTrader: (1)

Garage List
2006 330XI  [3.75]
Best bet is to just get it checked out, it can be anything really. No weird noises or anything?
__________________

instagram: amini77
| KW V1 | LCI rear | 359m Style | Michelin PSS | AA Stage 2 | Gruppe M | Remus | Mtech Rear | M3 Front |
Appreciate 0
      12-05-2012, 05:59 PM   #7
GoRomeo
Colonel
GoRomeo's Avatar
26
Rep
2,371
Posts

 
Drives: 330i
Join Date: Feb 2006
Location: San Diego CA

iTrader: (0)

Garage List
2006 330i  [2.83]
Sounds like an electrical problem for sure. I would start by testing the battery and alternator... keep us posted.
Appreciate 0
      12-05-2012, 06:07 PM   #8
John 070
Lieutenant General
157
Rep
11,517
Posts

 
Drives: 335i cpe
Join Date: Oct 2006
Location: ZSP/ZPP/ZCW

iTrader: (0)

Seriously, DME can cause random stalling, with no SES and no shadow faults either. Because it's so expensive, the dealership needs approval from the prime minister of Germany and Great Britain, like a prior auth if you have a lousy health plan.
Appreciate 0
      12-05-2012, 06:09 PM   #9
E9TOU
First Lieutenant
United_States
3
Rep
349
Posts

 
Drives: 2010 E92 335i
Join Date: Apr 2008
Location: Goleta, CA

iTrader: (0)

Garage List
Send a message via AIM to E9TOU
Maybe your car inherited the new engine start/stop feature.
Appreciate 0
      12-05-2012, 08:25 PM   #10
Das_Stig
I don't drink water. Fish fuck in it.
Das_Stig's Avatar
16
Rep
839
Posts

 
Drives: e90 335xi
Join Date: Nov 2012
Location: Some say he naturally faces magnetic north, and that all of his legs are hydraulic...

iTrader: (1)

if you ran over a squirrel it could be its ghost haunting your car... happened to a friend of mine.
who ya gonna call!?
Appreciate 0
      12-09-2012, 01:21 AM   #11
MstrRogers330i
Private First Class
MstrRogers330i's Avatar
3
Rep
109
Posts

 
Drives: 2006 BMW 330i
Join Date: Apr 2011
Location: Columbia, MO

iTrader: (0)

Garage List
2006 330i  [0.00]
Quote:
Originally Posted by GoRomeo View Post
Sounds like an electrical problem for sure. I would start by testing the battery and alternator... keep us posted.
Battery is only 3 months old or so, hoping thats not the issue.
Appreciate 0
      12-09-2012, 05:27 PM   #12
bumere90
Grozniy
United_States
52
Rep
2,601
Posts

 
Drives: Carless
Join Date: Jan 2009
Location: FL

iTrader: (12)

Get it scanned
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:11 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST