E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > airbag light ON? anyone has this problem?



Reply
 
Thread Tools Search this Thread
      06-04-2009, 11:07 PM   #1
BM2006i
Second Lieutenant
 
Drives: BMW
Join Date: Feb 2006
Location: USA

Posts: 263
iTrader: (0)

airbag light ON? anyone has this problem?

this is the first time i experienced this. i parked the car tonight for dinner, came back with my gf and turned the engine on. the AIRBAG light came on, at first i thought it was the seatbelts, took the belts off and fasten the belts again, then drove for 20 to 30 secs.. then light was still on. we pulled to the side, turned car off, waited 1 min, turned the car back on again, AIRBAG light was off.

Then Drove 1 miles, went to my friends place for 30 mins, Came back and turned the car on, AIRBAG light ON again. Turned the car off, Turned it on again, it was fine.. drove 10 miles home then parked. started the car after 10 mins, and it was fine.

has anyone has this problem before? what is the cause?

thanks

Last edited by BM2006i; 06-04-2009 at 11:51 PM.
BM2006i is offline  
0
Reply With Quote
      06-05-2009, 12:26 AM   #2
BK
Smiling politely
 
Drives: 330i
Join Date: Feb 2006
Location: Washington DC

Posts: 7,908
iTrader: (0)

Garage List
2006 330i  [4.50]
What year is your car? I think the early build 2006 models had a recall on the front passenger seat airbag sensor.
__________________

330i | Black Sapphire | Beige + Burl | Sport | Premium | Cold | Nav | CA | Sat prep
BK is offline   United_States
0
Reply With Quote
      06-05-2009, 01:10 AM   #3
BM2006i
Second Lieutenant
 
Drives: BMW
Join Date: Feb 2006
Location: USA

Posts: 263
iTrader: (0)

my car is 2006 march built.

hey, there is a recall? do you have a link to the recall info about the airbag?

Can someone confirm if there was a recall for the airbag for the ear 2006?
thanks
BM2006i is offline  
0
Reply With Quote
      06-05-2009, 01:15 AM   #4
GregL
Brigadier General
 
GregL's Avatar
 
Drives: 2010 C350 4Matic
Join Date: Nov 2005
Location: GTA

Posts: 3,623
iTrader: (4)

I can't find the TSB but here's a link describing it http://www.msnbc.msn.com/id/26179745/
__________________
2010 Mercedes-Benz C350 4Matic
2006 BMW 330xi - Gone
GregL is offline   Canada
0
Reply With Quote
      06-05-2009, 06:42 PM   #5
HermesRider
Captain
 
Drives: 2007 e92 335i
Join Date: Mar 2008
Location: Portland, OR

Posts: 949
iTrader: (0)

Call your SA, provide VIN, see if there is recall.
HermesRider is offline   United_States
0
Reply With Quote
      06-05-2009, 06:50 PM   #6
MMachines
BMW Owner
 
Drives: 2006 330i, 2008 M3
Join Date: Mar 2009
Location: Downtown Toronto

Posts: 428
iTrader: (1)

There's a recall for the passenger occupancy sensor in the US but not in Canada. I have the problem with my early build 06 and have yet to see if CPO covers this.
__________________
2006 330i & 2008 M3
MMachines is offline   Canada
0
Reply With Quote
      06-05-2009, 07:36 PM   #7
BM2006i
Second Lieutenant
 
Drives: BMW
Join Date: Feb 2006
Location: USA

Posts: 263
iTrader: (0)

i've tested it again this morning. when i start the engine, the Airbag light comes on ONLY when i have a passenger in the front seat. When it's on, it will stay on. The weird thing is IF i turned the engine off(with the passenger still in the seat, wait 20 secs) and started the car again, the airbag light was off and became normal again.

does this mean there's a sensor problem? or airbag problem?
thanks
BM2006i is offline  
0
Reply With Quote
      06-05-2009, 08:06 PM   #8
GregL
Brigadier General
 
GregL's Avatar
 
Drives: 2010 C350 4Matic
Join Date: Nov 2005
Location: GTA

Posts: 3,623
iTrader: (4)

Quote:
Originally Posted by MovinUp View Post
There's a recall for the passenger occupancy sensor in the US but not in Canada. I have the problem with my early build 06 and have yet to see if CPO covers this.
However I see in your sig that you have ZSP, according to the article this particular recall campaign only applies to standard seats. However if you're having the same problem, your dealer really should be able to do something especially with the liability concerning airbag problems... unless the dealer you go to is Autohaus in which case I understand their not wanting to do squat.
__________________
2010 Mercedes-Benz C350 4Matic
2006 BMW 330xi - Gone
GregL is offline   Canada
0
Reply With Quote
      06-05-2009, 08:11 PM   #9
GregL
Brigadier General
 
GregL's Avatar
 
Drives: 2010 C350 4Matic
Join Date: Nov 2005
Location: GTA

Posts: 3,623
iTrader: (4)

Quote:
Originally Posted by BM2006i View Post
i've tested it again this morning. when i start the engine, the Airbag light comes on ONLY when i have a passenger in the front seat. When it's on, it will stay on. The weird thing is IF i turned the engine off(with the passenger still in the seat, wait 20 secs) and started the car again, the airbag light was off and became normal again.

does this mean there's a sensor problem? or airbag problem?
thanks
The seat mat as referred to in the article and the airbag sensor are one in the same. As HermesRider said, call your dealer and provide your VIN number, they will be able to tell you straight away if your car is affected.
__________________
2010 Mercedes-Benz C350 4Matic
2006 BMW 330xi - Gone
GregL is offline   Canada
0
Reply With Quote
      06-05-2009, 08:43 PM   #10
MMachines
BMW Owner
 
Drives: 2006 330i, 2008 M3
Join Date: Mar 2009
Location: Downtown Toronto

Posts: 428
iTrader: (1)

I had called Autohaus, they said it'd cost me $120 to determine if it's covered by CPO. Same thing Durham said. The dealer I got it from is out of town so going there isn't really an option as I'm too busy to go there, likely twice, and continue to argue.

Although I don't have specific recall info, I was told my car doesn't qualify. I apologize if my previous post mislead anyone. I know another guy with the same mileage, non ZSP, with the exact same problem. I think the "reconditioning" (as per CPO website) process on my car was not done or something, cause oh man were there ever a lot of fault codes in the computer when I had a friend check it out, and it needed a new battery one and the airbag faults were there day one as well. Anyway, Performance BMW in St Catherines and Joe Primo can shove it. So can BMW Canada for telling me I should have done my due diligence. Sorry for the too much info.
__________________
2006 330i & 2008 M3
MMachines is offline   Canada
0
Reply With Quote
      06-05-2009, 09:01 PM   #11
SoCalTech
Captain
 
Drives: Not a BMW yet...
Join Date: Oct 2008
Location: Redondo Beach, Ca

Posts: 649
iTrader: (0)

BM2006i, where in the USA do you live?
SoCalTech is offline   United_States
0
Reply With Quote
      06-05-2009, 09:15 PM   #12
poiney
Captain
 
Drives: 328i coupe
Join Date: Dec 2006
Location: SJ

Posts: 798
iTrader: (0)

I had something funky like what the OP described on my passenger side. It sort of resolved itself. My car is a 2007.
poiney is offline  
0
Reply With Quote
      06-06-2009, 11:12 PM   #13
BM2006i
Second Lieutenant
 
Drives: BMW
Join Date: Feb 2006
Location: USA

Posts: 263
iTrader: (0)

Quote:
Originally Posted by poiney View Post
I had something funky like what the OP described on my passenger side. It sort of resolved itself. My car is a 2007.
how did it resolve itself? has it come back?

by the way, SoCalTech, i'm in New York/NJ area. Have you had the same problem?
BM2006i is offline  
0
Reply With Quote
      06-06-2009, 11:16 PM   #14
shift330
Blue Force Tracker
 
shift330's Avatar
 
Drives: 2010 Hyundai Genesis Coupe
Join Date: Feb 2008
Location: Sierra Vista, AZ

Posts: 1,377
iTrader: (6)

Garage List
2006 330i  [0.00]
I had the same issue at around 40k miles. Just take your car to the dealer and they'll replace the front passenger seat coushion and sensor for you. There wasn't even a recall going on when it happened to me but they didn't hesitate to replace it.

Quote:
To respond to the problem, BMW said it would extend the warranty to 10 years without any mileage limit for the following vehicles: 2006 6 Series, 2006 3 Series with standard seat, 2004-2005 Z4, 2004-2006 7 Series, 2006 X5, and 2004-2006 5 Series with comfort seats.
I've got sport seats and still had the problem but I assume they would also cover sport seats if you're out of warranty on you 325 and you have sport instead of standard seats.
__________________

Stay safe 855th MP Company! Hosmer/Espinoza you're my boys!!

Last edited by shift330; 06-06-2009 at 11:32 PM.
shift330 is offline   United_States
0
Reply With Quote
      06-07-2009, 12:54 AM   #15
SoCalTech
Captain
 
Drives: Not a BMW yet...
Join Date: Oct 2008
Location: Redondo Beach, Ca

Posts: 649
iTrader: (0)

Quote:
Originally Posted by BM2006i View Post
by the way, SoCalTech, i'm in New York/NJ area. Have you had the same problem?
Haven't had the same problem, I was just hoping you were local so I could fix it for you.
SoCalTech is offline   United_States
0
Reply With Quote
      06-07-2009, 01:11 AM   #16
MCMLXXXIX
wat
 
MCMLXXXIX's Avatar
 
Drives: a gr3at whit3 5hark
Join Date: Oct 2008
Location: Oct 2008

Posts: 3,410
iTrader: (0)

ive had the passenger airbag light go off on my previous 06 e90 325. took it to the dealer and had it fixed
__________________

2012 Toyota Highlander SE - PAST - 2008 e92 335i, 2006 e90 325i
MCMLXXXIX is offline  
0
Reply With Quote
      06-07-2009, 02:18 AM   #17
kuvesh
Lieutenant
 
kuvesh's Avatar
 
Drives: e92 335i juiced
Join Date: Jun 2008
Location: singapore

Posts: 513
iTrader: (1)

had a similar problem in my old e46 m3. went to get it fixed. the car was out of warranty and it cost a few hundred buck for them to replace the seat sensor...
__________________

HAMANN FRONT APRON, SIDES, ROOF SPOILER & QUAD DIFFUSER | VORSTEINER VRS TRUNK | CSC3 ON 19 ADVAN RS | BREMBO GT BBK | BASTUCK QUAD | KW V2 | JB3 v1.3s beta | BMW PERFORMANCE STEERING WHEEL | M3 SIDE MIRRORS | M5 SMG SHIFT KNOB | BLACKOUT GRILLS | PARTIALLY SMOKED LIGHTS | WINDOW TINT
kuvesh is offline   Singapore
0
Reply With Quote
      06-07-2009, 09:01 AM   #18
poiney
Captain
 
Drives: 328i coupe
Join Date: Dec 2006
Location: SJ

Posts: 798
iTrader: (0)

Quote:
Originally Posted by BM2006i View Post
how did it resolve itself? has it come back?

by the way, SoCalTech, i'm in New York/NJ area. Have you had the same problem?
It happened ~ 1.5 years ago. It hasn't come back. IIRC, I told BMW to check it whenever I brought in the car after it happened, but by then it was no longer doing it. I think BMW service dept said they dis/reconnected cables just to make sure, but IIRC, there was no fault found.
poiney is offline  
0
Reply With Quote
      10-13-2011, 08:43 PM   #19
nick0110
Registered
 
Drives: 06 325i
Join Date: Oct 2011
Location: beaufort sc

Posts: 3
iTrader: (0)

FML im having the same exact problem on my 2006 325i 52000 miles! called bmw usa with my vin to see if there was a warranty on it and there was nothing! im not sure if mine is a early build or not im assuming its late because there is no warranty. sooooo anyone know if im shit out of luck and have to pay out of pocket to get it fix if so anyone know around how much it should cost??
nick0110 is offline  
0
Reply With Quote
      11-15-2011, 10:41 PM   #20
sweetbeemer12
Registered
 
Drives: 2006 bmw 325i
Join Date: Nov 2011
Location: Clovis, NM

Posts: 1
iTrader: (0)

Call the NHSTA and file a complaint.. they gave me a complaint # and phone number for the attorney general to investigate my concern. I have the same issue with my it is a 06 325i with 53k miles and the lights stay on. call them and report it so maybe they will issue a full on recall for everyone to benefit from.

NHSTA phone number: 1-888-327-4236
sweetbeemer12 is offline  
0
Reply With Quote
      02-27-2012, 12:29 PM   #21
louie260
Registered
 
Drives: 325xi wagon
Join Date: Feb 2012
Location: fort lee

Posts: 3
iTrader: (0)

My 2006 325xi wagon had the same problem at 42K mi. Brought Tenafly BMW, they wanted $200 just to run the diagnosis. Plush extra to fix if there is a problem.. I asked if there is a recall. She said no.. Then I brought my car to my mechanical in Palisades Park, NJ. The owner ran a test, reset and turned off the lights. DONE! He said it could be short wire or the sensor. But at least the lights are off. I tipped him $10...
(BTW, the owner at Alltech has been treating my bimmer like his car. Highly recommended)
louie260 is offline  
0
Reply With Quote
      02-27-2012, 12:48 PM   #22
leod
New Member
 
Drives: 2012 e92 335i Msport
Join Date: Sep 2011
Location: philly

Posts: 17
iTrader: (0)

Quote:
Originally Posted by shift330 View Post
I had the same issue at around 40k miles. Just take your car to the dealer and they'll replace the front passenger seat coushion and sensor for you. There wasn't even a recall going on when it happened to me but they didn't hesitate to replace it.



I've got sport seats and still had the problem but I assume they would also cover sport seats if you're out of warranty on you 325 and you have sport instead of standard seats.
I had the standard seats in mine and had it replaced. I complained to the dealer before the recall about the same issues, and even after the recall was anounced, they still calimed it didnt exist until I got a postcard from BMW that said my car had been recalled. anyway, here is the link to the NHTSA recall listing.

http://www-odi.nhtsa.dot.gov/cars/pr...type=DrillDown

here is the defect notice BMW filed with the NHTSA, you'll notice on page 2 its stated they repair the sport seat, and replace the standard.

http://nhthqnwws112.odi.nhtsa.dot.go...8V384-5007.pdf
leod is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:37 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST