E90Post
 


VIBE Motorsports
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > have hifi system but logic7 interface



Reply
 
Thread Tools Search this Thread
      12-06-2012, 01:16 PM   #1
CruzS4e92
Lieutenant
 
CruzS4e92's Avatar
 
Drives: 2009 E92 328i coupe
Join Date: Oct 2012
Location: Horsham, PA/Sea Isle City, NJ

Posts: 414
iTrader: (0)

have hifi system but logic7 interface

Alright bear with me as this is sort of technical; (yes i searched as well)

2009 e92 328i, and as I've verified with bwmvin.com, my car HAS the HiFi system (non idrive, Professional head unit).

Alright I bought my car at the end of this June, and about a month later the head unit would be off every third or so time I started the car, (just displayed time) and couldn't get any sound out of it even after restarting the car; it would have to sit parked for a while then would be fine.

So since it was under warranty I took it to the dealer and they couldn't diagnose it so they kept it overnight to "update" it which I interpreted as encoding it with the latest software...

So anyway I was driving saturday and listening to a moderately bass intensive song with bass at +2 but not at a volume that should have done any damage to amped speakers... After a minute or so faint electronic burning smell so I shut it down immediately. No blown speakers or anything so I figured something minor with a voice coil or speaker glue (even though the car has a build date in '08).

So I search search search on forums etc and come to find that my head unit "has" Logic7, (Logic7 on/off and equalizer available) Logic7 having been "on" for months.

So I was talking to my buddy who has a shop and access to the BMW coding interface and can't believe they'd even be able to make a mistake like this. So I'm thinking if they did, and my head unit was sending processing meant for Logic7 to my amp/speakers, could that explain the burning smell have damaged anything? Sort of a hypochondriac when it comes to this stuff.

Btw it sounds much better with Logic7 "off".

TL/DR for most but I figure some may have some insight. If so should I call the dealership that did it? warranty is up at month's end
__________________

'09 328i coupe 6MT Sport
SG/CR - BMW SSK/alcantara boot - 30% Llumar - Shadowline - BBS Style 197 - LUX H8 V3 LEDs - OEM Aero Lip

Last edited by CruzS4e92; 12-06-2012 at 02:45 PM.
CruzS4e92 is offline  
0
Reply With Quote
      12-06-2012, 01:28 PM   #2
Das_Stig
I don't drink water. Fish fuck in it.
 
Das_Stig's Avatar
 
Drives: e90 335xi
Join Date: Nov 2012
Location: Some say he naturally faces magnetic north, and that all of his legs are hydraulic...

Posts: 839
iTrader: (1)

really? i find it way better with it on. if i were you i would take i t in and get it taken care of while under warranty. unless you like paying for stuff you dont have to
Das_Stig is offline  
0
Reply With Quote
      12-06-2012, 02:17 PM   #3
ctuna
Brigadier General
 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

Posts: 4,225
iTrader: (0)

L7 is called Top Hi Fi

L7 is called Top Hi Fi
Its not possible to have both as the interface between the amp
and head unit is totally different. One is fiberoptic (l7) and the other is analog
(Hi Fi) and the amps are different to accommodate this see diagrams below and info below.

Audio sub board is here

http://www.e90post.com/forums/forumdisplay.php?f=27
Also Fyi
http://www.e90post.com/forums/showthread.php?t=641323

BMW stereo types
http://www.e90post.com/forums/showthread.php?t=352586
http://www.e90post.com/forums/attach...2&d=1266451970
http://www.e90post.com/forums/attach...2&d=1260829447
http://www.e90post.com/forums/showthread.php?t=343673
http://www.e90post.com/forums/showthread.php?t=138949
http://www.e90post.com/forums/attach...2&d=1260829447
http://www.e90post.com/forums/attach...1&d=1209780605
http://www.e90post.com/forums/attach...1&d=1209780865
http://www.google.com/url?sa=t&rct=j...QNFyu70IsyKRlg
http://www.musicarnw.com/page-2/
http://www.e90post.com/forums/attach...4&d=1278871872

If the battery is low the ibs system can turn off electrical devices.
see google link for explanation not saying that's what it is but its
a possibility.
There are quite a few L7 users that share your observation that the system sounds better with L7 off.

Last edited by ctuna; 12-06-2012 at 02:25 PM.
ctuna is offline  
0
Reply With Quote
      12-06-2012, 02:45 PM   #4
CruzS4e92
Lieutenant
 
CruzS4e92's Avatar
 
Drives: 2009 E92 328i coupe
Join Date: Oct 2012
Location: Horsham, PA/Sea Isle City, NJ

Posts: 414
iTrader: (0)

alright well i have a silver amp does that automatically mean it's L7?
__________________

'09 328i coupe 6MT Sport
SG/CR - BMW SSK/alcantara boot - 30% Llumar - Shadowline - BBS Style 197 - LUX H8 V3 LEDs - OEM Aero Lip
CruzS4e92 is offline  
0
Reply With Quote
      12-06-2012, 04:28 PM   #5
ctuna
Brigadier General
 
Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

Posts: 4,225
iTrader: (0)

It does if its 09 or earlier.

It does if its 09 or earlier.
post 2010 hi fi amps are silver pre are black.
At least in the US.
ctuna is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:47 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST