E90Post
 


Sparta Evolution
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > 29e1 code



Reply
 
Thread Tools Search this Thread
      02-05-2013, 08:50 PM   #23
Rickygst
Private First Class
1
Rep
154
Posts

Drives: 335i
Join Date: Jun 2010
Location: Atlanta

iTrader: (3)

My car is at the dealer right now. I'm not having power loss. This has to be something simple. Dealer has not figure it out. I will keep you all posted on what I find out.
Appreciate 0
      02-05-2013, 08:52 PM   #24
Rickygst
Private First Class
1
Rep
154
Posts

Drives: 335i
Join Date: Jun 2010
Location: Atlanta

iTrader: (3)

slostjoe, which codes are you getting. Is it just the 29e1 code or is there others?
Appreciate 0
      02-06-2013, 08:57 PM   #25
slostjoe
NEWBICON
United_States
4
Rep
306
Posts

Drives: E92 335i
Join Date: Jul 2012
Location: Springfield, MO

iTrader: (6)

I've gotten misfire codes and I assume it was just because of my NLS module. I've gotten a couple T map codes and a couple throttlebody codes nothing consistent.

I'm literally replacing everything on my car to trace down this issue.
__________________
2013 Race Red GT500 708whp
www.cmsmotorsports.com
Appreciate 0
      02-12-2013, 01:28 AM   #26
E90Flossin
Vroooomm
2
Rep
196
Posts

Drives: Lci 335i
Join Date: Aug 2012
Location: Los Angeles

iTrader: (1)

I am also receiving the P29E1 and P2AAF. I am running Stage 2 cobb aggressive with the mix of E85 and 91 octane. I believe it's the fuel mixture. Also feeling loss of power, but maybe that's just me? Anyone have a clue?
Appreciate 0
      02-17-2013, 01:01 AM   #27
Rickygst
Private First Class
1
Rep
154
Posts

Drives: 335i
Join Date: Jun 2010
Location: Atlanta

iTrader: (3)

So I been driving the car for about two weeks now. The code has not come back since the injectors replacement. So my problem seen to have been the injectors. I was getting the 29e1 code before the new injectors.
So anyone getting this code, here are some things to look for. Air getting in somehow, may need to smoke test, Fuel related (injectors, fuel pump, etc.), maybe carbon buildup (Unlikely the cause but a problem), verify o2 sensors are working (Most likely not the issue but check anyway). I was on a stock tune.
Hope this helps someone
Appreciate 0
      02-17-2013, 05:57 AM   #28
joec500
Brigadier General
47
Rep
3,004
Posts

Drives: it has 4 wheels
Join Date: Jul 2008
Location: San Francisco

iTrader: (10)

Quote:
Originally Posted by Rickygst View Post
So I been driving the car for about two weeks now. The code has not come back since the injectors replacement. So my problem seen to have been the injectors. I was getting the 29e1 code before the new injectors.
So anyone getting this code, here are some things to look for. Air getting in somehow, may need to smoke test, Fuel related (injectors, fuel pump, etc.), maybe carbon buildup (Unlikely the cause but a problem), verify o2 sensors are working (Most likely not the issue but check anyway). I was on a stock tune.
Hope this helps someone
I also had a persistent 29E1 code...I replaced all 3 Bank 2 injectors and the code has yet to return for 2 months.
__________________
2007 E92 6MT SGM: MusicarNW Level 2, Procede Rev 2.5, FFTEC/Vishnu LPFP with Flexfuel Sensor and Flash, M3 Offset V701's, WaveTrac LSD, Michelin PSS, Downpipes, M3 Control Arms, TCKline D/A Suspension, LCI Tail lights, Lux AE's, ER Charge Pipe, DCI's, Mtech Front and Rear, M3 Sideskirts, HPF Stage 1 Clutch
Appreciate 0
      05-06-2013, 07:39 PM   #29
Indo Rider
Second Lieutenant
6
Rep
236
Posts

Drives: 135
Join Date: Apr 2012
Location: United States

iTrader: (0)

What kind of issue with a fuel injector could cause this code but not result in some other perceivable issue like a misfire or the plug on that cylinder looking fouled?

This code keeps coming back but I haven't been able to track it down conclusively. Seems neither has anyone else... Anybody got any updates?
Appreciate 0
      06-09-2014, 09:10 PM   #30
westchester335i
Second Lieutenant
4
Rep
295
Posts

Drives: 335i
Join Date: Oct 2013
Location: Westchester

iTrader: (1)

bump for updates

Got this code last week and after 1k miles its back. I just keep clearing it. Had a boost leak but fixed it and car runs and pulls fine.
Appreciate 0
      07-23-2014, 06:42 PM   #31
tb30570
Private
tb30570's Avatar
1
Rep
81
Posts

Drives: 2008 BMW 335xi Coupe 6-Speed
Join Date: May 2013
Location: Quad Cities

iTrader: (0)

Hi All,

I have a 2008 335xi that is keeps getting p0175 Rich Bank 1 & p29e1 Mix Control 2 codes together.

I'm not getting misfire codes.

Do mix control 2 and bank 1 cover the same cylinders? Could the o2 sensors be switched around?

What should I do first?

Car Background:
-idle isn't rough but not super smooth either
-New spark plugs about 10k miles ago
-Catless downpines
-Larger CXRacing intercooler
-93 octane E10 gasoline
-Cobb Stage2+FMIC Aggressive tune
__________________
2008 BMW 335xi Coupe 6-speed, 12.8 @ 107
2000 Chevrolet Corvette Z51, 11.4 @ 123
2005 Saturn Ion Redline, 14.1 @ 100 (sold Jun-2013)

Last edited by tb30570; 07-23-2014 at 07:10 PM.
Appreciate 0
      07-28-2014, 04:05 PM   #32
Bimmer Barney
First Lieutenant
Bimmer Barney's Avatar
6
Rep
397
Posts

Drives: 2007 335i Sedan
Join Date: Jan 2011
Location: Santa Barbara, CA

iTrader: (4)

I'm also gettin 29E1 and from my research the suggested causes (most suggested causes) are injectors, O2 sensors and/or LPFP.
__________________
2007 SGM E90 335i
JB4 G4, Mr.5 Intake, VRSF 7" FMIC, ER Sport Oil Cooler, RB PCV Valve, Cyba Scoops and Quad Tips, 17x9 ET30 and 17x9.5 ET35 Concave Apex Arc 8, M3 UCA/LCA
Appreciate 0
      11-19-2014, 03:38 AM   #33
Stevan335
Enlisted Member
Stevan335's Avatar
0
Rep
31
Posts

Drives: e93 - 335i
Join Date: Nov 2013
Location: FL - HH

iTrader: (0)

29E1

Also get the 29E1 f***ing code.
Car is double FBO

replaced O2 front Bank 2 sensor
Cleaned my injectors via ultraschall
Do a valve clean
ngkīs 10k on the car
HPFP new
LPFP inline 255

driving the jb4 e85 flash e50

will try now to drive without e85
Maybe the problem is the winterethanol in germany.
itīs not e85, itīs e75 in the winter month
Appreciate 0
      11-19-2014, 08:41 AM   #34
KeepRidingDirty
Professional Money Trainer
KeepRidingDirty's Avatar
Canada
2
Rep
160
Posts

Drives: 2007 BMW 335xi
Join Date: Aug 2014
Location: Ottawa, On

iTrader: (0)

+1

My 29E1 codes were from my injectors dumping fuel into the cylinders while sitting overnight (leaky injectors) causing it to run rich. If your not running E85 or an ethanol mix this is most likely your culprit.

Quote:
Originally Posted by Bimmer Barney View Post
I'm also gettin 29E1 and from my research the suggested causes (most suggested causes) are injectors, O2 sensors and/or LPFP.
Appreciate 0
      11-19-2014, 09:35 AM   #35
Tim603
Major
Tim603's Avatar
United_States
24
Rep
1,135
Posts

Drives: 2007 335i E90
Join Date: Feb 2012
Location: North Canton, OH

iTrader: (3)

Quote:
Originally Posted by Indo Rider View Post
What kind of issue with a fuel injector could cause this code but not result in some other perceivable issue like a misfire or the plug on that cylinder looking fouled?

This code keeps coming back but I haven't been able to track it down conclusively. Seems neither has anyone else... Anybody got any updates?
You could be running a little lean or rich and not have a misfire, as far as the plug fouling, it only takes a little less fuel than required to be lean and that may not be represented on the plug.
__________________
Appreciate 0
      01-01-2015, 01:40 PM   #36
Jeffman
Lieutenant
Jeffman's Avatar
5
Rep
441
Posts

Drives: 2008 335xi E90
Join Date: Jul 2010
Location: Somewhere in America

iTrader: (1)

Garage List
I'm interested in reviving this thread as my p29e0 and p29e1 codes are back after switching back to 93 octane from E40. Here are some Observations/Comments/Questions/Thoughts/Musings/Ideas:

1. p29e0 and p29e1 happen only when car is cold (like sitting overnight when it's 40F or lower outside).

2. These codes don't appear immediately upon starting the engine. Takes at least a few minutes while idling or simple cruising - no WOT or high revving.

3. This is really interesting: I never got these codes for several months, including in cold weather recently, with my latest E40 map that I created using Cobb ATR. My E40 scalars were very high (1.4-1.5) to bring my STFT trims down below 20 during WOTs.
So I'm wondering what tuning parameters could possibly be adjusted to help prevent these lean codes from appearing - maybe adjust up the fuel scalars? My 93 oct ATR map has 3D scalars starting at 1.04 (from 1.00) at idling. Still getting the codes. I'll probably up the scalars to 1.1.

4. These codes first appeared last year after experimenting with E85 (I had started several threads in 2013 about this). Going back to the stock tune did not eliminate these codes at the time.

5. A previous poster suggested leaking injectors could cause these p29e0/p29e1 codes. But aren't these codes triggered in a lean condition? I'd expect leaking injectors dumping fuel into the cylinders overnight would cause a rich condition?

6. Ethanol has about three times the viscosity as gasoline (about 1.1 cP versus 0.4 cP at ambient temp, I think). Ethanol / gas blends would probably be somewhere in between. E40 would like be twice as viscous as E10; much more so in cold weather. Could the injectors be slightly permanently deformed somehow using cold E40 one morning? (I need to go look at the injector designs). Then switching back to gasoline might later result in leaking - remember, gasoline has lower viscosity.

7. Materials contract in cold weather. Upon starting a cold engine cylinders warm first, followed by parts (e.g., injectors, and fuel runners) connected to the engine. Could thermal expansion mismatch result in a lean condition?

8. Cold fuel in tank has higher viscosity and thus harder for the LPFP to pump.

Any thoughts or comments from anyone?
Thanks, and happy new year.
Appreciate 0
      01-02-2015, 08:35 AM   #37
Jeffman
Lieutenant
Jeffman's Avatar
5
Rep
441
Posts

Drives: 2008 335xi E90
Join Date: Jul 2010
Location: Somewhere in America

iTrader: (1)

Garage List
9. Colder temps -> colder air -> more oxygen -> leaner mixtures if the engine is not properly compensating for colder temps.
Appreciate 0
      01-02-2015, 08:41 AM   #38
Jeffman
Lieutenant
Jeffman's Avatar
5
Rep
441
Posts

Drives: 2008 335xi E90
Join Date: Jul 2010
Location: Somewhere in America

iTrader: (1)

Garage List
10. A lot of the problems mentioned by people in this thread happened in the winter. Spend 2-3 months trying to solve the problem - parts, dealer, etc. - then something seems to work. Changed O2 sensors, changed injectors, changed tune, changed gas, etc. All different solutions and everybody seems to have a different answer. But one thing everyone seems to have in common is p29e1 appearing in the colder weather months at it going away a few months later.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:42 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST