E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Engine Malfunction



Reply
 
Thread Tools Search this Thread
      12-15-2012, 05:14 AM   #1
skatenc123
Captain
 
skatenc123's Avatar
 
Drives: 2007 335i coupe
Join Date: Jan 2012
Location: NC

Posts: 648
iTrader: (1)

Exclamation Engine Malfunction

Ok guys. so i installed the bms dp fix yesterday for emissions. passed.
but after that i uninstalled it, car started right up so i went ahead and loaded back up cobb stg2+.

car was running ok but i was having a p2c7f (lambda probe after cat 2. trimming control) and p2c6a (lambda prove after cat reversed).

but once i got into boost i got a bunch of codes p29cf, p29ce, p29cd, p29cf, p29cc (misfires) p30ba (injector, pwer stage) p2a2b, p29eo, p29f1.

Followed by a engine malfunction. so i got it towed back to my house. Im getting all they codes with just having the car at idle in park.

ive disconected the battery to let it reset, and also pulled the clip out of the ecu made sure that the wires were where they were suppose to be and all looked good.

im completely lost now as to what to do. any input guys?
skatenc123 is offline  
0
Reply With Quote
      12-15-2012, 05:32 AM   #2
enrita
Major General
 
enrita's Avatar
 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

Posts: 7,323
iTrader: (0)

you have done something wrong with the removal.
__________________
07 335i AT - TD St.2 Turbos - COBB (Custom Cobb mapping by http://www.protuningfreaks.com/) - JB4G5 ISO - Okada Coils - NGK 5992 Plugs - E85 Walbro - Injen Intake - Helix IC - Snow Stg. 3 - Stett CP - AR DPs - midpipes 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - Level 10 AT upgrade - Alpina AT Flash
enrita is offline   Sweden
0
Reply With Quote
      12-15-2012, 05:51 AM   #3
skatenc123
Captain
 
skatenc123's Avatar
 
Drives: 2007 335i coupe
Join Date: Jan 2012
Location: NC

Posts: 648
iTrader: (1)

Checked it 3 times made sure I had the correct wires in the correct places and that I didn't knock anything else loose. I'll check it again tomorrow. But I don't see anything I could do differently.
skatenc123 is offline  
0
Reply With Quote
      12-15-2012, 12:07 PM   #4
Ænema
Captain
 
Drives: BMW
Join Date: Aug 2012
Location: Arizona Bay

Posts: 961
iTrader: (0)

Yeah, something is off with the removal.
__________________
"I'm not surprised you get along well with all the other neighbours. If you put fifty children with Down's syndrome in a room there is going to be a lot of hugging." David Thorne
Ænema is offline  
0
Reply With Quote
      12-15-2012, 02:50 PM   #5
skatenc123
Captain
 
skatenc123's Avatar
 
Drives: 2007 335i coupe
Join Date: Jan 2012
Location: NC

Posts: 648
iTrader: (1)

checked all connections again. everything is in where it should be. with the car set to on position and not running. im getting p30a2 (ignition coil cylinder 3, control). and when the car is started it jerks and bucks and the rpms drop and rise (400-1200)
skatenc123 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:05 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST