E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > N52 engine problem



Reply
 
Thread Tools Search this Thread
      12-14-2012, 02:05 AM   #1
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

N52 engine problem

Can it be coils?
Last night my engine cut off and after restart start dancing. Looks like misfiring, but when I stopped at car park remove key. And then start again without problem, but after few hundred metres its start again. Check with my dis and din'd show any fault.
It show stored old faults and one off them was something with vanos. I don't have time to bring to stealers my car. My missis hates my car but she drive every day to work and when she takes car somewhere in country side then she loves it. It's only five minutes from home. I thinking can in cause problem every day only short journeys. It's only appear when is cold. I got same last winter but after restart it gone till now.
lemonukas is offline  
0
Reply With Quote
      12-14-2012, 02:43 AM   #2
KUSH
Enlisted Member
 
Drives: MY 08 325i M Sport/Innovations
Join Date: Jun 2008
Location: Melbourne

Posts: 41
iTrader: (0)

It sounds like a sticky vanos solenoid same thing was happening to me. Try cleaning them both there is a DIY for this if you do a search of this site. Its quite an easy fix.
KUSH is offline   Australia
0
Reply With Quote
      12-14-2012, 02:49 AM   #3
KUSH
Enlisted Member
 
Drives: MY 08 325i M Sport/Innovations
Join Date: Jun 2008
Location: Melbourne

Posts: 41
iTrader: (0)

http://www.e90post.com/forums/showth...s+solenoid+diy
KUSH is offline   Australia
0
Reply With Quote
      12-14-2012, 03:15 AM   #4
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

Thanks guys
I will try this weekend to look at it.
lemonukas is offline  
0
Reply With Quote
      12-17-2012, 01:24 AM   #5
lemonukas
Second Lieutenant
 
Drives: 325i e91
Join Date: Jun 2012
Location: hemel hempstead

Posts: 281
iTrader: (0)

OK I tried to clean it my vanos and swap it. Than it show me both intake and exhaust jammed. Swap it back and no faults so far for 55 miles.
Next weekend I will try floor it my car and I will see how it goes.
lemonukas is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:30 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST