E90Post
 


Evolve Automotive
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Coolant Venting Issue



Reply
 
Thread Tools Search this Thread
      12-23-2012, 08:53 AM   #1
Fpaliwala
New Member
 
Drives: 2006 325i
Join Date: Jan 2012
Location: Houston, Tx

Posts: 20
iTrader: (0)

Garage List
2006 325i  [0.00]
Coolant Venting Issue

I'm a new member and not sure where to exactly ask this question. I just did a radiator drain and refill based on the DIY write up. The issue I'm having is that I cannot get the water pump to vent. I put the key in hit the ignition button(with foot off the brake) set the heater to max(84 degrees) on the lowest fan setting than push the accelerator to the floor for 10 sec, but nothing happens. All i hear is the air coming from the vent. I get under the car and listen to the water pump and hear nothing. Anybody have any ideas or suggestion on what I'm doing wrong. I have a 2006 325i if that helps.
Fpaliwala is offline  
0
Reply With Quote
      12-24-2012, 12:13 AM   #2
Fpaliwala
New Member
 
Drives: 2006 325i
Join Date: Jan 2012
Location: Houston, Tx

Posts: 20
iTrader: (0)

Garage List
2006 325i  [0.00]
Can someone please help me.
Fpaliwala is offline  
0
Reply With Quote
      12-24-2012, 12:29 AM   #3
fenixxishot
Lieutenant
 
Drives: 08 335i e92 AW MT
Join Date: Feb 2011
Location: Austin

Posts: 513
iTrader: (8)

We have been posting in ur other thread and I just responded to ur pm. You seem to be doing the procedure correctly so either one of two things is occurring your pump is not getting power(I don't know how to check for this or which fuse is specifically tied to the wp) or your pump is shot and you will have to replace it.
fenixxishot is offline  
0
Reply With Quote
      12-24-2012, 06:32 AM   #4
Efthreeoh
Brigadier General
 
Drives: E90
Join Date: May 2012
Location: MARLAND

Posts: 3,253
iTrader: (0)

The pump is very quiet when it is working. The only way to check if is working is to open the reservoir cap, look inside when the pump is in venting mode and see if you see the coolant circulating. Also, when the pump is working it should slighly pressurize the system, so you could try to feel pressure by putting the palm of you hand over the openining.

If you find the pump is working, then you will need to re-vent the system with the cap closed and vent screw closed.
Efthreeoh is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:54 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST