E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Help! Excessive Tapping Noise and codes!



Reply
 
Thread Tools Search this Thread
      01-13-2013, 10:12 PM   #1
bimmer35
Drive Responsibly, Race on the Track
 
bimmer35's Avatar
 
Drives: 435i M Sport
Join Date: Sep 2011
Location: MA

Posts: 505
iTrader: (7)

Help! Excessive Tapping Noise and codes!

Hi all,

Need some advice here.
About a month ago, with my catless dps installed, my car started smoking alot. I sent it in to BMW with the DPs on, and they said themselves it could be turbo seals. I left the car with them after reverting it back to stock, and i got a call from them that BMW NA has requested for them to change the valve cover, something to do with the oil recirculation of some sort.

Took the car back a week ago, and i notice while walking over to it, that the usual direct fuel injection tick, was louder than normal. I drove it, and the car seemed fine, except that the tick was excessively loud contrary to my friends 328, and my previous N55 335.

Regardless, i put everything back on, BOV, CP, Intake, BMS JB4 ISO, and the car ran and boosted fine. Map 5 showed that i was boosting at 14PSI Max. On Thursday i decided to bring the car in to BMW to check on the noise. They brought a tech down, and he said its normal. Its the injector noise that is famous with these engines. I told him that i understood that, but the noise was louder than normal. Either way, i took the car back and it still drove fine.

Just yesterday, i drove about 40miles on the highway, and after the highway drive, i noticed that the ticking noise got noticeably louder. So much so that my car sounded like a diesel. However it still drove fine. Unfortunately, this morning, when i started the car, it was struggling and shaking at idle, and the rpms were fluctuating. When the car warmed it, it seemed fine, but that tapping noise was still very loud.

On the way to dinner tonight, i decided that i should switch of my tune (map 0) and send the car in to bmw tomorrow morning. With the tune off and auto clear off, the car went in to limp mode, and showed the engine light.

I plugged my computer to the car, and these were the codes i got.
2C7E Lambada Probe behind catalytic converter, trimming control.
2ABC Charging Pressure Sensor, electrical
30FF Boost under target - possible boost leak
2F7B Oil Pressure Switch - plausibility
0000 Failure location not implemented.

Please help! This excessive ticking was not there till BMW changed my valve cover! And the ticking is noticed throughout the RPM range.

Thanks very much!
__________________
Current: 14' 435i M Sport: Cold Weather Pkg, Tech Pkg, Premium Pkg, Driver Assist Pkg, Lighting Pkg, Dynamic Handling Pkg, M Brakes, HK Sound.

PAST: 09' 335i (Beast), 09' Z4 30i, 09' 328xDrive, 11' Camaro 2SS, 05' M3, 11' Mustang GT 5.0, 09' ML350, 07' RS4, 08' X5 48i, 07' Cayman, 11' 335i xDrive
bimmer35 is offline  
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:35 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST