E90Post
 


E92 Lighting
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Help,my car lost DS mode.



Reply
 
Thread Tools Search this Thread
      12-29-2012, 04:31 AM   #1
diddlkiss
Second Lieutenant
China
3
Rep
247
Posts

 
Drives: 2010 335i E90 Lci N54
Join Date: May 2012
Location: Tsingtao

iTrader: (0)

Garage List
Help,my car lost DS mode.

My car can not enter the DS mode from the last week, I try to replace the fuse, check each plug, including Guadang the assembly, are intact, but I just can not enter the DS mode, I have exhausted all means.is to search the posts, and I swear I checked every thread very carefully, and they are in good condition!
Please help me, thank you very much!
Appreciate 0
      12-29-2012, 05:38 AM   #2
e90sexion
E 9 0 S E X I O N
e90sexion's Avatar
Canada
81
Rep
6,365
Posts

 
Drives: M3, Z4MC
Join Date: Sep 2006
Location: Vancouver/WA

iTrader: (16)

u have warranty
go to dealer?
Appreciate 0
      12-29-2012, 06:15 AM   #3
Autobahn335i
Lieutenant Colonel
Autobahn335i's Avatar
Luxembourg
28
Rep
1,600
Posts

 
Drives: E92 335i
Join Date: Mar 2009
Location: Luxembourg

iTrader: (5)

Probably a wire broke in the steptronic shifter assembly. That would cause this problem. Unfortunately quite an expensive fix if you are out of warranty.
__________________
Performance Seats, Exhaust, Splitters, Pedals, Steering Wheel / RB Turbos / M3 CF Roof / Brembo GT BBK 355/345 / Rollcage / Forge FMIC / Quaife LSD / Íhlins Road & Track / M3 Suspension Parts / Powerflex Bushings / Vorshlag Camberplates / Megan Racing Toe Links / LeatherZ Gauges / Extended M3 DCT Paddles / ER Sports OC / AR OC / Aux Radiator / AR DPs / Alpina TCU / COBB Pro-Tune
Appreciate 0
      12-29-2012, 08:48 AM   #4
roadkillrob
Brigadier General
United_States
58
Rep
3,907
Posts

 
Drives: 2008 335Cic, 2011 X5 35i
Join Date: Jul 2007
Location: Boston

iTrader: (14)

This has happened to a bunch of people - mine went out when the car was pretty much new - it was a microswitch in the assembly.

Dealer replaced this in my car 25167563655 but it is a $500 part - not sure if you could take it apart and fix/replace the microswitch itself, but I would try before spending the money on the whole part.
__________________

2008 E93 335i, GIAC Stage 2, HPF IC, Injen Intake, Defective AR Design DP's with useless cats
2014 X3 35i JB Stage 1
Appreciate 0
      12-29-2012, 09:05 AM   #5
diddlkiss
Second Lieutenant
China
3
Rep
247
Posts

 
Drives: 2010 335i E90 Lci N54
Join Date: May 2012
Location: Tsingtao

iTrader: (0)

Garage List
Quote:
Originally Posted by e90sexion View Post
u have warranty
go to dealer?
BMW only 2years warranty in China...
Appreciate 0
      12-29-2012, 09:09 AM   #6
diddlkiss
Second Lieutenant
China
3
Rep
247
Posts

 
Drives: 2010 335i E90 Lci N54
Join Date: May 2012
Location: Tsingtao

iTrader: (0)

Garage List
Quote:
Originally Posted by Autobahn335i View Post
Probably a wire broke in the steptronic shifter assembly. That would cause this problem. Unfortunately quite an expensive fix if you are out of warranty.
BMW only 2years warranty in China,I get my car in 07/2010.
I took it apart, you can see that there are six small iron piece, they are like antennae, but not in a plane, I do not know how to do.
Appreciate 0
      12-29-2012, 01:06 PM   #7
BuraQ
BimmerPost Supporting Vendor
BuraQ's Avatar
United_States
64
Rep
3,208
Posts


 
Drives: 11" E92 335is
Join Date: Nov 2010
Location: Florida

iTrader: (0)

Garage List
2011 BMW 335is  [3.03]
I had this happen to me on my previous E92 335i. When I was having my laser diffuser installed something got disconnected by the shifter handle. Took it back to the installer took him 5 mintues to fix the issue. So more than likely its a wire/plug etc that not connected or crossing
__________________
BQ Tuning by WedgePerformance - Torque Junkies
DCT 335is 121-122 mph in the 1/4 mile Stock Turbos / Full Weight
Appreciate 0
      12-29-2012, 01:41 PM   #8
Jeff@TopGearSolutions
BimmerPost Supporting Vendor
Jeff@TopGearSolutions's Avatar
United_States
244
Rep
18,339
Posts


 
Drives: C6 Z06, GSXR-750, 09 335i
Join Date: Dec 2008
Location: TopGearSolutions.com

iTrader: (32)

Send a message via AIM to Jeff@TopGearSolutions
Quote:
Originally Posted by Autobahn335i View Post
Probably a wire broke in the steptronic shifter assembly. That would cause this problem. Unfortunately quite an expensive fix if you are out of warranty.
This is very common.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:25 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST