E90Post
 


Extreme Power House
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > oil level



Reply
 
Thread Tools Search this Thread
      12-29-2012, 10:18 PM   #1
white08135i
Lieutenant
 
white08135i's Avatar
 
Drives: 08e90335i
Join Date: Sep 2012
Location: Norcal

Posts: 494
iTrader: (10)

oil level

07 335i doesnt show date and miles left for oil change?
white08135i is online now   United_States
0
Reply With Quote
      12-29-2012, 10:29 PM   #2
sammk
Private First Class
 
Drives: 2008 328i Coupe
Join Date: Oct 2011
Location: Michigan

Posts: 173
iTrader: (1)

It should, at engine start-up for 3 secs or so. If not, turn the ignition on, hold down the odo reset until you get into the service menu, you can navigate using the BC arrow buttons on the stalk, and view oil change info..
__________________
sammk is offline  
0
Reply With Quote
      12-29-2012, 10:33 PM   #3
white08135i
Lieutenant
 
white08135i's Avatar
 
Drives: 08e90335i
Join Date: Sep 2012
Location: Norcal

Posts: 494
iTrader: (10)

i navigate there and it says km ----- and where date is shows ----- as well

?
white08135i is online now   United_States
0
Reply With Quote
      12-29-2012, 10:39 PM   #4
sammk
Private First Class
 
Drives: 2008 328i Coupe
Join Date: Oct 2011
Location: Michigan

Posts: 173
iTrader: (1)

Sorry bud, this is now out of my simple range of comprehension. I didn't know that the car could somehow forget the oil change mileage. Maybe the others could chime in on how such a thing could happen, or if the info's stored elsewhere..

If you're not sure about the oil change history, you could do one just to be sure and reset the mileage. That way, you begin with a clean sheet.
__________________
sammk is offline  
0
Reply With Quote
      12-29-2012, 10:43 PM   #5
white08135i
Lieutenant
 
white08135i's Avatar
 
Drives: 08e90335i
Join Date: Sep 2012
Location: Norcal

Posts: 494
iTrader: (10)

I just changed it and tried to reset it confirms when you reset it but still shows ---- when done.
white08135i is online now   United_States
0
Reply With Quote
      12-29-2012, 10:50 PM   #6
sammk
Private First Class
 
Drives: 2008 328i Coupe
Join Date: Oct 2011
Location: Michigan

Posts: 173
iTrader: (1)

Has it always done it or did it just start.. Like, when you turn on the engine, did it always show ----?
__________________
sammk is offline  
0
Reply With Quote
      12-29-2012, 10:54 PM   #7
white08135i
Lieutenant
 
white08135i's Avatar
 
Drives: 08e90335i
Join Date: Sep 2012
Location: Norcal

Posts: 494
iTrader: (10)

oil level checks out fine, but the the service light leaves miles and date blank? i attached a pics

white08135i is online now   United_States
0
Reply With Quote
      12-29-2012, 10:55 PM   #8
white08135i
Lieutenant
 
white08135i's Avatar
 
Drives: 08e90335i
Join Date: Sep 2012
Location: Norcal

Posts: 494
iTrader: (10)

i just recently bought the car and noticed that today
white08135i is online now   United_States
0
Reply With Quote
      12-29-2012, 11:03 PM   #9
sammk
Private First Class
 
Drives: 2008 328i Coupe
Join Date: Oct 2011
Location: Michigan

Posts: 173
iTrader: (1)

I've never heard of that, so I'm sorry, not sure what to do. Are there other related issues you've noticed? Are the brake indicators and general service indicators showing good numbers? An overnight battery reset may help, maybe the computer needs some nudging..
__________________
sammk is offline  
0
Reply With Quote
      12-29-2012, 11:06 PM   #10
sammk
Private First Class
 
Drives: 2008 328i Coupe
Join Date: Oct 2011
Location: Michigan

Posts: 173
iTrader: (1)

I just did an oil change last week btw, I didn't have any issues resetting the indicator. Have you taken the car for a spin after resetting? That might help (although mine immediately flashed 15000 mi after resetting, then changed to 9000 mi because my 60k mi Inspection is due in that many miles).
__________________
sammk is offline  
0
Reply With Quote
      12-29-2012, 11:18 PM   #11
white08135i
Lieutenant
 
white08135i's Avatar
 
Drives: 08e90335i
Join Date: Sep 2012
Location: Norcal

Posts: 494
iTrader: (10)

in fact all the service lights are blank. yes i took it for a spin. weird.
white08135i is online now   United_States
0
Reply With Quote
      12-30-2012, 01:41 PM   #12
Monster900
Zeed
 
Monster900's Avatar
 
Drives: BMW 335i Coupe
Join Date: Nov 2009
Location: Detroit, MI

Posts: 391
iTrader: (0)

Check if you have correct date set.
Monster900 is offline   Canada
0
Reply With Quote
      12-30-2012, 02:22 PM   #13
white08135i
Lieutenant
 
white08135i's Avatar
 
Drives: 08e90335i
Join Date: Sep 2012
Location: Norcal

Posts: 494
iTrader: (10)

Yes the date is set
white08135i is online now   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:17 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST