E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Help!! Turbo whining/howl and power loss!!



Reply
 
Thread Tools Search this Thread
      12-30-2012, 01:46 PM   #1
KASPA
Second Lieutenant
 
Drives: BMW 320D MSPORT
Join Date: Jul 2011
Location: Birmingham

Posts: 218
iTrader: (0)

Help!! Turbo whining/howl and power loss!!

Hi guys. In need of some help before the car goes into the garage. I have a 57 reg 520d lci that has just developed a problem. Cars been fine until now. Has done 80,000 miles and looked after pretty well. Came off the motorway earlier and heard a really loud whining noise followed by a loss in power. The whine sounds really high pitch and not whistle like, more like a cat stuck under the bonnet. It makes the noise when revved standing still and when driven too, the noise gets louder higher up the rev range. No smoking at all and no oil burning either.

Any idea what it is?? I can only think of boost pipes or turbo.
KASPA is offline   England
0
Reply With Quote
      12-30-2012, 02:03 PM   #2
briers
Ben
 
briers's Avatar
 
Drives: XFR
Join Date: May 2010
Location: Midlands,UK

Posts: 1,944
iTrader: (0)

It sounds like turbo failure to me

I would get it recovered to your garage to prevent further damage

If a pipe was loose you would get no boost or air flow through the turbo and no noise.
briers is offline   United Kingdom
0
Reply With Quote
      12-30-2012, 02:27 PM   #3
Red_Bean_Bun
Captain
 
Drives: E92
Join Date: Nov 2009
Location: Wilmington, DE

Posts: 699
iTrader: (2)

If there is a turbo being its a 520d......possible differential issues ?
Red_Bean_Bun is offline  
0
Reply With Quote
      12-30-2012, 02:32 PM   #4
briers
Ben
 
briers's Avatar
 
Drives: XFR
Join Date: May 2010
Location: Midlands,UK

Posts: 1,944
iTrader: (0)

If it didn't have a turbo it would struggle to haul its heavy ass over the simplest of inclines
briers is offline   United Kingdom
0
Reply With Quote
      12-30-2012, 03:16 PM   #5
KASPA
Second Lieutenant
 
Drives: BMW 320D MSPORT
Join Date: Jul 2011
Location: Birmingham

Posts: 218
iTrader: (0)

It could very well be the turbo.

Just the fact that there is no oil burning or smoking that makes me think it may be a split pipe or something.
KASPA is offline   England
0
Reply With Quote
      12-30-2012, 07:17 PM   #6
briers
Ben
 
briers's Avatar
 
Drives: XFR
Join Date: May 2010
Location: Midlands,UK

Posts: 1,944
iTrader: (0)

Does it sound similar to this?


If so the impeller assembly is moving inside the casing, sooner or later the blades will touch the metal casing and possibly shatter, maybe even breaking the seals in which case they could make it into the engine causing further damage and you would see smoke and oil makes it where it shouldn't be.

You may find a little black smoke if you have continued to drive it.

Alternatively if it is a split hose you may hear a high pitched whistling possibly
briers is offline   United Kingdom
0
Reply With Quote
      01-03-2013, 09:26 PM   #7
mtr123
Private First Class
 
Drives: e90 320d le-mans blue
Join Date: Nov 2012
Location: cheshire

Posts: 105
iTrader: (1)

this has happened to mine at the end of a couple of hundred mile journey tonight

sounds like a new turbo is needed so going to get it to a garage int he morning as the aa towed me back to my house.

hoping its not buggered anything else
mtr123 is offline  
0
Reply With Quote
      01-04-2013, 02:01 PM   #8
KASPA
Second Lieutenant
 
Drives: BMW 320D MSPORT
Join Date: Jul 2011
Location: Birmingham

Posts: 218
iTrader: (0)

Had it checked out and yes it was bad news, needs a new turbo!!
Bit of a shock seeing as it showed no symptoms at all.
KASPA is offline   England
0
Reply With Quote
      09-11-2013, 04:34 PM   #9
Steinegal
New Member
 
Drives: 320D E91 M-Sport
Join Date: Nov 2010
Location: Stavanger, Norway

Posts: 12
iTrader: (0)

First sorry for reviving an old thread.
Did a new turbo fix your problem?
This happened to me today. I tried accelerating while going up hill en the power just dissapeared, turned down the radio and yeah it does sound like a cat in pain. Towed my car back home and started ripping it appart, there is alot of play in the impeller, but it is not damaged so the engine should be fine. My car has rolled 159 000km (about 100k miles) and I haven't noticed any thing until yesterday when I had a sudden abrupt powerloss when accelerating hard, but it was fine again so I blamed the DTC for it. My car has been slightly hesitant around 1500-2000RPMs, but nothing out of the ordinary for a turbo diesel. Will replace it my self with a core exchange as BMW want 2000 for a new turbo and at least 2000 for the work. Will clean an check my inlet manifold and all hose while I'm waiting for my overhauld turbo. BTW my car is a December 2005 build E91 320D
__________________
320D E91 M-sport 2005 Navi Proff
Steinegal is offline   Norway
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:28 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST