BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > power steering line disconnected by itself?

Thread Tools Search this Thread
      09-30-2015, 05:49 PM   #1
Second Lieutenant

Drives: 2010 328XI
Join Date: Jul 2012
Location: Michigan

iTrader: (0)

power steering line disconnected by itself?

I have a 2010 328i awd with 46k miles and had a strange thing happen today. The push on connector where the power steering line that goes from the reservoir to the upper port on the power steering cooler just disconnected and spewed all my power steering fluid everywhere. I have never had it removed before or anything in the area touched. I thought it broke but when I pushed it back on it locked and won't come off. Cleaned everything, refilled and everything is good again. Is this just a fluke? Maybe not pushed on all the way from the factory? Anyone else ever have this happen?
Appreciate 0


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 01:56 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST