E90Post
 


ECS BMW
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Bizarre problem



Reply
 
Thread Tools Search this Thread
      01-19-2013, 09:50 PM   #1
ihc95
Major
ihc95's Avatar
12
Rep
1,167
Posts

 
Drives: TiAg E92 335i
Join Date: Jul 2011
Location: NJ

iTrader: (1)

Garage List
**UPDATED**Bizarre problem

About two weeks ago my car started making the dreaded "turbo siren" noise under acceleration. At first I thought it was just an ordinary turbo failure since my car now has over 77k miles on it. However the car makes hardly any boost at all and usually turbo failure is more gradual and not so sudden and noticeable. So I uninstalled my Cobb and I open my air box to remove my BMS drop in and I see a chunk of the air filter is broken off. The chunk is from the right side of the box right above the rear turbo inlet. I believe the chunk of rubber got sucked into the intake and caused damage to one of the turbos. I don't really know what to do and the car isn't under warranty. Any advice is greatly appreciated. Thank you.

Name:  filter005_zps91ff790a.jpg
Views: 412
Size:  114.6 KB




UPDATE: My car had BOTH turbos replaced under the 8 year/ 82,000 mile warranty for the turbos. I'm so happy!! Feels like a brand new car! Even better than before! Apparently there was enough play in the wastegates (6mm stated in the RO) to justify replacement under the warranty.

Last edited by ihc95; 02-06-2013 at 10:00 PM.
Appreciate 0
      01-19-2013, 10:07 PM   #2
idrift4wd
Brigadier General
45
Rep
3,378
Posts

 
Drives: Three Hundred and Thirty Five
Join Date: Jul 2010
Location: Yonkers NY

iTrader: (0)

Garage List
2007 BMW  [3.50]
Quote:
Originally Posted by ihc95 View Post
About two weeks ago my car started making the dreaded "turbo siren" noise under acceleration. At first I thought it was just an ordinary turbo failure since my car now has over 77k miles on it. However the car makes hardly any boost at all and usually turbo failure is more gradual and not so sudden and noticeable. So I uninstalled my Cobb and I open my air box to remove my BMS drop in and I see a chunk of the air filter is broken off. The chunk is from the right side of the box right above the rear turbo inlet. I believe the chunk of rubber got sucked into the intake and caused damage to one of the turbos. I don't really know what to do and the car isn't under warranty. Any advice is greatly appreciated. Thank you.

Also I'll try to get a pic of the broken air filter. I'm on my phone now so I can't at the moment.
you can always replace one turbo if you dont have the funds. a used turbo can be had for 2-3 hundred.

labor if you cant do it yourself shouldnt be more then 300-500.
Appreciate 0
      01-19-2013, 10:33 PM   #3
rdeterman
First Lieutenant
rdeterman's Avatar
7
Rep
391
Posts

 
Drives: 2008 335i Coupe 6mt
Join Date: Apr 2012
Location: Iowa

iTrader: (1)

order a set of RB's
__________________
JB4 G5 ISO W/BMS FLASH, FBO, Walbro LPFP, Spec S2+ SMFW
Appreciate 0
      01-20-2013, 08:48 AM   #4
ihc95
Major
ihc95's Avatar
12
Rep
1,167
Posts

 
Drives: TiAg E92 335i
Join Date: Jul 2011
Location: NJ

iTrader: (1)

Garage List
Do you guys think I should contact BMS regarding a defective part?

Last edited by ihc95; 01-20-2013 at 10:01 AM.
Appreciate 0
      01-20-2013, 12:03 PM   #5
psmitty95
Brigadier General
psmitty95's Avatar
United_States
104
Rep
3,770
Posts

 
Drives: 2009 E90 335i xDrive
Join Date: Jan 2012
Location: Greenwich, CT/ Dallas, TX

iTrader: (8)

I just started getting the siren a few weeks ago... I'm hoping its normal but i'm a bit worried. When the cars warmed up i can barely notice it but when its cold it's pretty loud.
__________________
< Click picture for photoshoot
E90 335i xDrive 6spd, Nav, Prem, Cold Weather, & Sports package - Msport Conversion
Mods: Cobb V3 w/ Motiv Tune, VRSF DP/FMIC, ER CP, Roc-Euro DCI, SteveAZ LPFP & more
More Pictures: Build Thread /// Shop I use: Aci Dynamix 408AWHP/ 483AWTQ Uncorrected Mustang Dyno
Appreciate 0
      01-20-2013, 12:22 PM   #6
Kienvu14
Private First Class
2
Rep
141
Posts

 
Drives: 07' E90 N54 Aspen White
Join Date: Dec 2012
Location: Denver

iTrader: (1)

When I bought my 07 335xi used,it still has a 8 year 80k mile extended warranty for defective turbos for a recall. What year is yours?
__________________
E90 - N54 2007 Alpine White FBO :
VRSF CP w/ Tial BOV,VRSF 7 inch FMIC, VRSF Catless DP's, VTT Stg2 w/ billet 6x6, Cobb V3, VMR V710 Gunmetal 19x8.5 and 19x9.5, Slotted rotors EBC, Hawks HPS pads, SteveAZ walboro 450 drop in
Appreciate 0
      01-20-2013, 12:22 PM   #7
CT335xi
First Lieutenant
CT335xi's Avatar
3
Rep
339
Posts

 
Drives: e90 335xi, evo 8, gmc syclone
Join Date: Dec 2011
Location: Naugatuck,Ct

iTrader: (0)

Quote:
Originally Posted by ihc95 View Post
About two weeks ago my car started making the dreaded "turbo siren" noise under acceleration. At first I thought it was just an ordinary turbo failure since my car now has over 77k miles on it. However the car makes hardly any boost at all and usually turbo failure is more gradual and not so sudden and noticeable. So I uninstalled my Cobb and I open my air box to remove my BMS drop in and I see a chunk of the air filter is broken off. The chunk is from the right side of the box right above the rear turbo inlet. I believe the chunk of rubber got sucked into the intake and caused damage to one of the turbos. I don't really know what to do and the car isn't under warranty. Any advice is greatly appreciated. Thank you.

Attachment 809494
That sucks man , chances are that turbo did ingest that broken piece. Maybe call where you got the filter and out of good will they will help you out . GL
__________________
volk re30 18x8.5 / tc kline coilovers / cobb ap / afe stg 2 sealed cai / afe air scoops / 5" ets fmic
Appreciate 0
      01-20-2013, 12:27 PM   #8
E3r2E9r
Banned
5
Rep
421
Posts

 
Drives: 3 Series
Join Date: Sep 2011
Location: NE

iTrader: (0)

Doubt anyone will help. There is a bunch of fine print. Aftermarket parts come with a risk. Return it back to stock and play dumb at dealer. Everyone hopes and assumes the dealer should cover parts on this forum when its their fault so you mine as well give it a shot too.
Appreciate 0
      01-20-2013, 01:48 PM   #9
BMWM.D.
Stupid Idiot
BMWM.D.'s Avatar
8
Rep
687
Posts

 
Drives: E90 335i & C6 Grand Sport
Join Date: May 2009
Location: Santa Barbara

iTrader: (1)

Quote:
Originally Posted by Kienvu14 View Post
When I bought my 07 335xi used,it still has a 8 year 80k mile extended warranty for defective turbos for a recall. What year is yours?
The turbos do have an extended warranty, but it's only for wategate-related failures. Sucking debris into the impeller wheel definitely isn't covered.

Quote:
Originally Posted by ihc95 View Post
Do you guys think I should contact BMS regarding a defective part?
It looks like it was an install error. That strip probably got pinched during install and eventually came off. I doubt it came torn or damaged from BMS.
__________________
Appreciate 0
      01-20-2013, 02:13 PM   #10
ihc95
Major
ihc95's Avatar
12
Rep
1,167
Posts

 
Drives: TiAg E92 335i
Join Date: Jul 2011
Location: NJ

iTrader: (1)

Garage List
It didn't come torn or damaged at all. The weird thing is the car was running perfectly for 6 months so how can it be install error? The filter fit fine and all of a sudden I see a chunk broken off. I'm gonna play dumb at the dealer and maybe see if they can write it up as a wastegate failure since they'd get reimbursed from BMWNA anyway.
Appreciate 0
      01-20-2013, 02:21 PM   #11
Red_Bean_Bun
Captain
7
Rep
711
Posts

 
Drives: E92
Join Date: Nov 2009
Location: Wilmington, DE

iTrader: (2)

Seen it damaged due to the heat but not like what you have in the pic ....
Appreciate 0
      01-20-2013, 08:13 PM   #12
volkswackin
Lieutenant Colonel
United_States
19
Rep
1,918
Posts

 
Drives: too broke for a BMW
Join Date: Jan 2008
Location: i get around..

iTrader: (1)

Just because it was fine for a while doesn't mean it wasn't installed incorrectly and finally broke off then got sucked in
Appreciate 0
      01-20-2013, 08:33 PM   #13
cn555ic
BimmerPost Supporting Vendor
cn555ic's Avatar
United_States
246
Rep
18,287
Posts


 
Drives: Bimmerscoding.com
Join Date: Jun 2007
Location: New York

iTrader: (5)

Send a message via Yahoo to cn555ic
That's for sure going to damage the turbo if Injested.
__________________
917-939-4980 CODING E and F Series New York Area

Appreciate 0
      01-20-2013, 09:55 PM   #14
boostaholic786
Lieutenant
boostaholic786's Avatar
6
Rep
565
Posts

 
Drives: E92 JB4 G5 ISO RB's FBO+40%E85
Join Date: Dec 2011
Location: irving tx

iTrader: (0)

I would put the factory filter back in and go to the dealer and then play dumb. If your dealer is pretty cool you should have a chance and getting them replaced. make sure you take it there STOCK
__________________
A/W E92 335i M-sport with JB4 G5 ISO/ E40 WEDGE PERFORMANCE BACKEND FLASH, Alpina TCU flash for AT/Switch-tronic +AR Downpipes, Stett gen 1 intake, Wagner-Tuning FMIC+RB Turbo setup/ RB PCV Valve+ Akro exhaust+60% E85/93 mix,+ HRE P40S wheels, KW coilovers, M3 sways,+BMW performance CF Mirrors, BMW Performance CF deck lid spoiler,+ CF interior trim, p3 vent boost gauge,+ LUX angel eyes (11.73@119mph on street tires) NO METH!
Appreciate 0
      01-20-2013, 10:38 PM   #15
ihc95
Major
ihc95's Avatar
12
Rep
1,167
Posts

 
Drives: TiAg E92 335i
Join Date: Jul 2011
Location: NJ

iTrader: (1)

Garage List
Quote:
Originally Posted by boostaholic786
I would put the factory filter back in and go to the dealer and then play dumb. If your dealer is pretty cool you should have a chance and getting them replaced. make sure you take it there STOCK
Yup. Exactly what I am doing.
Appreciate 0
      01-20-2013, 10:44 PM   #16
bulldog x6
Major General
65
Rep
5,022
Posts

 
Drives: x6 panzer
Join Date: Oct 2008
Location: probably work

iTrader: (28)

wow im checking my drop in filter tomorrow! good luck bro
Appreciate 0
      01-21-2013, 03:43 PM   #17
ihc95
Major
ihc95's Avatar
12
Rep
1,167
Posts

 
Drives: TiAg E92 335i
Join Date: Jul 2011
Location: NJ

iTrader: (1)

Garage List
Quote:
Originally Posted by bulldog x6
wow im checking my drop in filter tomorrow! good luck bro
Thanks. Everyone should definitely check their drop in filter. Mine fit well but it was a tighter squeeze than the OEM filter in the air box. Even so I'm still amazed a piece managed to break off while driving.
Appreciate 0
      02-06-2013, 10:01 PM   #18
ihc95
Major
ihc95's Avatar
12
Rep
1,167
Posts

 
Drives: TiAg E92 335i
Join Date: Jul 2011
Location: NJ

iTrader: (1)

Garage List
Update in OP!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:41 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST