E90Post
 


Horizon LED
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > Regional Forums > UK > UK Technical Forum > Ipod 'Y' cable



Reply
 
Thread Tools Search this Thread
      12-02-2014, 04:05 PM   #1
badgerbrock72
Private First Class
badgerbrock72's Avatar
2
Rep
136
Posts

 
Drives: 330D M Sport
Join Date: Aug 2012
Location: Birmingham

iTrader: (0)

Ipod 'Y' cable

Hi all

Its been suggested by a car audio shop that the official BMW Y cable provides a cleaner signal to the i-Drive and hence a better sound, then the regular white apple USB jobbie.

Reason I ask is that virtually every day my iPod magically disconnects from the iDrive for no apparent reason, and the only way to reconnect is to reboot either the iDrive or the iPod. Using the apple cable.

So, does anyone know if there is any truth in my first paragraph above? and also if the Y cable carries album art on a 2011 with the USB in the front armrest?

finally do you reckon it might fix the iPod disconnecting issue?

cheers in anticipation of any help!

Garry
Appreciate 0
      12-02-2014, 05:29 PM   #2
afalton
First Lieutenant
United Kingdom
3
Rep
363
Posts

 
Drives: bmw e92 330i m sport
Join Date: Oct 2012
Location: london

iTrader: (2)

I had similar experience with my 08 e92 idrive. On my research and chat with a mate that worked st bmw he said that the genuine bmw y lead will process all ipod playlists and show them on the nav screen. Since I had the gen cable it's been great touch wood
Appreciate 0
      12-02-2014, 11:15 PM   #3
Monger007
Enlisted Member
0
Rep
32
Posts

 
Drives: BMW 320D M Sport
Join Date: Oct 2014
Location: Thailand

iTrader: (0)

Please post your findings after you gather the info.

I have a Dec 2010 3 series with I Drive and sat navigation. In the centre arm rest I have 2 sockets, 1 round pin and 1 USB.

I recently connected my I Pod using the white USB cable that came with the I Pod. The artist and albums all appear on the screen and it appears its working ok.

I have observed on another forum someone stated that the Apple cable is no good and a BMW Y cable must be used, that will connect to both sockets.

I do not have any disconnecting issue, but I have no album art work on the screen, and its takes some time before the system will boot if it has just been switched on


Quote:
Originally Posted by badgerbrock72 View Post
Hi all

Its been suggested by a car audio shop that the official BMW Y cable provides a cleaner signal to the i-Drive and hence a better sound, then the regular white apple USB jobbie.

Reason I ask is that virtually every day my iPod magically disconnects from the iDrive for no apparent reason, and the only way to reconnect is to reboot either the iDrive or the iPod. Using the apple cable.

So, does anyone know if there is any truth in my first paragraph above? and also if the Y cable carries album art on a 2011 with the USB in the front armrest?

finally do you reckon it might fix the iPod disconnecting issue?

cheers in anticipation of any help!

Garry
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:54 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST