E90Post
 


Bimmer Retrofit
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > Suspension problem, any ideas what i should tackle first



Reply
 
Thread Tools Search this Thread
      05-01-2017, 03:04 PM   #1
Masry335i
Private
Masry335i's Avatar
Canada
7
Rep
75
Posts

Drives: E92 335i 6mt
Join Date: Jan 2016
Location: Toronto

iTrader: (0)

Suspension problem, any ideas what i should tackle first

BIMMERPOST
     Featured on BIMMERPOST.com
Hey guys im back again with another question about the most reliable car on this planet the bmw 335 08' model. Long story short, my right rear wheel wobbles a tiny bit while driving, and at high speeds going over an expansion joint makes the car sway quite a bit turning on the traction control light, and now when i pull out my driveway the car makes a light clunk noise. The wheel is also further back then it should be toward the trunk, and the car looks lowered on that side. Can it be more than one problem? Heres some pics and give me some ideas as this is gonna be a DIY repair like all my other problems with this car.








The last picture is the left side how it should look, all centered and behaved.
Appreciate 0
      05-01-2017, 03:35 PM   #2
WhiteBeard
Lieutenant
United_States
71
Rep
432
Posts

Drives: slowly
Join Date: Feb 2016
Location: Jacksonville

iTrader: (0)

You have bent/broken suspension parts on that rear passenger wheel. usually things like this happen if you hit the curb for example and bent/broke control arms, but anything could be bent - we don't and can't diagnose it remotely from looking at wheels only. Would be more informative if you can park the car at your garage/driveway and take that wheel off and take a good pictures of suspension - then we can tell better and you most probably will be able to tell too which component is bent/broken. My bet is that it's either a broken strut or bent control arm (lower and/or upper)
Appreciate 1
      05-01-2017, 04:03 PM   #3
Volasko
Lieutenant Colonel
Volasko's Avatar
Canada
168
Rep
1,825
Posts

Drives: 2006 E90 330i BSM 6MT ZSP
Join Date: Dec 2010
Location: Toronto

iTrader: (2)

Garage List
^^ What he said, take that wheel off right away and take a peek around. That isn't right....
Appreciate 1
      05-01-2017, 04:46 PM   #4
Masry335i
Private
Masry335i's Avatar
Canada
7
Rep
75
Posts

Drives: E92 335i 6mt
Join Date: Jan 2016
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by WhiteBeard View Post
You have bent/broken suspension parts on that rear passenger wheel. usually things like this happen if you hit the curb for example and bent/broke control arms, but anything could be bent - we don't and can't diagnose it remotely from looking at wheels only. Would be more informative if you can park the car at your garage/driveway and take that wheel off and take a good pictures of suspension - then we can tell better and you most probably will be able to tell too which component is bent/broken. My bet is that it's either a broken strut or bent control arm (lower and/or upper)
If you look at my post history youll see that last year around this time i did hit a curb, but completely replaced all the suspension parts. Literally everything was changed, and i havent hit a curb since...
Appreciate 0
      05-01-2017, 04:51 PM   #5
Volasko
Lieutenant Colonel
Volasko's Avatar
Canada
168
Rep
1,825
Posts

Drives: 2006 E90 330i BSM 6MT ZSP
Join Date: Dec 2010
Location: Toronto

iTrader: (2)

Garage List
Quote:
Originally Posted by Masry335i View Post
If you look at my post history youll see that last year around this time i did hit a curb, but completely replaced all the suspension parts. Literally everything was changed, and i havent hit a curb since...
I would inspect all the areas the rear control arms connect to the rear subframe. Something is either bent or damaged to have rear wheel sit so far back like that.
Appreciate 0
      05-01-2017, 05:39 PM   #6
SlimE92
Captain
SlimE92's Avatar
49
Rep
662
Posts

Drives: E92 N54
Join Date: Apr 2014
Location: Queens NY

iTrader: (0)

Probably a crack on the rear subframe or a bad axle
Appreciate 0
      05-02-2017, 12:29 PM   #7
Masry335i
Private
Masry335i's Avatar
Canada
7
Rep
75
Posts

Drives: E92 335i 6mt
Join Date: Jan 2016
Location: Toronto

iTrader: (0)

so update guys, finally had time off work today thanks to the rain took off the wheel, and found what i think is the sway bar link? any idea what part this is.





if you look at the second picture youll see that one piece sticking out behind the rotor saying hello. Other than the mud on the multilink and rusted rotors from the job sites i have to visit, does everything else look okay? And what part is that
Appreciate 0
      05-02-2017, 01:10 PM   #8
Masry335i
Private
Masry335i's Avatar
Canada
7
Rep
75
Posts

Drives: E92 335i 6mt
Join Date: Jan 2016
Location: Toronto

iTrader: (0)

jesus so it looks like the whole sway bar end link snapped off completely upon comparison of both sides. Would this cause any other problems if it was off for long enough?
Appreciate 0
      05-02-2017, 01:26 PM   #9
Donutz
Second Lieutenant
41
Rep
270
Posts

Drives: 335i
Join Date: Sep 2015
Location: Toronto, eh

iTrader: (2)

Keep looking. I don't believe the swaybar is the root cause of your problem.
Appreciate 0
      05-02-2017, 01:38 PM   #10
ucdbiendog
Lieutenant
36
Rep
565
Posts

Drives: 2008 335xi E90
Join Date: Mar 2008
Location: Reno, NV

iTrader: (0)

Quote:
Originally Posted by Donutz View Post
Keep looking. I don't believe the swaybar is the root cause of your problem.
exactly. sway bar just transfers load from one side of the suspension to the other. if you're on flat ground you could remove the sway bar and you would not see this. i would bet that this snapped end link was caused by whatever is causing this side to sit funny. it is possible that you cracked/damaged the subframe on your curb hit, but didnt realize it, and a year later the failure propagated catastrophically. good luck
Appreciate 0
      05-02-2017, 01:48 PM   #11
Donutz
Second Lieutenant
41
Rep
270
Posts

Drives: 335i
Join Date: Sep 2015
Location: Toronto, eh

iTrader: (2)

Quote:
Originally Posted by Masry335i View Post


Sorry, can't seem to get the image uploaded on my phone, but the issue looks to me to be in the top right corner of this picture. I believe it's the rear upper guide arm, and it looks like it's no longer attached, and further, the mounting bracket looks to have failed. This too could be collateral damage from another issue, and may not necessarily be the root cause.
Appreciate 0
      05-02-2017, 03:14 PM   #12
Masry335i
Private
Masry335i's Avatar
Canada
7
Rep
75
Posts

Drives: E92 335i 6mt
Join Date: Jan 2016
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by Donutz View Post
Sorry, can't seem to get the image uploaded on my phone, but the issue looks to me to be in the top right corner of this picture. I believe it's the rear upper guide arm, and it looks like it's no longer attached, and further, the mounting bracket looks to have failed. This too could be collateral damage from another issue, and may not necessarily be the root cause.
Jesus christ you're right!!!! I cant believe i didn't see the upper guide arm completely un-attatched! Looks like the bolts is completely missing! I had the subframe checked out by two mechanics last year after the multi link swap and they said it was fine. So it looks like its the control arm there is missing the nut, or does that control arm look damaged? Should i just buy the nut or the entire arm
Appreciate 0
      05-02-2017, 04:25 PM   #13
Wolf 335
Lieutenant Colonel
Wolf 335's Avatar
Canada
285
Rep
1,512
Posts

Drives: 2007 E92 335i
Join Date: Aug 2012
Location: GTA - Greater Toronto Area

iTrader: (0)

How long have you been driving like this?
Appreciate 0
      05-02-2017, 04:34 PM   #14
justpete
Brigadier General
United_States
688
Rep
3,559
Posts

Drives: '11 328i '16 550i
Join Date: Jan 2012
Location: DFW

iTrader: (0)

Garage List
2011 BMW 328i  [4.33]
2016 BMW 550i  [4.12]
Quote:
Originally Posted by Masry335i View Post
so update guys, finally had time off work today thanks to the rain took off the wheel, and found what i think is the sway bar link? any idea what part this is.



if you look at the second picture youll see that one piece sticking out behind the rotor saying hello. Other than the mud on the multilink and rusted rotors from the job sites i have to visit, does everything else look okay? And what part is that
That's the wishbone and the bolt holding it to the subframe has backed out and is missing. Should be as simple as installing another one which you can do with the wheel off as it is. Doesn't look like anything else is damaged.
__________________
2011 E90 328i ZSP 6MT, 2960#, BMW Aero, CF hood/boot, PI+CAI+RM+3IM+BPC, SS+CI528+ThermoTec+SS#1+Burns, AKG eng, UUC trans, Delrin diff/RS, CM 850, UCP, CAE, AKG DSSR, DiffsOnline 3.91 30/90 LSD+BW cooler, C&R, Setrab, Accusump, AST 3-way+Swift, all Aurora PR+BW spherical, Vorshlag CPs, M3 brace+UR bar, ARC-8 18x8.5, 255 R1R, RB/CSL rotors, 135i calipers, RS29, RT700, Safecraft, OMP HTE-R+804F+QD Superquadro, 8pt cage+FIA, Braille, RT DL1Mk3
Appreciate 0
      05-02-2017, 05:00 PM   #15
Masry335i
Private
Masry335i's Avatar
Canada
7
Rep
75
Posts

Drives: E92 335i 6mt
Join Date: Jan 2016
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by Wolf 335 View Post
How long have you been driving like this?
Well after the car started swaying heavily maybe a day or two then parked it after I noticed the wheel going back. And these bolts i need are so rare, bmw wants me to buy a pack of 10 and indi part shops wont get it for a week because itd be too much to express ship. Any ideas?
Appreciate 0
      05-02-2017, 05:06 PM   #16
justpete
Brigadier General
United_States
688
Rep
3,559
Posts

Drives: '11 328i '16 550i
Join Date: Jan 2012
Location: DFW

iTrader: (0)

Garage List
2011 BMW 328i  [4.33]
2016 BMW 550i  [4.12]
Quote:
Originally Posted by Masry335i View Post
Well after the car started swaying heavily maybe a day or two then parked it after I noticed the wheel going back. And these bolts i need are so rare, bmw wants me to buy a pack of 10 and indi part shops wont get it for a week because itd be too much to express ship. Any ideas?
Check getbmwparts.com
__________________
2011 E90 328i ZSP 6MT, 2960#, BMW Aero, CF hood/boot, PI+CAI+RM+3IM+BPC, SS+CI528+ThermoTec+SS#1+Burns, AKG eng, UUC trans, Delrin diff/RS, CM 850, UCP, CAE, AKG DSSR, DiffsOnline 3.91 30/90 LSD+BW cooler, C&R, Setrab, Accusump, AST 3-way+Swift, all Aurora PR+BW spherical, Vorshlag CPs, M3 brace+UR bar, ARC-8 18x8.5, 255 R1R, RB/CSL rotors, 135i calipers, RS29, RT700, Safecraft, OMP HTE-R+804F+QD Superquadro, 8pt cage+FIA, Braille, RT DL1Mk3
Appreciate 0
      05-02-2017, 05:40 PM   #17
Masry335i
Private
Masry335i's Avatar
Canada
7
Rep
75
Posts

Drives: E92 335i 6mt
Join Date: Jan 2016
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by justpete View Post
Check getbmwparts.com
So due to my dilemma of needing to fix this so quickly, I need express shipping and every parts place and website i checked would cost about 30$ for two f****** bolts. So for the first time ladies and gentlemen the bmw dealership actually came victorious with the best price and itll be here tomorrow. 26 dollars inculding tax for 2 bolts guys, except one of the bolts only come in packs of 10. SO 26 dollars for 11 bolts. If anyone needs bolts for the sway bar linkage holler at me
Appreciate 0
      05-03-2017, 08:13 AM   #18
Wolf 335
Lieutenant Colonel
Wolf 335's Avatar
Canada
285
Rep
1,512
Posts

Drives: 2007 E92 335i
Join Date: Aug 2012
Location: GTA - Greater Toronto Area

iTrader: (0)

So what was the root cause of this?

After your curb impact the shop didn't install the nut on the bolt?
Appreciate 0
      05-03-2017, 08:33 AM   #19
gunnerxq
Major
gunnerxq's Avatar
United_States
74
Rep
1,471
Posts

Drives: e90 "325i"
Join Date: Sep 2010
Location: Staten Island and Albany

iTrader: (0)

Google the torque specs. Some if these suspension parts are over 120 lbs then add another 90
Appreciate 0
      05-04-2017, 12:20 PM   #20
Masry335i
Private
Masry335i's Avatar
Canada
7
Rep
75
Posts

Drives: E92 335i 6mt
Join Date: Jan 2016
Location: Toronto

iTrader: (0)

Quote:
Originally Posted by Wolf 335 View Post
So what was the root cause of this?

After your curb impact the shop didn't install the nut on the bolt?
I did the repair my self, and took it to two indi shops for inspection and to check out the subframe. They both said it was fine, maybe it wasnt torqued down enough? I have to visit job sites sometimes and find my self going through horrible roads, maybe it got vibrated loose?
Appreciate 0
      05-04-2017, 03:44 PM   #21
Jarrod
Second Lieutenant
United_States
38
Rep
221
Posts

Drives: 2012 E93 335is
Join Date: Nov 2016
Location: SE USA

iTrader: (0)

Quote:
Originally Posted by Masry335i View Post
I did the repair my self, and took it to two indi shops for inspection and to check out the subframe. They both said it was fine, maybe it wasnt torqued down enough?
...Did you use a torque wrench when you put it back together last time?

I learned my lesson on my truck 25 years ago, when the trailer hitch I installed came off on the freeway...while I had a u-haul in tow. I suggest you get a torque wrench.
__________________
Appreciate 0
      05-04-2017, 03:45 PM   #22
justpete
Brigadier General
United_States
688
Rep
3,559
Posts

Drives: '11 328i '16 550i
Join Date: Jan 2012
Location: DFW

iTrader: (0)

Garage List
2011 BMW 328i  [4.33]
2016 BMW 550i  [4.12]
And some Loctite couldn't hurt.
__________________
2011 E90 328i ZSP 6MT, 2960#, BMW Aero, CF hood/boot, PI+CAI+RM+3IM+BPC, SS+CI528+ThermoTec+SS#1+Burns, AKG eng, UUC trans, Delrin diff/RS, CM 850, UCP, CAE, AKG DSSR, DiffsOnline 3.91 30/90 LSD+BW cooler, C&R, Setrab, Accusump, AST 3-way+Swift, all Aurora PR+BW spherical, Vorshlag CPs, M3 brace+UR bar, ARC-8 18x8.5, 255 R1R, RB/CSL rotors, 135i calipers, RS29, RT700, Safecraft, OMP HTE-R+804F+QD Superquadro, 8pt cage+FIA, Braille, RT DL1Mk3
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:45 PM.




e90post
e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST