E90Post
 


GT Haus
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Another P112C question w/ snapshot. HELP



Reply
 
Thread Tools Search this Thread
      01-11-2013, 05:49 AM   #1
schctrg
New Member
0
Rep
23
Posts

 
Drives: e90 325i
Join Date: Mar 2009
Location: socal

iTrader: (0)

Another P112C question w/ snapshot. HELP

Hi please let me know if you can help me.
I have a SES light on after a long drive from vegas. I have random rough idle and the following code pulled from an innova scanner. P112c, heres a freeze frame of when the light went off.

p112c
fuel sys 1 CL
fuel sys 2 CL
calc load(%) 29.4
ECT (F) 203
STFT b1(%) -3.1
LTFT b1(% -6.3
STFT B2(%) .8
LTFT B2(5) -3.1
ENG RPM 1786
VEH SPEED 30MPH
SPARK ADV 37.5
IAT (F) 75
MAF (LB/MIN)2.0
TPS (%) 22.4
Appreciate 0
      01-11-2013, 06:10 AM   #2
VirtuousWolf
Private First Class
3
Rep
144
Posts

 
Drives: 06 BMW 330i SP
Join Date: Sep 2011
Location: Lubbock/Mission Texas

iTrader: (0)

No idea what half of that stuff means. But whenever someone says they got back from a trip and have a problem, possible bad gas comes to mind. Hopefully it's that! Good luck!
Appreciate 0
      01-11-2013, 06:13 AM   #3
schctrg
New Member
0
Rep
23
Posts

 
Drives: e90 325i
Join Date: Mar 2009
Location: socal

iTrader: (0)

hmm. would bad gas do this?
Appreciate 0
      01-11-2013, 06:51 AM   #4
VirtuousWolf
Private First Class
3
Rep
144
Posts

 
Drives: 06 BMW 330i SP
Join Date: Sep 2011
Location: Lubbock/Mission Texas

iTrader: (0)

Well I've never had a problem with the cars I've had, saab or bmw. But my parents have had this issue before with their lexus es. There were two different issues. The first one was when my dad was overfilling the gas tank, he does this thing where he likes to make the total be 42.42, or 51.51, etc. (not sure if it's ocd or if he does it for "security" reasons) Well overfilling it past the point of where the gas pump clicks would give him a check engine light, it took a while for him to figure out what was happening because of depending on the total he would only have to add a little bit of gas, or if he overshot it up to $3's too much. After a while the car would go back to normal.

Other times though though it would have a rough idle if he would put local style gas on road trips. I'm sure someone will chime in and say it all comes from the same place, and it probably does. But I like to go to newer style gas stations with a lot of traffic when I can't find a shell. He just puts whatever in it, lowest grade. But the car did not like the bad gas from those places.

The car is a tank though, 2001 es300 170k miles on it, no maintenance whatsoever, except for oil changes, air filter (like twice), brakes and tires. Lol no coolant change, brake fluid, tranny oil etc. It has had zero problems lol... Like zero it has never gone in for service ever. The car drives like a boat though, super floaty and the worst steering feel I've ever felt. Lol the rear suspension rattles but they don't wanna put anything in to it since they are going to trade it in. I'm trying to convince them to get either an X1 or a 328i.

I'm not a mechanic or anything, but I would say start small get some new premium gas from a nice place land dump some techron in. Oh and maybe clean your maf?

The real smarties on here are gonna want some more info, like the mileage of your car, transmission, spark plug history, etc. So it would probably help if you added that.

Hopefully it's something minor I'm sure all the guru's will chime in once they wake up.

Sorry about the rant haha, too tired to proofread it so sorry if I sound crazy
Appreciate 0
      01-11-2013, 07:47 AM   #5
schctrg
New Member
0
Rep
23
Posts

 
Drives: e90 325i
Join Date: Mar 2009
Location: socal

iTrader: (0)

I should mention I cleaned up the maf already and also measured the resistance all within normal values. Still not sure what's wrong
Appreciate 0
      01-11-2013, 09:35 PM   #6
schctrg
New Member
0
Rep
23
Posts

 
Drives: e90 325i
Join Date: Mar 2009
Location: socal

iTrader: (0)

So the light turned off. Don't worry about it anymore?
Appreciate 0
      01-12-2013, 05:08 AM   #7
VTECaddict
Where'd my VTEC go?
VTECaddict's Avatar
47
Rep
4,625
Posts

 
Drives: 06 330i 6MT
Join Date: Mar 2009
Location: Bakersfield, CA

iTrader: (4)

P112C - O2 Sensor Negative Current or Positive Current Control Circuit/Open (Bank 1 Sensor 1)
__________________
AW/Terra | ZSP | ZPP | ZCW | iDrive | CA
Mods: BC BR | OEM Blacklines | M-tech rear | custom dual exhaust | M3 steering wheel | BMW SSK | ZHP shift knob | BMW Performance rep spoiler
Varrstoen ES1 19x9.5+20 Front, 19x11+25 rear
Appreciate 0
      01-13-2013, 04:38 AM   #8
VirtuousWolf
Private First Class
3
Rep
144
Posts

 
Drives: 06 BMW 330i SP
Join Date: Sep 2011
Location: Lubbock/Mission Texas

iTrader: (0)

Glad it got resolved!!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:05 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST