E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Transmission Problem Help



Reply
 
Thread Tools Search this Thread
      01-14-2013, 03:08 AM   #1
Mattme90
MattM
 
Drives: e90 335i pre-lci
Join Date: Apr 2012
Location: Los Angeles

Posts: 66
iTrader: (0)

Transmission Problem Help

i drive on 08 e90 335i with 6AT transmission. recently i have discovered that there is a problem with my gears while driving. driving in sport mode from 1st to 2nd gear is fine, then 2nd to 3rd is fine, 3rd to 4th is fine, but once it goes from 4th to 5th gear, the car automatically revs high and it gives me the transmission malfunction alert. does anybody know what the problem is here? thanks.
Mattme90 is offline   United_States
0
Reply With Quote
      01-14-2013, 04:22 AM   #2
tinnsoldaten
Captain
 
tinnsoldaten's Avatar
 
Drives: e92 335i coupe
Join Date: Dec 2008
Location: Bergen

Posts: 644
iTrader: (1)

Check you oil level in transmission , sounds like you are low on oil or low oil pressure in transmission.

If the car is tuned , also transmission can be starting to fail.

I had some rev in 5th some while ago , since then I have done a full oil and filter change on engine and transmission and diff. No problems lately.

And run a diagnostic on the car , see what errors you get.
__________________
Vargas S2 turbos|VAC S3 Cylinder head|RR DPs|RR MPs|Supersprint X pipe|Remus Quad Sport mufflers|aFe Stage 2 Si with scoops|Forge DVs|ER CP|BMS meth elbow|Aquamist HFS-4|Walbro 450 E85 LPFP|AA FMIC|BMS OCC|ESS S2|P3 Boost Gauge|JIC CROSS Competition Coilvers|M3 sways F/R+ Ground control endlinks|Vorsteiner v303 19"|Michelin PS2 sport|Quaife LSD|Vorsteiner V35 CF hood|CF CLS trunk|Duke Dynamics quad diffusor
tinnsoldaten is offline   Norway
0
Reply With Quote
      01-15-2013, 07:25 PM   #3
Mattme90
MattM
 
Drives: e90 335i pre-lci
Join Date: Apr 2012
Location: Los Angeles

Posts: 66
iTrader: (0)

bump
Mattme90 is offline   United_States
0
Reply With Quote
      01-15-2013, 10:09 PM   #4
kfrazie1
Lieutenant
 
kfrazie1's Avatar
 
Drives: 335i
Join Date: Aug 2010
Location: NY

Posts: 441
iTrader: (4)

Did you scan the car?
__________________
Montego Blue E90 335i
7" VRSF IC | OFT Tune | DCI | RB PCV | Secondary CAT Delete & CYBA 3.75" Tips | M3 Front | CSL Trunk | 19" LC Dyna Wheels
kfrazie1 is offline  
0
Reply With Quote
      01-15-2013, 10:21 PM   #5
SIKH335
Banned
 
Drives: 2007 335i Coupe
Join Date: May 2011
Location: SF Bay Area

Posts: 969
iTrader: (6)

Garage List
2007 E92 335i  [0.50]
Is this under normal driving or WOT
SIKH335 is offline  
0
Reply With Quote
      01-16-2013, 01:58 AM   #6
Mattme90
MattM
 
Drives: e90 335i pre-lci
Join Date: Apr 2012
Location: Los Angeles

Posts: 66
iTrader: (0)

Quote:
Originally Posted by SIKH335 View Post
Is this under normal driving or WOT
both
Mattme90 is offline   United_States
0
Reply With Quote
      02-05-2013, 11:07 PM   #7
Mattme90
MattM
 
Drives: e90 335i pre-lci
Join Date: Apr 2012
Location: Los Angeles

Posts: 66
iTrader: (0)

bump
Mattme90 is offline   United_States
0
Reply With Quote
      02-07-2013, 11:32 PM   #8
Mattme90
MattM
 
Drives: e90 335i pre-lci
Join Date: Apr 2012
Location: Los Angeles

Posts: 66
iTrader: (0)

Bump please!!
Mattme90 is offline   United_States
0
Reply With Quote
      02-08-2013, 05:46 AM   #9
enrita
Major General
 
enrita's Avatar
 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

Posts: 7,318
iTrader: (0)

you already got a pretty good answer, scan the car ECU/TCU for codes , is it tuned? miles?
__________________
07 335i AT - TD St.2 Turbos - COBB (Custom Cobb mapping by http://www.protuningfreaks.com/) - JB4G5 ISO - Okada Coils - NGK 5992 Plugs - E85 Walbro - Injen Intake - Helix IC - Snow Stg. 3 - Stett CP - AR DPs - midpipes 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - Level 10 AT upgrade - Alpina AT Flash
enrita is offline   Sweden
0
Reply With Quote
      02-08-2013, 08:55 AM   #10
HPF 335i #1
Captain
 
Drives: 2008 E92 335i 6AT
Join Date: Sep 2009
Location: Ft. Riley Kansas

Posts: 880
iTrader: (0)

My first trans did the same thing and it was stock. Few days later its was smoked and i had no gears left. Ive herd A LOT about the 4-5 shift from many others.

There is an issue with it. Ive seen a few threads this. nothing helpful yet...
__________________
FFTEC Single Turbo, HPF FMIC, HPF OCC, HPF Exhaust, KW V1, M3 Front & Rear Roll Bars, M3 Control Arms, Rear Toe Arms, M3 Sub Bushings, WT LSD, VMR 710s, Stop Tech Brakes, AEM Boost Pods, CF Boot Lid, Vented CF Hood, M-Tech Front, Aluminum Pedals, LED Shifter, Mat Black front Grill.
HPF 335i #1 is offline  
0
Reply With Quote
      02-08-2013, 04:10 PM   #11
Tari
Captain
 
Drives: e92 335i
Join Date: Dec 2009
Location: NYC

Posts: 602
iTrader: (0)

make sure your fluids aren't low. The mechatronic seal on our cars leak after a while. Im having mine done next.
Tari is offline  
0
Reply With Quote
      02-19-2013, 11:00 PM   #12
83k
Private First Class
 
83k's Avatar
 
Drives: 2008 335xi
Join Date: Apr 2011
Location: NYC

Posts: 185
iTrader: (1)

I just recently had the same problem.. did you come up with a solution?
83k is offline  
0
Reply With Quote
      02-20-2013, 01:22 AM   #13
Mattme90
MattM
 
Drives: e90 335i pre-lci
Join Date: Apr 2012
Location: Los Angeles

Posts: 66
iTrader: (0)

Quote:
Originally Posted by 83k View Post
I just recently had the same problem.. did you come up with a solution?
i took my car into the dealer and they said it was a battery issue. they replaced my battery but i still have the same issue. no solution so far
Mattme90 is offline   United_States
0
Reply With Quote
      02-20-2013, 02:30 PM   #14
Crazylegs
Lieutenant
 
Crazylegs's Avatar
 
Drives: 08 Black on Red 335I
Join Date: May 2011
Location: South Florida

Posts: 426
iTrader: (1)

Quote:
Originally Posted by Mattme90
Quote:
Originally Posted by 83k View Post
I just recently had the same problem.. did you come up with a solution?
i took my car into the dealer and they said it was a battery issue. they replaced my battery but i still have the same issue. no solution so far
Take it back in to dealer
__________________
AA 3" Downpipes || AA FMIC RACE || AA Charge Pipe BOV || BMS DCI || Vishnu Procede 2.5 || 50/50 E85/93 Stage 3 Maps || Alpina TCU Flash ||
M-Tech Front Bumper + Hamann CF lip || M-Tech Rear Bumper || VMR V701's Powder coated Metallic Bronze 19/8.5/245 19/9.5/275
Crazylegs is offline   United_States
0
Reply With Quote
      02-21-2013, 01:24 AM   #15
Mattme90
MattM
 
Drives: e90 335i pre-lci
Join Date: Apr 2012
Location: Los Angeles

Posts: 66
iTrader: (0)

Quote:
Originally Posted by Crazylegs View Post
Take it back in to dealer
i would if i could get my car to start. my car has been dead for 2 days and ive tried jump starting it but theres no juice in my battery. not even 1 light. and my battery is brand brand new.
Mattme90 is offline   United_States
0
Reply With Quote
      02-26-2013, 02:14 AM   #16
Crazylegs
Lieutenant
 
Crazylegs's Avatar
 
Drives: 08 Black on Red 335I
Join Date: May 2011
Location: South Florida

Posts: 426
iTrader: (1)

alternator?
__________________
AA 3" Downpipes || AA FMIC RACE || AA Charge Pipe BOV || BMS DCI || Vishnu Procede 2.5 || 50/50 E85/93 Stage 3 Maps || Alpina TCU Flash ||
M-Tech Front Bumper + Hamann CF lip || M-Tech Rear Bumper || VMR V701's Powder coated Metallic Bronze 19/8.5/245 19/9.5/275
Crazylegs is offline   United_States
0
Reply With Quote
      02-26-2013, 02:24 AM   #17
Wolf 335
Lieutenant
 
Wolf 335's Avatar
 
Drives: E92 335i
Join Date: Aug 2012
Location: GTA

Posts: 483
iTrader: (0)

If you recently had your Mechatronics seal replaced, electrical connector pins might have gotten damaged if not installed carefully. Bent or broken pin will cause a fault in sport mode.
Wolf 335 is offline   Canada
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:43 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST