E90Post
 


TNT Racewerks
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Transmission Problem Help



Reply
 
Thread Tools Search this Thread
      01-14-2013, 03:08 AM   #1
Mattme90
MattM
United_States
0
Rep
68
Posts

 
Drives: e90 335i pre-lci
Join Date: Apr 2012
Location: Los Angeles

iTrader: (0)

Transmission Problem Help

i drive on 08 e90 335i with 6AT transmission. recently i have discovered that there is a problem with my gears while driving. driving in sport mode from 1st to 2nd gear is fine, then 2nd to 3rd is fine, 3rd to 4th is fine, but once it goes from 4th to 5th gear, the car automatically revs high and it gives me the transmission malfunction alert. does anybody know what the problem is here? thanks.
Appreciate 0
      01-14-2013, 04:22 AM   #2
tinnsoldaten
Captain
tinnsoldaten's Avatar
Norway
6
Rep
685
Posts

 
Drives: e92 335i coupe
Join Date: Dec 2008
Location: Bergen

iTrader: (1)

Check you oil level in transmission , sounds like you are low on oil or low oil pressure in transmission.

If the car is tuned , also transmission can be starting to fail.

I had some rev in 5th some while ago , since then I have done a full oil and filter change on engine and transmission and diff. No problems lately.

And run a diagnostic on the car , see what errors you get.
__________________
Vargas S2 turbos|VAC S3 Cylinder head|RR DPs|RR MPs|Supersprint X pipe|Remus Quad Sport mufflers|aFe Stage 2 Si with scoops|Forge DVs|ER CP|BMS meth elbow|Aquamist HFS-4|Walbro 450 E85 LPFP|AA FMIC|BMS OCC|Cobb stage2+ agressive FMIC LT|P3 Boost Gauge|JIC CROSS Competition Coilvers|M3 sways F/R+ Ground control endlinks|Vorsteiner v303 19"|Michelin PS2 sport|Quaife LSD|Vorsteiner V35 CF hood|CF CLS trunk|Duke Dynamics quad diffusor
Appreciate 0
      01-15-2013, 07:25 PM   #3
Mattme90
MattM
United_States
0
Rep
68
Posts

 
Drives: e90 335i pre-lci
Join Date: Apr 2012
Location: Los Angeles

iTrader: (0)

bump
Appreciate 0
      01-15-2013, 10:09 PM   #4
kfrazie1
Lieutenant
kfrazie1's Avatar
11
Rep
476
Posts

 
Drives: 335i
Join Date: Aug 2010
Location: NY

iTrader: (4)

Did you scan the car?
__________________
Montego Blue E90 335i
7" VRSF IC | OFT Tune | DCI | RB PCV | Secondary CAT Delete & CYBA 3.75" Tips | M3 Front | CSL Trunk | 19" LC Dyna Wheels
Appreciate 0
      01-15-2013, 10:21 PM   #5
SIKH335
Banned
17
Rep
969
Posts

 
Drives: 2007 335i Coupe
Join Date: May 2011
Location: SF Bay Area

iTrader: (6)

Garage List
2007 E92 335i  [0.50]
Is this under normal driving or WOT
Appreciate 0
      01-16-2013, 01:58 AM   #6
Mattme90
MattM
United_States
0
Rep
68
Posts

 
Drives: e90 335i pre-lci
Join Date: Apr 2012
Location: Los Angeles

iTrader: (0)

Quote:
Originally Posted by SIKH335 View Post
Is this under normal driving or WOT
both
Appreciate 0
      02-05-2013, 11:07 PM   #7
Mattme90
MattM
United_States
0
Rep
68
Posts

 
Drives: e90 335i pre-lci
Join Date: Apr 2012
Location: Los Angeles

iTrader: (0)

bump
Appreciate 0
      02-07-2013, 11:32 PM   #8
Mattme90
MattM
United_States
0
Rep
68
Posts

 
Drives: e90 335i pre-lci
Join Date: Apr 2012
Location: Los Angeles

iTrader: (0)

Bump please!!
Appreciate 0
      02-08-2013, 05:46 AM   #9
enrita
Major General
enrita's Avatar
Sweden
94
Rep
7,331
Posts

 
Drives: 335i - Big turbos
Join Date: Sep 2008
Location: Italian in Sweden

iTrader: (0)

you already got a pretty good answer, scan the car ECU/TCU for codes , is it tuned? miles?
__________________
07 335i AT - TD St.2 Turbos - COBB (Custom Cobb mapping by http://www.protuningfreaks.com/) - JB4G5 ISO - Okada Coils - NGK 5992 Plugs - E85 Walbro - Injen Intake - Helix IC - Snow Stg. 3 - Stett CP - AR DPs - midpipes 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - Level 10 AT upgrade - Alpina AT Flash
Appreciate 0
      02-08-2013, 08:55 AM   #10
AYF80
Captain
11
Rep
967
Posts

 
Drives: 2015 AY F80
Join Date: Sep 2009
Location: Nashville, TN

iTrader: (0)

My first trans did the same thing and it was stock. Few days later its was smoked and i had no gears left. Ive herd A LOT about the 4-5 shift from many others.

There is an issue with it. Ive seen a few threads this. nothing helpful yet...
Appreciate 0
      02-08-2013, 04:10 PM   #11
Tari
Captain
11
Rep
602
Posts

 
Drives: e92 335i
Join Date: Dec 2009
Location: NYC

iTrader: (0)

make sure your fluids aren't low. The mechatronic seal on our cars leak after a while. Im having mine done next.
Appreciate 0
      02-19-2013, 11:00 PM   #12
83k
Private First Class
83k's Avatar
1
Rep
185
Posts

 
Drives: 2008 335xi
Join Date: Apr 2011
Location: NYC

iTrader: (1)

I just recently had the same problem.. did you come up with a solution?
Appreciate 0
      02-20-2013, 01:22 AM   #13
Mattme90
MattM
United_States
0
Rep
68
Posts

 
Drives: e90 335i pre-lci
Join Date: Apr 2012
Location: Los Angeles

iTrader: (0)

Quote:
Originally Posted by 83k View Post
I just recently had the same problem.. did you come up with a solution?
i took my car into the dealer and they said it was a battery issue. they replaced my battery but i still have the same issue. no solution so far
Appreciate 0
      02-20-2013, 02:30 PM   #14
Crazylegs
Lieutenant
Crazylegs's Avatar
United_States
5
Rep
434
Posts

 
Drives: 08 Black on Red 335I
Join Date: May 2011
Location: South Florida

iTrader: (1)

Quote:
Originally Posted by Mattme90
Quote:
Originally Posted by 83k View Post
I just recently had the same problem.. did you come up with a solution?
i took my car into the dealer and they said it was a battery issue. they replaced my battery but i still have the same issue. no solution so far
Take it back in to dealer
__________________
2008 Bsm E92 335i - FBO -E85--------Sold

2014 BSM 335i Msport - Stock
Appreciate 0
      02-21-2013, 01:24 AM   #15
Mattme90
MattM
United_States
0
Rep
68
Posts

 
Drives: e90 335i pre-lci
Join Date: Apr 2012
Location: Los Angeles

iTrader: (0)

Quote:
Originally Posted by Crazylegs View Post
Take it back in to dealer
i would if i could get my car to start. my car has been dead for 2 days and ive tried jump starting it but theres no juice in my battery. not even 1 light. and my battery is brand brand new.
Appreciate 0
      02-26-2013, 02:14 AM   #16
Crazylegs
Lieutenant
Crazylegs's Avatar
United_States
5
Rep
434
Posts

 
Drives: 08 Black on Red 335I
Join Date: May 2011
Location: South Florida

iTrader: (1)

alternator?
__________________
2008 Bsm E92 335i - FBO -E85--------Sold

2014 BSM 335i Msport - Stock
Appreciate 0
      02-26-2013, 02:24 AM   #17
Wolf 335
Lieutenant
Wolf 335's Avatar
Canada
7
Rep
551
Posts

 
Drives: E92 335i
Join Date: Aug 2012
Location: GTA

iTrader: (0)

If you recently had your Mechatronics seal replaced, electrical connector pins might have gotten damaged if not installed carefully. Bent or broken pin will cause a fault in sport mode.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:36 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST