E90Post
 


European Auto Source
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > Acceleration Stutter?!



Reply
 
Thread Tools Search this Thread
      01-15-2013, 12:28 PM   #1
ALEXROD89
New Member
0
Rep
9
Posts

 
Drives: 2008 328i
Join Date: Oct 2012
Location: Miami FL

iTrader: (0)

Garage List
2008 328i  [0.00]
Acceleration Stutter?!

I have a 2008 328i e90 sport package 50k...

I have had the car for almost a year i bought it CPO. I have discovered that by driving the car with the paddles all the time i have increased my MPG from 19-20 to 22-23 so the problem i have is...

When my car is on Drive or Sport/paddles and i punch it when its below 1800 rpms the car will stutter when accelerating, once i pass about 1800rpm the cars accelarates perfect with no stutter like the day i bought it.

ive heard from different people that it could be transmission (which scares me) it could be something with the ECU or simply the car is in too high of a gear and im trying to accelerate it too much... the latter although makes sense around 1000rpm but should be the issue when the car is in Drive...

Anyone have a suggestion?
Appreciate 0
      01-15-2013, 01:01 PM   #2
Volasko
Major
Volasko's Avatar
Canada
22
Rep
1,125
Posts

 
Drives: 2006 E90 330i BSM 6MT ZSP
Join Date: Dec 2010
Location: Toronto

iTrader: (2)

Garage List
Honestly.... you should probably take a video to show what you are talking about. I am having a hard time understanding what your problem is. I assume you you aren't talking about the lag when the car downshifts?!?
Appreciate 0
      01-15-2013, 06:17 PM   #3
Phil325i
Major
Phil325i's Avatar
United Kingdom
14
Rep
1,177
Posts

 
Drives: E92 325i MSport Coupe
Join Date: Apr 2012
Location: UK South East

iTrader: (0)

Garage List
Coil pack on the way out? Have you had the ECU read for fault codes?
__________________
E92 pre-LCI 325i - Ohlins R&T; H&R spacers; M3 strut brace; Meyle HD droplinks; BMS clutch stop; BMS CDV; RE g/box mounts; Saikoumichi OCC; K&N; Cyba scoops; BMW Perf Exhaust; M3 rear spoiler; M3 white dash LEDs; LED Angels; BMW Perf black grille; CSL reps; SSDD carbon diffuser; Monster Wrap black roof
Appreciate 0
      01-16-2013, 11:13 AM   #4
ALEXROD89
New Member
0
Rep
9
Posts

 
Drives: 2008 328i
Join Date: Oct 2012
Location: Miami FL

iTrader: (0)

Garage List
2008 328i  [0.00]
Quote:
Originally Posted by Volasko View Post
Honestly.... you should probably take a video to show what you are talking about. I am having a hard time understanding what your problem is. I assume you you aren't talking about the lag when the car downshifts?!?
Ill get video posted
Appreciate 0
      01-17-2013, 01:18 PM   #5
simon
Private First Class
simon's Avatar
United_States
3
Rep
120
Posts

 
Drives: E92 Montego Blue 328i
Join Date: Mar 2005
Location: Atlanta, GA

iTrader: (1)

I had the exact issue with a 2007 328. Low rpms, below about 2000 or so it would stutter during medium to hard acceleration. It almost felt like traction control was blipping in and out for a split second. Regardless, turns out it was a coil pack on the way out.

Simon
Appreciate 0
      01-17-2013, 07:41 PM   #6
r_khiami
Registered
0
Rep
1
Posts

 
Drives: E90 2006
Join Date: Jan 2013
Location: Lebanon

iTrader: (0)

i thought at first it was a problem but noticed it was running on high gear. either you have to press the peddle a little bit more so the trans shifts on its own or just manually shift down the gear.
Appreciate 0
      01-18-2013, 12:09 PM   #7
ALEXROD89
New Member
0
Rep
9
Posts

 
Drives: 2008 328i
Join Date: Oct 2012
Location: Miami FL

iTrader: (0)

Garage List
2008 328i  [0.00]
Quote:
Originally Posted by simon
I had the exact issue with a 2007 328. Low rpms, below about 2000 or so it would stutter during medium to hard acceleration. It almost felt like traction control was blipping in and out for a split second. Regardless, turns out it was a coil pack on the way out.

Simon
That's exactly what happens... how did you fix it? $?
Appreciate 0
      04-26-2013, 05:16 AM   #8
cmascis
Registered
0
Rep
4
Posts

 
Drives: '07 335xi
Join Date: Apr 2013
Location: ma

iTrader: (0)

I have the same exact problem my tech change the solenoid that oils the variable valve timing and that fixed it
Appreciate 0
      04-29-2013, 08:01 PM   #9
thefull9yards
Private
thefull9yards's Avatar
United_States
0
Rep
67
Posts

 
Drives: 2007 Sparkling Graphite 328i
Join Date: Apr 2013
Location: San Francisco, CA

iTrader: (0)

I'm no expert, but it honestly just sounds like you need to downshift first. It automatically downshifts during hard acceleration in automatic mode, and even in shiftronic. Try a hard acceleration from 1st gear and see if the problem persists. Also, if you want to accelerate quickly and your already moving, start the accel from above 2500 rpm for best results.
Appreciate 0
      04-29-2013, 10:50 PM   #10
Delusive
Lieutenant Colonel
Delusive's Avatar
United_States
27
Rep
1,500
Posts

 
Drives: Static E92
Join Date: May 2012
Location: Bay Area, CA

iTrader: (6)

OP when your in manual mode what gear does this usually happen in? I noticed mines started doing this in M2 only during medium acceleration once it gets to around 1,800-2,000 RPM it stutters for a split second then continues on.

I did assume it was either a bad coil pack or spark plug, but didn't know this was happening to others on the forums also.
__________________
Appreciate 0
      04-30-2013, 07:32 AM   #11
Three_thirty_I
Captain
Three_thirty_I's Avatar
South Africa
12
Rep
810
Posts

 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa

iTrader: (0)

Garage List
Quote:
Originally Posted by thefull9yards View Post
I'm no expert, but it honestly just sounds like you need to downshift first. It automatically downshifts during hard acceleration in automatic mode, and even in shiftronic. Try a hard acceleration from 1st gear and see if the problem persists. Also, if you want to accelerate quickly and your already moving, start the accel from above 2500 rpm for best results.
The thing is, this is a known issue with these engines and very annoying when it is the case. Mine for instance would do this the moment you wanted to just quickly accelerate a bit while at a sedate speed - annoying because you expect decent flexibility and tractability from an engine like this, just like the older M54 engines. Now of course all within reason, I am not talking about expecting the engine to respond cleanly and instantly when it is barely ticking over and in a tall gear! But for instance sitting behind slower traffic in 4th gear at around 60 km/h on a level road is not unreasonable to expect the engine to respond cleanly when asked to accelerate, and we are not even talking about mashing the throttle, just a firm foot down on the throttle to go past.

But this varies from car to car and from instance to instance, and I tested it with my car - for instance sitting in 5th gear at 80 km/h level road, foot down and noticeable hesitation/jerk, but then immediately back off for a second or so and then repeat, and no hesitation/jerk. So it's as if the engine was running in some sort of relaxed mode. But I do think that it is most likely the Vanos solenoids that could be causing this if they are slightly clogged or the oil level is a bit low - Vanos relies on good oil pressure and supply!

My driving style over the years has adapted to this hesitation issue so cannot say for sure without actually testing it if cleaning the Vanos solenoids has helped! But it could very well be the case...
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03


Appreciate 0
      04-30-2013, 01:54 PM   #12
BoogeyMan'sBMW
Major
BoogeyMan'sBMW's Avatar
Bangladesh
18
Rep
1,380
Posts

 
Drives: SLOW
Join Date: Jun 2009
Location: Queens NY

iTrader: (3)

The video would definitely help. From the looks of it to me, it can be either of two things.

1: Since there is a sputtering involved, and its proven to be the reason to why some of the above posters had an issue, I would check that first. I had the same issue but it only occured at idle. The difficulty of diagnosing that is that if a coil pack is on its way out, it won't always be problematic. These are like $40 each, you have 6 and the DIY is very simple.

2: It can also be that you are talking about the dead pedal or the lag that we get with our n52s. You can start by resetting the throttle. Since our cars have the adaptive throttle, it may get a little sluggish every now and then. Put the key in, press start (without the foot on the brake) and your dash will light up. Hold down the gas pedal all the way down for 30 sec. I have heard many different things but 30 seconds is the safest bet so just try that and your throttle will be reset.
Appreciate 0
      04-30-2013, 03:50 PM   #13
Beamin
Private First Class
1
Rep
117
Posts

 
Drives: Black 06 330i Sport
Join Date: Apr 2012
Location: Tallahassee

iTrader: (0)

My 06 330 does that. If I am in DS1 and I floor it sometimes nothing happens then after the ringers higher it kicks in. It's terrible
Appreciate 0
      04-30-2013, 04:00 PM   #14
MrDummy
→сяuisiиg iи му вмш←
MrDummy's Avatar
United_States
27
Rep
1,643
Posts

 
Drives: 2010 Space Gray 328i
Join Date: May 2009
Location: The Unemployment Capitol of America

iTrader: (1)

Garage List
2010 BMW 328i  [0.00]
I'm having this same issue again, I've reset before and it seemed to work, but when I took in for service back in Jan, the tech said there's an update for this issue.

Solved it for a few days then it went back to sluggishness response...

I Will bring this up on Thursdays appt, if I can get a confirmation I still have an appt?

MrD
Appreciate 0
      05-03-2013, 09:38 PM   #15
MrDummy
→сяuisiиg iи му вмш←
MrDummy's Avatar
United_States
27
Rep
1,643
Posts

 
Drives: 2010 Space Gray 328i
Join Date: May 2009
Location: The Unemployment Capitol of America

iTrader: (1)

Garage List
2010 BMW 328i  [0.00]
Well after a bunch of shyt from dealers, I got an appt date for the 22nd, so I will see what's up then...about getting another software update.
Appreciate 1
      05-06-2013, 06:01 PM   #16
Three_thirty_I
Captain
Three_thirty_I's Avatar
South Africa
12
Rep
810
Posts

 
Drives: '05 E90 330i Manual
Join Date: Aug 2010
Location: Cape Town, South Africa

iTrader: (0)

Garage List
Keep us posted!
__________________
BMW E90 330i (M) '05 (His) | (Hers) BMW E46 320i f/l (M) '03


Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:03 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST