E90Post
 


 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > NA Engine (non-turbo) / Drivetrain / Exhaust Modifications > My Steptronic won't upshift!



Reply
 
Thread Tools Search this Thread
      01-22-2013, 02:12 AM   #1
Tsaoster
Private
 
Drives: 2008 BMW with Premium Pkg
Join Date: Oct 2011
Location: Vancouver

Posts: 67
iTrader: (0)

Exclamation My Steptronic won't upshift!

Hey guys, on my way to work today I tried to go into manual mode and i was going upshift and realized that the car didn't do anything. The car will down shift and go into DS without a problem. I have no idea what is happening.

I have an 08 323i, any help is appreciated!
Tsaoster is offline  
0
Reply With Quote
      01-22-2013, 02:25 AM   #2
JDane07
Major
 
JDane07's Avatar
 
Drives: '06 E90 330i
Join Date: Nov 2011
Location: Napa, CA

Posts: 1,394
iTrader: (2)

Quote:
Originally Posted by Tsaoster View Post
Hey guys, on my way to work today I tried to go into manual mode and i was going upshift and realized that the car didn't do anything. The car will down shift and go into DS without a problem. I have no idea what is happening.

I have an 08 323i, any help is appreciated!
Hmmm sometimes the wires underneath the shifter can become a little tangled and cramped, so maybe look under and see if everything looks ordinary.

I had a somewhat similar issue, except both DS and manual mode would refuse to engage, and even the little orange light on the shifter was out.
Cost a nice $1100 to fix
__________________
OEM Mtech | AG M580 | Performance Exhaust | AA Tune | ST Coilovers | MMW Catless Headers | Euro BavX LS3 | Blacklines | CF diffuser, Performance Spoiler, Front splitters | Other goodies here and there...
Wish List: ESS SUPERCHARGER FTW
Recent Thread: http://www.e90post.com/forums/showth...NE07+vineyards
JDane07 is offline   United_States
0
Reply With Quote
      01-22-2013, 02:31 AM   #3
Tsaoster
Private
 
Drives: 2008 BMW with Premium Pkg
Join Date: Oct 2011
Location: Vancouver

Posts: 67
iTrader: (0)

yeah i just checked under the shift boot and every things seems in tact. man if it costs 1100 for me to upshift, i don't think it'll be worth it haha, good thing ds still works...

thanks tho, very fast response XD



Quote:
Originally Posted by JDane07 View Post
Hmmm sometimes the wires underneath the shifter can become a little tangled and cramped, so maybe look under and see if everything looks ordinary.

I had a somewhat similar issue, except both DS and manual mode would refuse to engage, and even the little orange light on the shifter was out.
Cost a nice $1100 to fix
Tsaoster is offline  
0
Reply With Quote
      01-24-2013, 08:40 PM   #4
mlifxs
Diamond Geezer
 
mlifxs's Avatar
 
Drives: Jet Black 2007 328i Saloon
Join Date: Nov 2007
Location: Florida

Posts: 1,601
iTrader: (0)

Garage List
check out this DIY.
http://www.e90post.com/forums/showth...=511799&page=2
It might help you investigate further, in case you missed anything.
I had a similar problem and found a very small wire was broken. Patched the wire, fixed.
May not be your cure but might be worth checking about before shelling out big $$
mlifxs is offline  
0
Reply With Quote
      01-24-2013, 08:57 PM   #5
Johnny D
Major
 
Johnny D's Avatar
 
Drives: 2006 BMW 325i
Join Date: Apr 2011
Location: Hot Springs, AR

Posts: 1,124
iTrader: (4)

Garage List
2006 BMW 325i  [4.58]
You have a cut wire. You didn't look hard enough. Take it apart and you'll find it.
__________________
Johnny D is offline  
0
Reply With Quote
      01-26-2013, 04:28 AM   #6
vfeng
Captain
 
vfeng's Avatar
 
Drives: E90 335i
Join Date: Mar 2009
Location: Norcal

Posts: 932
iTrader: (16)

Garage List
2008 E90 335i  [4.50]
Quote:
Originally Posted by Johnny D
You have a cut wire. You didn't look hard enough. Take it apart and you'll find it.
+1 i had the same problem and it was due to a cut wire and another wiring almost falling apart. You can try connecting the wire back together but I just got a new shifter assembly off the forums and swapped it and now its all good. Ebay may have a couple shifter assemblies for a reasonable price if youre looking to replace it
__________________
E90 335i Black Sapphire | M-Tech | LTBMW | Vorsteiner | AE | AR | KW | STETT | VRSF| Duke Dynamics | Volk | Blacklines | BavarianX LS3 | Philips 6000K | OpenFlash | BLOX
vfeng is offline   United_States
0
Reply With Quote
      01-27-2013, 04:54 PM   #7
Tsaoster
Private
 
Drives: 2008 BMW with Premium Pkg
Join Date: Oct 2011
Location: Vancouver

Posts: 67
iTrader: (0)

Thanks guys I'll definitely check our the wires more thoroughly!

Cheers
Tsaoster is offline  
0
Reply With Quote
      01-27-2013, 09:15 PM   #8
xxxjecxxx
Captain
 
xxxjecxxx's Avatar
 
Drives: Jet Black 06 325i LCI
Join Date: Aug 2009
Location: Orlando, FL

Posts: 746
iTrader: (1)

Dont replace the shifter assembly. I did that only to find out it was the wires. You have to take off the tape that's around the wires and you will see which ones are damaged. Total cost = $2 electrical tape
xxxjecxxx is offline  
0
Reply With Quote
      01-30-2013, 09:57 PM   #9
woodpecka
Captain
 
woodpecka's Avatar
 
Drives: E91
Join Date: May 2010
Location: Montreal

Posts: 997
iTrader: (2)

Idem here. Got a cut wire and same symptoms.
woodpecka is offline   Canada
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:29 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST