E90Post
 


GTB Performance
 
BMW 3-Series (E90 E92) Forum > BMW E90/E92/E93 3-series General Forums > General E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio > vehicle electronics failure?



Reply
 
Thread Tools Search this Thread
      09-21-2013, 05:52 PM   #1
alexx03
Lieutenant
4
Rep
426
Posts

 
Drives: 2007 BMW 335I
Join Date: Jun 2012
Location: Vaughan

iTrader: (2)

vehicle electronics failure?

so i was driving today and the ABS light,DSC light(as if you were holding it tho,all systems off) and the light that comes on when you raise your e-brake came on in yellow.(6MT)
i got to a friends house and checked the manual and it says vehicle electronics failure....
the weird thing is that it all keeps going on and off, it did it like 4-5 times now.

i tried to search up something but i got mixed solutions. 1 thread said they unplugged the battery for 20 minutes and all was good, another said it was a rear wheel bearing that has some sensors on it,another said they had to replace the entire battery and the worst story was one about some 2400$ ABS pump!!
any help would be greatly appreciated!
i just lowered my car on BC coilovers and got an alignment yesterday if that helps.
thanks!!
Appreciate 0
      09-21-2013, 05:56 PM   #2
alexx03
Lieutenant
4
Rep
426
Posts

 
Drives: 2007 BMW 335I
Join Date: Jun 2012
Location: Vaughan

iTrader: (2)

car is an 07 335i e92 FBO JB4 just in case it helps.
Appreciate 0
      09-21-2013, 06:54 PM   #3
alexx03
Lieutenant
4
Rep
426
Posts

 
Drives: 2007 BMW 335I
Join Date: Jun 2012
Location: Vaughan

iTrader: (2)

now im confused....in the manual it says when you have a red car on a lift and then the ABS light,DSC light(as if you were holding it tho,all systems off) and the light that comes on when you raise your e-brake came on in yellow(6MT) on your dash it is vehicle electronics failure.

but then it also says when you have the ABS light on where the red car on the lift would be with the ABS light,DSC light(as if you were holding it tho,all systems off) and the light that comes on when you raise your e-brake came on in yellow(6MT) BUT ALSO the flat tire monitor light comes up on the dash that it could be driver stability control systems including ABS,Xdrive, and flat tire monitor have failed.

the problem is that the exact configuration of lights i have on is not in the manual, i have the ABS light in the center screen(where the red cor on lift would be) and on the dash i only have ABS,DSC light(all functions off symbol,circle and triangle with !) and the e-brake light in yellow. no flat tire monitor light. the flat tire monitor light only shows up when i go through the check control menu with the BC stalk on the left side.

im seriously confused now,sorry for the long ass posts but im trying to give the best detail possible so i can get some help and try myself before going to a shop or worst the STEALERship
Appreciate 0
      09-21-2013, 07:17 PM   #4
VTECaddict
Where'd my VTEC go?
VTECaddict's Avatar
47
Rep
4,625
Posts

 
Drives: 06 330i 6MT
Join Date: Mar 2009
Location: Bakersfield, CA

iTrader: (4)

Get codes read would be the only way to get a definitive answer unless you want to start throwing money at it randomly.

Battery can cause weird electrical gremlins too. How old is your battery? If it's the original, it's probably on its last legs anyways so you might as well start with a new one.
__________________
AW/Terra | ZSP | ZPP | ZCW | iDrive | CA
Mods: BC BR | OEM Blacklines | M-tech rear | custom dual exhaust | M3 steering wheel | BMW SSK | ZHP shift knob | BMW Performance rep spoiler
Varrstoen ES1 19x9.5+20 Front, 19x11+25 rear
Appreciate 0
      09-21-2013, 07:31 PM   #5
triger716
Second Lieutenant
3
Rep
295
Posts

 
Drives: '09 335i E90
Join Date: Nov 2011
Location: United States

iTrader: (0)

It could be the steering angle sensor is going bad.

As stated above get the codes read to make sure.
Appreciate 0
      09-21-2013, 07:38 PM   #6
Groganrocket
Second Lieutenant
2
Rep
225
Posts

 
Drives: 2010 e90 335i
Join Date: Jun 2010
Location: Area 57

iTrader: (0)

I had abs dcs and start assit inactive it turned out to be rear speed sensor
Appreciate 0
      09-21-2013, 07:48 PM   #7
alexx03
Lieutenant
4
Rep
426
Posts

 
Drives: 2007 BMW 335I
Join Date: Jun 2012
Location: Vaughan

iTrader: (2)

no codes guys that was the first thing i checked for and yes the battery is the original from an 01/07 build date
Appreciate 0
      09-21-2013, 07:51 PM   #8
dazzabb
New Member
Thailand
0
Rep
26
Posts

 
Drives: 2011 M3 E92, 2006 330i E90
Join Date: Jun 2013
Location: Thailand

iTrader: (1)

There are some weird relationships between electronics in these cars for sure!

I had DSC, ABS and FTM come on 2 days ago, it was a faulty left wheel ABS sensor.

ABS sensor failure seems to be the cause of a lot of unexpected warning lights so I would begin there.

I too read the threads about failure of the ABS pump and $2,500+ for replacement, that goodness it wasn't that!

Good luck.
Appreciate 0
      09-21-2013, 08:04 PM   #9
alexx03
Lieutenant
4
Rep
426
Posts

 
Drives: 2007 BMW 335I
Join Date: Jun 2012
Location: Vaughan

iTrader: (2)

Quote:
Originally Posted by dazzabb View Post
There are some weird relationships between electronics in these cars for sure!

I had DSC, ABS and FTM come on 2 days ago, it was a faulty left wheel ABS sensor.

ABS sensor failure seems to be the cause of a lot of unexpected warning lights so I would begin there.

I too read the threads about failure of the ABS pump and $2,500+ for replacement, that goodness it wasn't that!

Good luck.
ok kool thanks man
so ill check battery voltage first and then wheel bearings!
Appreciate 0
      09-21-2013, 11:45 PM   #10
saini7
Private
1
Rep
70
Posts

 
Drives: 07 335i sedan.
Join Date: Mar 2011
Location: Calgary

iTrader: (1)

hey i just lowered my car as well and had these lights come on before i got a chance to take it in for alignment. after alignment about 70-100km the lights went away, its been 3 months now and i havent had an issue .
Appreciate 0
      09-22-2013, 12:07 AM   #11
VTECaddict
Where'd my VTEC go?
VTECaddict's Avatar
47
Rep
4,625
Posts

 
Drives: 06 330i 6MT
Join Date: Mar 2009
Location: Bakersfield, CA

iTrader: (4)

Quote:
Originally Posted by alexx03 View Post
no codes guys that was the first thing i checked for and yes the battery is the original from an 01/07 build date
You need something like INPA to scan the other modules for errors. It won't show with a normal ODBII scan tool.
__________________
AW/Terra | ZSP | ZPP | ZCW | iDrive | CA
Mods: BC BR | OEM Blacklines | M-tech rear | custom dual exhaust | M3 steering wheel | BMW SSK | ZHP shift knob | BMW Performance rep spoiler
Varrstoen ES1 19x9.5+20 Front, 19x11+25 rear
Appreciate 0
      09-22-2013, 12:28 AM   #12
kurtural
Private First Class
kurtural's Avatar
United_States
3
Rep
117
Posts

 
Drives: 2006 325i, 2006 X3, 2006 525i
Join Date: Jun 2009
Location: Fresno, CA

iTrader: (0)

If you are on the original battery it is going out. Your car is six years old. Time to get a new battery.
Appreciate 0
      09-22-2013, 12:36 AM   #13
alexx03
Lieutenant
4
Rep
426
Posts

 
Drives: 2007 BMW 335I
Join Date: Jun 2012
Location: Vaughan

iTrader: (2)

Quote:
Originally Posted by VTECaddict View Post
You need something like INPA to scan the other modules for errors. It won't show with a normal ODBII scan tool.
okay thank you for the information
Appreciate 0
      09-23-2013, 11:00 PM   #14
alexx03
Lieutenant
4
Rep
426
Posts

 
Drives: 2007 BMW 335I
Join Date: Jun 2012
Location: Vaughan

iTrader: (2)

front right speed sensor was gone,thanks everyone!
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:42 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST