E90Post
 


MINHS Auto Care Center
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Powertrain and Drivetrain Discussions > N54 Turbo Engine / Drivetrain / Exhaust Modifications - 335i > Jb4 Shifting Fail



Reply
 
Thread Tools Search this Thread
      03-03-2014, 05:56 PM   #1
e92stealth
New Member
 
e92stealth's Avatar
 
Drives: e92 335i Premium, Sport, Nav,
Join Date: Feb 2013
Location: United States

Posts: 18
iTrader: (0)

Garage List
09 e92 335  [2.75]
Jb4 Shifting Fail

Greetings,

I've had the Jb4 G5 installed in my car for a solid year. Only problem I had during that time was a coil went out, fixed it and the car continued pulling like a monster.

About a month ago, I started hitting a rev limiter time thing, when in drive sport and gunning it around the city. It's almost like it hits a wall and instead of shifting hard into the next gear, it drops back and loses power.

Another coil went out soon after I was having these problems. Coil replaced. A couple days later, after pulling good no issues, bam it happens again when I installed downpipes. Except this time, coil seems to be hanging on because after car shook at stoplight, I took off and it seemed to auto repair itself. Drove around 7 days with no shaking, but a noticeable loss of power and hesitation at WOT or even 1/2 WOT.

So, I bought all new coils and spark plugs. Replaced everything today. Car pulls good again, but it's hitting that wall and I feel it's only a matter of time before this pattern repeats itself.

Have I accidentally triggered a shifting scenario by hitting the wrong buttons inside my Jb4. I don't think it happens when jb4 is off.

Map 2 does it harder than map 5, but both are basically showing the same symptoms.

Anyone know what is going on? No codes are thrown when it happens, so there is nothing to read.

I just ordered the BMS USB cable, so I can't check logs yet.

Is there anything I am missing right now?
__________________

//JB4 G5//FORMULA ONE CERAMIC//BMS DROP IN//SPORT//PREMIUM//NAV//PASSPORT MAX//RIP LUX BECAUSE THEY SUCK ASS
e92stealth is offline  
0
Reply With Quote
      03-03-2014, 06:09 PM   #2
zeel
Lieutenant
 
Drives: 08 AW e92 335i
Join Date: Nov 2010
Location: MD/NOVA/DC

Posts: 580
iTrader: (2)

Garage List
Its probably not jb4 related. You'll have to wait till you can read the codes until we can give you any advice.
__________________
11.76 @ 124mph (123.9) full weight/street tires/no meth.
zeel is offline  
0
Reply With Quote
      03-03-2014, 07:20 PM   #3
Ingeniator
Captain
 
Ingeniator's Avatar
 
Drives: 07 335XI(90) 09 135I(82)
Join Date: Nov 2013
Location: Fort Mac, Alberta

Posts: 946
iTrader: (1)

Quote:
Originally Posted by e92stealth View Post
Greetings,

I've had the Jb4 G5 installed in my car for a solid year. Only problem I had during that time was a coil went out, fixed it and the car continued pulling like a monster.

About a month ago, I started hitting a rev limiter time thing, when in drive sport and gunning it around the city. It's almost like it hits a wall and instead of shifting hard into the next gear, it drops back and loses power.

Another coil went out soon after I was having these problems. Coil replaced. A couple days later, after pulling good no issues, bam it happens again when I installed downpipes. Except this time, coil seems to be hanging on because after car shook at stoplight, I took off and it seemed to auto repair itself. Drove around 7 days with no shaking, but a noticeable loss of power and hesitation at WOT or even 1/2 WOT.

So, I bought all new coils and spark plugs. Replaced everything today. Car pulls good again, but it's hitting that wall and I feel it's only a matter of time before this pattern repeats itself.

Have I accidentally triggered a shifting scenario by hitting the wrong buttons inside my Jb4. I don't think it happens when jb4 is off.

Map 2 does it harder than map 5, but both are basically showing the same symptoms.

Anyone know what is going on? No codes are thrown when it happens, so there is nothing to read.

I just ordered the BMS USB cable, so I can't check logs yet.

Is there anything I am missing right now?
Check JB4 when you go to speedo 1 does it show 3 on the tack? If so auto clear is on. ou won't keep codes in that way. Not sure about the shifting thing that is likely TCU related. Do you have the Alpina flash?
__________________
07 335XI (A008006) 6AT ~94K miles JB4 G5 ISO VSRF DP's
09 135I M (VK80379) 6MT. Race Project car.
2) Install Cobb/piggyback? and JRZ suspension. 3) Build parrallel HPFP and highflow intake manifold with multi-port fuel and meth. 4) Build full cage and staged twin setup with turbochargers. HTA3076R (tial.82 or Garret divided 1.01)/ HTA4205R (tial 1.16)
Ingeniator is offline   Canada
0
Reply With Quote
      03-03-2014, 11:53 PM   #4
mike@x-ph.com
BimmerPost Supporting Vendor

 
mike@x-ph.com's Avatar
 
Drives: 2007 e92 335i
Join Date: Sep 2013
Location: Las Vegas

Posts: 9,550
iTrader: (2)

I do not think it is JB4 related. In any case contact Terry he will help you figure it out
__________________
Active Autowerke Group Buys (Pm Me For Prices)
N54/N55 E9x Intercooler||E9x 328 Exhaust||F30 328 Dual Tip Exhaust||F30/F32 335/435 Exhaust
Super Bright LED Angel Eyes 99$||Sale On Evolution Racewerks||Amazing Deals On VRSF Products||Burger Motorsports Products
WWW.EXTREMEPOWERHOUSE.COM|| Facebook Page||Android Free App
mike@x-ph.com is offline   United_States
0
Reply With Quote
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:30 PM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST