E90Post
 


GetBMWParts
 
BMW 3-Series (E90 E92) Forum > E90 / E92 / E93 3-series Technical Forums > AUDIO/VIDEO + BLUETOOTH + Electronics/Alarm/Software > How to begin MOST diagnosis? (no stereo, yes to door ding)



Reply
 
Thread Tools Search this Thread
      08-11-2015, 06:53 PM   #1
cipher982
Private
United_States
0
Rep
78
Posts

Drives: 07 335i
Join Date: Dec 2013
Location: Birmingham, AL

iTrader: (0)

How to begin MOST diagnosis? (no stereo, yes to door ding)

About a week ago I started having a hissing sound when using AUX cable, figured cable was bad. But then yesterday it started when using my USB drive plugged into center console. Then this morning it began making noises like R2D2 being murdered, after about 10 seconds of which I no longer have any stereo output.

2007 e93 335i with L7 system. At first my searches said that it is likely the amp, and to replace it or re-code to hifi and change the amp. But I have also read that if I have other noises, such as the door gong, the amp works. And I do have the door gong whenever I get out of the car. Also, the SOS Call Malfunction warning popped up on iDrive a couple times and then went away.

So I assume something in the MOST system is causing this error, are there any specific tests to begin diagnosis, can I pull the amp and check resistances?

Thanks in advance for any help!
Appreciate 0
      08-11-2015, 08:58 PM   #2
Rickygst
Second Lieutenant
7
Rep
231
Posts

Drives: 335i
Join Date: Jun 2010
Location: Atlanta

iTrader: (5)

I think the first step is to get the codes and go from there.
Appreciate 0
      08-11-2015, 09:52 PM   #3
ctuna
Major General
360
Rep
7,214
Posts

Drives: 325xi 06 wagon MT
Join Date: Jan 2010
Location: Santa Cruz, Ca

iTrader: (0)

Did you check for water in the amp area.

Did you check for water in the amp area.
It one of the most common causes for failure.

Early cars had a speaker under the dash for some of the
alarms . I think only PDC sounds came through the stereo
on those.

A most jumper is used to bypass individual most modules
for troubleshooting.
Appreciate 0
      08-11-2015, 11:17 PM   #4
cipher982
Private
United_States
0
Rep
78
Posts

Drives: 07 335i
Join Date: Dec 2013
Location: Birmingham, AL

iTrader: (0)

I did a quick check for water earlier and didn't notice anything, but it did rain a whole lot the night before so that's possible. I go back out this evening and now everything works: Stereo, SOS Call, etc. . . So hopefully not all hope is lost and maybe there's just a poor connection somewhere. I ordered an INPA cable also so I can better get a read on the car.
Appreciate 0
      08-12-2015, 05:18 AM   #5
ptpending
Major
58
Rep
1,000
Posts

Drives: e91
Join Date: Dec 2013
Location: vilnius

iTrader: (0)

if you have usb audio fault, sos call error or malfunction and have sound then your car have mulf2high and tcu and mulf2high dies or dead already
you need to trace mulf2high circuit to most concentrator under left side of rear backrest and remove it from loop, or loop most wires at mulf2high
__________________
E91 2006. Retrofits:High beam assistant, Individual Audio, Autodim mirrors, CIC, Combox(USB and Bluetooth), Electric Sport Seats, Light package, Front PDC, Heated Steering Wheel, Happy Robot, Climate Comfort Windscreen, Blackline rear lights.
Appreciate 0
Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:45 AM.




e90post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST